Results 1 to 6 of 6

Thread: Cricket Internet Settings For HTC Touch??

  1. #1
    Join Date
    May 2008
    Location
    Tulsa
    Posts
    27
    Phone
    HTC 6900
    Carrier
    Cricket
    Feedback Score
    0

    Cricket Internet Settings For HTC Touch??

    so im new...(matter fact i just registered today) and im sure there is already a thread so if a mod see's this if you send me in the right direction you can delete this thread...but here is my dillema....so i bought this touch...(i work for sprint!! lol)...but i owe them money so cricket is the way to go...so at first i was happy with only being able to use voice and sms...but i started hearing rumors that you could get the net to work....so thats where this site comes in...so when i do a ##data on my phone all the settings are wipped out....what the hell do i put in there?...does cricket have a user name and password?....primary and secondary hha ip?...i saw somthing about wap....any way..im rambling....can anyone send me in the righ direction?

  2. #2
    Join Date
    May 2008
    Location
    Tulsa
    Posts
    27
    Phone
    HTC 6900
    Carrier
    Cricket
    Feedback Score
    0
    up...dang not even a point in the right direction?....ive done the work on my end...i searched and searched and i know i need to set up a proxy server connection and input the cricket wap settings but i dont know the domain and when i leave the domain black it doesnt work...and i think my phone is still trying to connect to sprint internet...ionno...how do i change it?....helpppppp!!!!!...please!!

  3. #3
    Join Date
    Feb 2006
    Location
    USA
    Posts
    1,011
    Carrier
    AT&T
    Feedback Score
    0
    Try the network wizard from HTC. You can get it at xda-developers.com

  4. #4
    Join Date
    May 2008
    Location
    Tulsa
    Posts
    27
    Phone
    HTC 6900
    Carrier
    Cricket
    Feedback Score
    0
    thnx!!...ima look into that now

  5. #5
    Join Date
    Feb 2009
    Posts
    3
    Feedback Score
    0
    Post by Sam Sinister:

    Recently, I purchased a HTC Touch Diamond that was supposedly fully flashed to cricket using the ToO’s ROM (But I’m sure they will work on other ROM’s). My internet was working but my MMS was not working at all like they said they would and after they charged me $65.00 but after completing the steps in this document, I had no problem but I could only confirm that I could send have not tried to receive yet.

    This is using Arcsoft MMs_5_0_31_16 on ToO’s Cricket Diamond edition ROM but could work for you as well. Please follow these steps carefully and one by one in my case the phone was already flashed but the MMS didn’t work.

    HKLM\Software\Arcsoft\Arcsoft MMS UA\Config\MM1 Default Setting Cricket MMS and Change WAP default Port 1&2 to 8080 and WAP Default Time Out to 10000

    HKLM\Software\Arcsoft\Arcsoft MMS UA\Config\MM1\MMSCSetting\Cricket MMS Ensure Gateway Port is 8080, ISP is Cricket MMS, MmscURI is set to http://mms.mycricket.com/servlets/mms , Name is Cricket MMS, Ensure the next 4 settings WAP1RecvDefault Size, WAP1Send WAP2 Recv and WAP2 Send are set to 1024000, WAPType to 1 (WAPType to 1 Ensures WAP 2.0) also make sure that you check the following settings as well; Configurable is set to 1, ConnectionVia is set to {0789CC17-B679-D3F5-73CD-8AD4CB9, and PacketSize is 1000.
    HKLM\Software\Arcsoft\Arcsoft MMS UA\Config\MM1\MMSCSetting\Cricket MMS\WspHeader
    Accept: application/vnd.wap.multipart.related
    X-Cricket-MDN this is your 10digit cell number (this might say X-Verizon or X-Sprint Change the value name to X-Cricket-MDN) Value Data 555-xxx-xxxx, of course put in your own phone number no dashes.
    HKLM\Software\Arcsoft\Arcsoft MMS UA\Config\MM1\MMSCSetting\WspHeader\
    Domain http://mms.mycricket.com/servlets/mms
    SizeLimit WAP1RecvLimit 1,2,3 set everything on that page to 1024000 (this is part of your 1000K send and receive limit)

    The setting below was not available on my phone so I skipped it but if it is on yours please make sure you change it:
    HKLM /software/arcsoft mms ua/config/UI
    find EnableServerEdit and change it from 0 to 1



    Again the setting below was not available on my phone so I skipped it but make sure that you double check to see if you have this string and deleted it:
    HKCU\Software\Microsoft\Windows\CurrentVersion\Int ernet Settings Where it says Connections, Delete that entire string Hold down stylus on Connections circles it and delete it; this is what keeps the MMS from sending. Bad thing is every time you open explorer it re-writes this registry. To solve that many of us have just used something else besides Explorer. Like Opera, Firefox Mobile or Skyfire.
    You can still use these browsers without writing the Connections Value. If you don’t want to use anything but Explorer, you are going to have to go into this registry file and delete the Connections string every time to send MMS or until someone comes up with a registry hack to Auto delete this value every time you close IE …Close Regedit.

    Now go to your messages and click menu/MMS options and then click server and click add new. Add new or if you already have one called something else just click it and click edit...you need to change these settings to

    Server Name: Cricket
    Gateway leave: blank
    Port Number: 8080
    Server address: http://mms.mycricket.com/servlets/mms
    Connect Via Cricket: MMS

    Double check your settings:
    Sending limit (should be 1024000 if you changed these settings correctly in regedit)
    Wap version Wap 2.0 (Wap 2.0 should be pre selected, if it is don’t touch it. If it keeps reverting back to 1.2 when you click close? Go back into regedit and select WAPType 1 as mentioned previously, this forces it into WAP 2.0 without it MMS won’t work.) Now if you have more than 1 select the cricket one you just configured and hit set as default then go back to HKLM\Software\Arcsoft\Arcsoft MMS UA\Config\MM1\MMSCSetting\Cricket MMS and delete the other configuration, when you go back into settings Cricket should be the only one there and it should be default.

    The settings below are only if you are setting up MMS for the first time on partially flashed without MMS. Remember my phone was already flashed.

    Start\Settings\Connections\Connections Under the General Tab Enter Cricket. Under the Modem Tab put in Cricket Mobile Web select modem to cellular line. Click next put in #777 to dial to Cricket, click next… User Name: your10digitcellnumber@mycricket.com Password: cricket Domain: Leave Blank, click finish…under proxy settings, check these 2 boxes (this network connects to the internet, and this network uses a proxy server to connect to the internet) Proxy Server: wap.mycricket.com click advanced. The only thing with a value should be HTTP wap.mycricket.com:8080 the rest blank if your MMS still doesn’t work click on start/settings/ connections/connections/ then click on edit my proxy server then click on Advanced, click on WAP and set to wap.mycricket.com. Port 8080 and do the same for Secure WAP & Socks. Click ok and ok again, this ok should bring you back to the connections screen at the bottom click advanced. Click select networks. Under both drop downs select Cricket. Click Ok Go into Exceptions Click add new URL for each of the following settings you are going to need to click add new url again, these don’t all go under one “Add new URL” Block

    mms.mycricket.com/servlets/mms
    .mms.mycricket.com/servlets/mms
    mycricket.com/
    .mycricket.com/
    .mms.mycricket.com/
    mms.mycricket.com/

    And there you go; good luck and all the stores I went to help for wanted to charge me anywhere from $50 to $80 to re-flash it, ha, ha, ha,

  6. #6
    Join Date
    Feb 2009
    Posts
    3
    Feedback Score
    0

    Talking !!!! Update !!!!

    Quote Originally Posted by djsoss
    Post by Sam Sinister:

    Recently, I purchased a HTC Touch Diamond that was supposedly fully flashed to cricket using the ToO’s ROM (But I’m sure they will work on other ROM’s). My internet was working but my MMS was not working at all like they said they would and after they charged me $65.00 but after completing the steps in this document, I had no problem but I could only confirm that I could send have not tried to receive yet.

    This is using Arcsoft MMs_5_0_31_16 on ToO’s Cricket Diamond edition ROM but could work for you as well. Please follow these steps carefully and one by one in my case the phone was already flashed but the MMS didn’t work.

    HKLM\Software\Arcsoft\Arcsoft MMS UA\Config\MM1 Default Setting Cricket MMS and Change WAP default Port 1&2 to 8080 and WAP Default Time Out to 10000

    HKLM\Software\Arcsoft\Arcsoft MMS UA\Config\MM1\MMSCSetting\Cricket MMS Ensure Gateway Port is 8080, ISP is Cricket MMS, MmscURI is set to http://mms.mycricket.com/servlets/mms , Name is Cricket MMS, Ensure the next 4 settings WAP1RecvDefault Size, WAP1Send WAP2 Recv and WAP2 Send are set to 1024000, WAPType to 1 (WAPType to 1 Ensures WAP 2.0) also make sure that you check the following settings as well; Configurable is set to 1, ConnectionVia is set to {0789CC17-B679-D3F5-73CD-8AD4CB9, and PacketSize is 1000.
    HKLM\Software\Arcsoft\Arcsoft MMS UA\Config\MM1\MMSCSetting\Cricket MMS\WspHeader
    Accept: application/vnd.wap.multipart.related
    X-Cricket-MDN this is your 10digit cell number (this might say X-Verizon or X-Sprint Change the value name to X-Cricket-MDN) Value Data 555-xxx-xxxx, of course put in your own phone number no dashes.
    HKLM\Software\Arcsoft\Arcsoft MMS UA\Config\MM1\MMSCSetting\WspHeader\
    Domain http://mms.mycricket.com/servlets/mms
    SizeLimit WAP1RecvLimit 1,2,3 set everything on that page to 1024000 (this is part of your 1000K send and receive limit)

    The setting below was not available on my phone so I skipped it but if it is on yours please make sure you change it:
    HKLM /software/arcsoft mms ua/config/UI
    find EnableServerEdit and change it from 0 to 1



    Again the setting below was not available on my phone so I skipped it but make sure that you double check to see if you have this string and deleted it:
    HKCU\Software\Microsoft\Windows\CurrentVersion\Int ernet Settings Where it says Connections, Delete that entire string Hold down stylus on Connections circles it and delete it; this is what keeps the MMS from sending. Bad thing is every time you open explorer it re-writes this registry. To solve that many of us have just used something else besides Explorer. Like Opera, Firefox Mobile or Skyfire.
    You can still use these browsers without writing the Connections Value. If you don’t want to use anything but Explorer, you are going to have to go into this registry file and delete the Connections string every time to send MMS or until someone comes up with a registry hack to Auto delete this value every time you close IE …Close Regedit.

    Now go to your messages and click menu/MMS options and then click server and click add new. Add new or if you already have one called something else just click it and click edit...you need to change these settings to

    Server Name: Cricket
    Gateway leave: blank
    Port Number: 8080
    Server address: http://mms.mycricket.com/servlets/mms
    Connect Via Cricket: MMS

    Double check your settings:
    Sending limit (should be 1024000 if you changed these settings correctly in regedit)
    Wap version Wap 2.0 (Wap 2.0 should be pre selected, if it is don’t touch it. If it keeps reverting back to 1.2 when you click close? Go back into regedit and select WAPType 1 as mentioned previously, this forces it into WAP 2.0 without it MMS won’t work.) Now if you have more than 1 select the cricket one you just configured and hit set as default then go back to HKLM\Software\Arcsoft\Arcsoft MMS UA\Config\MM1\MMSCSetting\Cricket MMS and delete the other configuration, when you go back into settings Cricket should be the only one there and it should be default.

    The settings below are only if you are setting up MMS for the first time on partially flashed without MMS. Remember my phone was already flashed.

    Start\Settings\Connections\Connections Under the General Tab Enter Cricket. Under the Modem Tab put in Cricket Mobile Web select modem to cellular line. Click next put in #777 to dial to Cricket, click next… User Name: your10digitcellnumber@mycricket.com Password: cricket Domain: Leave Blank, click finish…under proxy settings, check these 2 boxes (this network connects to the internet, and this network uses a proxy server to connect to the internet) Proxy Server: wap.mycricket.com click advanced. The only thing with a value should be HTTP wap.mycricket.com:8080 the rest blank if your MMS still doesn’t work click on start/settings/ connections/connections/ then click on edit my proxy server then click on Advanced, click on WAP and set to wap.mycricket.com. Port 8080 and do the same for Secure WAP & Socks. Click ok and ok again, this ok should bring you back to the connections screen at the bottom click advanced. Click select networks. Under both drop downs select Cricket. Click Ok Go into Exceptions Click add new URL for each of the following settings you are going to need to click add new url again, these don’t all go under one “Add new URL” Block

    mms.mycricket.com/servlets/mms
    .mms.mycricket.com/servlets/mms
    mycricket.com/
    .mycricket.com/
    .mms.mycricket.com/
    mms.mycricket.com/

    And there you go; good luck and all the stores I went to help for wanted to charge me anywhere from $50 to $80 to re-flash it, ha, ha, ha,
    I just had a buddy of mine send me an audio & pic message and they came thru.

Bookmarks