Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2003
    Posts
    203
    Carrier
    AT&T
    Feedback Score
    0

    Why do my apps take so long to install?

    One of my coworkers just came to me with the new iPhone 3G he bought on Friday, to have me set him up wtih work email, and show him how to use the thing. I got the point of installing apps for him, so I went and downloaded Facebook, it downloaded and installed in under 10 seconds for him, same with Tris and the Wikipedia apps. This seemed abnormally fast to me, so I went over to my iPhone and downloaded Facebook, and it took over a minute to download and install. We are both on the same WiFi network, and both running 2.0.2 firmware.

    Is there something wrong with my iPhone? Should it really be taking me this long to install apps?

    Thanks.

  2. #2
    Join Date
    Nov 2003
    Location
    Toronto, Canada
    Posts
    517
    Phones
    iPhone 4
    iPhone 3G
    BB 8320
    Carrier
    Rogers
    Feedback Score
    0
    I have noticed that sometimes an app takes a long time to install, and sometimes it is very fast - even installing the same app on one phone, and multiple phones.

    I've noticed sometimes that it claims that it cannot be installed OTA, but has to be connected to itunes, but if I force it to install again, it's ok. Perhaps there is some kind of authentication going on when you install an app, and it hangs or times out occasionally?

    Bearing in mind however this only happens a minority of the time, maybe 1 out of 10. If it's happening to you every time, I guess I would say investigate further? Try it on wifi, 3G, different places...

  3. #3
    Join Date
    Mar 2003
    Posts
    203
    Carrier
    AT&T
    Feedback Score
    0
    Quote Originally Posted by mmmiles
    I have noticed that sometimes an app takes a long time to install, and sometimes it is very fast - even installing the same app on one phone, and multiple phones.

    I've noticed sometimes that it claims that it cannot be installed OTA, but has to be connected to itunes, but if I force it to install again, it's ok. Perhaps there is some kind of authentication going on when you install an app, and it hangs or times out occasionally?

    Bearing in mind however this only happens a minority of the time, maybe 1 out of 10. If it's happening to you every time, I guess I would say investigate further? Try it on wifi, 3G, different places...
    Well I've noticed that even since day one that it takes at least a minute to install any apps, and larger apps take even longer. It's never been faster than a minute for me. For this guy, he's installed 5 other apps so far, and none taking longer than 20 seconds. Mine acts the same way no matter what WiFi network I'm logged into, and takes even longer when using Edge or 3G.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •