Results 1 to 7 of 7

Thread: "Invalid destination address" when sending MMS

  1. #1
    Join Date
    Jun 2007
    Posts
    680
    Phone
    HTC Droid Incredible 2, Motorola Droid X, Nokia Lumia 520
    Carrier
    Page Plus Cellular, Lycamobile
    Feedback Score
    0

    "Invalid destination address" when sending MMS

    Lately, when I try to send an MMS (picture) message to a known valid email address or phone number, it fails on an "Invalid destination address" error. It will show "Sending message", then the progress bar goes to 100%, then I get the "Invalid destination address".

    Any idea what could be the culprit here? I am running QNC on my Motorola W385 if that makes a difference. WAP and voice are working OK.

  2. #2
    Join Date
    Jun 2007
    Posts
    680
    Phone
    HTC Droid Incredible 2, Motorola Droid X, Nokia Lumia 520
    Carrier
    Page Plus Cellular, Lycamobile
    Feedback Score
    0
    I am suspecting that somehow that MMS was inadvertently turned off on my account. I just submitted a message at the Page Plus web site. Hopefully they can fix it.

  3. #3
    Join Date
    Jun 2007
    Posts
    680
    Phone
    HTC Droid Incredible 2, Motorola Droid X, Nokia Lumia 520
    Carrier
    Page Plus Cellular, Lycamobile
    Feedback Score
    0
    Quote Originally Posted by slyphoxj
    I am suspecting that somehow that MMS was inadvertently turned off on my account. I just submitted a message at the Page Plus web site. Hopefully they can fix it.
    PP answered my email request saying that they don't support MMS on the W385 and that I have to buy a handset directly from PP to get MMS.

    Is there anything I can check on my phone? Or am I just out of luck?

  4. #4
    Join Date
    Aug 2006
    Posts
    5,009
    Phone
    HTC Droid Incredible 2
    Carriers
    PagePlus Cellular
    Feedback Score
    0
    Since you said "lately", I guess that means it used to work? If so, then I wouldn't accept PP's answer. Tell them it used to work, and ask them why it no longer does.
    PagePlus---13 Years & Counting . . . . . Lycamobile---1 Year & Counting
    *Ericsson AF738, Jul 2001-Dec 2003, *Qualcomm QCP 2760, Dec 2003-Feb 2008, *LG VX-8600, Feb 2008-Apr 2010, *Samsung Omnia SCH-i910, Apr 2010-Nov 2011, *HTC Droid Incredible (CM7.2 ROM), Nov 2011-Jun 2013, *HTC Droid Incredible 2 (CM7.2 ROM), Jun 2013-Present

  5. #5
    Join Date
    Jun 2007
    Posts
    680
    Phone
    HTC Droid Incredible 2, Motorola Droid X, Nokia Lumia 520
    Carrier
    Page Plus Cellular, Lycamobile
    Feedback Score
    0
    I pushed the issue. I replied "Is MMS enabled on my account?" Another PP CSR responded and said that she turned on MMS. And it's working now . Seems to only work reliably with QNC. It seemed to send awfully fast, even though I set the data rate to 14.4/14.4 with QNC.

    WAP is working fine now, albeit slowly with QNC. IM still won't work unless I set the Auto or Packet Data Only bits in offset F5 of SEEM 275A . But I'm not sure I really want to use IM all that much... it sends/receives quite a few SMS's which chew down my balance.

    Not sure why MMS was turned off in the first place... maybe PP goofed something up when they launced their own WAP?

  6. #6
    Join Date
    Jan 2012
    Posts
    1
    Feedback Score
    0
    Hi everyone,

    I am having similar problems with my Droid 2 Global. Until yesterday, I had no problems sending MMS messages to any of my contacts. Then, I started receiving the "invalid destination address" message when trying to send a message to one contact. This contact is a Verizon Wireless customer, as am I. Messages to other Verizon and non-Verizon customers go through with no problem. I called Verizon and performed the *228 update, performed a power cycle (removing the battery, waiting 20 seconds, putting it back in), cleared out all of my text messages, had my friend perform the *228 and power cycle, ensured that there were not any changes made to my account or my friend's account, and it is still not working.

    Verizon's only suggestion was to factory reset my phone. I'm not satisfied with that answer. Do you all have any other suggestions of things I can try?

    Thanks!

  7. #7
    Join Date
    Jul 2007
    Location
    PNW
    Posts
    1,763
    Phones
    Verizon iPhone
    Droid Maxx
    Carriers
    Verizon Page Plus
    Feedback Score
    0
    Quote Originally Posted by lguy4 View Post
    This contact is a Verizon Wireless customer, as am I.
    So are you saying you are a Verizon subscriber and not a Page Plus subscriber? If so, you would probably do better posting this in the Verizon forum. Verizon employees frequent that forum and may have some ideas.

    Are you able to send a SMS successfully to this "one contact?" So SMS to this contact works but MMS does not?
    Have you tried deleting and remaking that one contact? I assume you tried that but you didn't mention it.
    Have you tried sending a MMS to this contact by sending to cellnumber@vzwpix.com? If so, does that work?

    You may not like Verizon's answer but at least 3 or 4 times on Verizon postpaid with a smartphone I had MMS issues and I tried everything I could think of but the only thing that fixed it was a factory reset. Of course, I was using a cooked ROM at the time so that may have played into things also.

Bookmarks