Page 1 of 7 1 2 3 4 5 6 7 LastLast
Results 1 to 15 of 103

Thread: Does anyone know the proper APN settings for Android Devices?

  1. #1
    Join Date
    Mar 2006
    Posts
    13
    Carrier
    ATT
    Feedback Score
    0

    Does anyone know the proper APN settings for Android Devices?

    Using the info in the iPhone thread, I've got mobile data working, but mms is still not working.

    Does anyone know what the proper APN Settings are to get MMS on android devices?

    Thanks

  2. #2
    Join Date
    Feb 2004
    Location
    USA
    Posts
    683
    Phones
    iPhone 4S 16GB
    iPhone 4 16GB
    Carriers
    StraightTalk Wireless
    Feedback Score
    0
    Should be same. Check your spelling. Also ur phone might have a separate spot to enter the port # in which case dont enter :80 at the end of the proxy address and just enter 80 where it asks for the port address
    iPhone 4 running on StraightTalk Wireless 3G (AT&T MVNO)


    Time Warner Cable (Home ISP)
    [/URL]

  3. #3
    Join Date
    Mar 2006
    Posts
    13
    Carrier
    ATT
    Feedback Score
    0
    Quote Originally Posted by MrRomeo View Post
    Should be same. Check your spelling. Also ur phone might have a separate spot to enter the port # in which case dont enter :80 at the end of the proxy address and just enter 80 where it asks for the port address
    Thanks for your reply, but I have triple checked my settings.

    If anyone have actually got this functional on android please chime in.

    Here are the fields in the android APN Settings list, in order as they appear:
    Name
    APN
    Proxy
    Port
    Username
    Password
    Server
    MMSC
    MMS Proxy
    MMS Port
    MCC
    MNC
    APN Type

    Here are the working settings when you have actual AT&T, not a mvno:
    Name: whatever_you_want_the_name_to_be
    APN: wap.cingular
    Username: wap@cingulargprs.com
    Password: cingular1
    MMSC: http://mmsc.cingular.com
    MMS Proxy: wireless.cingular.com
    MMS port: 80
    MCC: 310
    MNC: 410

  4. #4
    Join Date
    Feb 2004
    Location
    USA
    Posts
    683
    Phones
    iPhone 4S 16GB
    iPhone 4 16GB
    Carriers
    StraightTalk Wireless
    Feedback Score
    0
    Try this for MMS

    Name: whatever_you_want_the_name_to_be
    APN: att.mvno
    Username:
    Password:
    MMSC: http://mmsc.cingular.com
    MMS Proxy: proxy.mvno.tracfone.com
    MMS port: 80
    MCC: 310
    MNC: 410

    EDIT: not sure what MCC and MNC stand for, or what the settings should be, but try leaving the 310, 410 settings in place, if it doesnt work, try leaving them blank.

  5. #5
    Join Date
    Dec 2010
    Posts
    762
    Carrier
    Straight Talk
    Feedback Score
    0

    Working MMS settings for android on Straight Talk

    Quote Originally Posted by mburris View Post
    Using the info in the iPhone thread, I've got mobile data working, but mms is still not working.

    Does anyone know what the proper APN Settings are to get MMS on android devices?

    Thanks
    Here are the steps I used to get MMS working on Moto Backflip with Android 2.1

    First download Apn Backup and Restore app from app store, and delete all existing APNs. Then manually enter APNs. In android you must have 2 apns setup for mms to work (at least in my case).

    Here are my settings:

    Name
    HOME

    APN
    att.mvno

    Leave everything else alone EXCEPT the bottom selection that says:

    APN type (here you must enter the following)
    default,supl

    Then save, next choose to add another APN
    make it look like this:

    Name
    MMS

    APN
    att.mvno

    skip down to
    MMSC
    http://mmsc.cingular.com

    MMS proxy
    proxy.mvno.tracfone.com

    MMS port
    80

    skip to:
    APN type (enter the following)
    mms
    THEN SAVE

    You will see that only one APN has the option to be chosen, that is ok, Just choose the one that is able to be chosen.

    Now go back to Homescreen and then reboot your phone.
    This works for me, hope it can help you. I tried a hundred different ways and this was it. Capitalization is important, and the APN type was the trick.
    GOOD LUCK and let me know if it worked for you.

  6. #6
    Join Date
    Dec 2009
    Location
    Clemson, SC
    Posts
    39
    Carrier
    Atrix on ST = :)
    Feedback Score
    0
    Just tried your method on my Samsung Captivate and it worked great. Thanks!



    Quote Originally Posted by Zmk76 View Post
    Here are the steps I used to get MMS working on Moto Backflip with Android 2.1

    First download Apn Backup and Restore app from app store, and delete all existing APNs. Then manually enter APNs. In android you must have 2 apns setup for mms to work (at least in my case).

    Here are my settings:

    Name
    HOME

    APN
    att.mvno

    Leave everything else alone EXCEPT the bottom selection that says:

    APN type (here you must enter the following)
    default,supl

    Then save, next choose to add another APN
    make it look like this:

    Name
    MMS

    APN
    att.mvno

    skip down to
    MMSC
    http://mmsc.cingular.com

    MMS proxy
    proxy.mvno.tracfone.com

    MMS port
    80

    skip to:
    APN type (enter the following)
    mms
    THEN SAVE

    You will see that only one APN has the option to be chosen, that is ok, Just choose the one that is able to be chosen.

    Now go back to Homescreen and then reboot your phone.
    This works for me, hope it can help you. I tried a hundred different ways and this was it. Capitalization is important, and the APN type was the trick.
    GOOD LUCK and let me know if it worked for you.

  7. #7
    Join Date
    Jan 2011
    Posts
    6
    Feedback Score
    0

    Needed this

    thanks for the help

  8. #8
    Join Date
    Jan 2011
    Posts
    5
    Feedback Score
    0
    hi i do have captivate internet works sms works but cant send mms like pic etc help please have all the setting as above

  9. #9
    Join Date
    Dec 2010
    Posts
    762
    Carrier
    Straight Talk
    Feedback Score
    0
    Did you start out by downloading APN backup and restore and delete all apns before creating new apns?? The stock AT&T configuration can not be present for this to work. Have you rebooted after creating both new apns?

  10. #10
    Join Date
    Jan 2011
    Posts
    5
    Feedback Score
    0
    Quote Originally Posted by Zmk76 View Post
    Did you start out by downloading APN backup and restore and delete all apns before creating new apns?? The stock AT&T configuration can not be present for this to work. Have you rebooted after creating both new apns?
    did not know will try now thanks for the info

  11. #11
    Join Date
    Jan 2011
    Posts
    5
    Feedback Score
    0
    i tired that just know and stays at sending can send regular sms tho
    Quote Originally Posted by cisco150 View Post
    did not know will try now thanks for the info

  12. #12
    Join Date
    Dec 2010
    Posts
    762
    Carrier
    Straight Talk
    Feedback Score
    0
    Try rebooting your phone and then go into apns and make sure the one you can choose is highlighted with the green circle.

  13. #13
    Join Date
    Dec 2010
    Posts
    762
    Carrier
    Straight Talk
    Feedback Score
    0
    If that is not it, review all entries, it only takes one typo for this to not work.

  14. #14
    Join Date
    Jan 2011
    Posts
    5
    Feedback Score
    0
    tried every thing not working and in network setting where i set apn dont have data packet in menu do i need that and how to install
    Quote Originally Posted by Zmk76 View Post
    If that is not it, review all entries, it only takes one typo for this to not work.

  15. #15
    Join Date
    Dec 2010
    Posts
    762
    Carrier
    Straight Talk
    Feedback Score
    0
    I do not have a Captivate but if your regular data still works, I don't think that setting missing has anything to do with it. If your regular data is now not working with that setting missing my guess is you need to to do a hard reset of your device. Before you go doing that I would pm the person in this thread with the Captivate that this method worked for. I am in no way meaning to sound like an *** but I believe you may need to stop and read the instructions carefully and follow it step by step, I think you may be missing something.

Page 1 of 7 1 2 3 4 5 6 7 LastLast

Similar Threads

  1. Proper APN settings for Android?
    By Benny_L in forum Mobilicity
    Replies: 29
    Last Post: 11-29-2010, 07:19 PM
  2. Just switched devices. My settings are gone!
    By mrseed in forum BlackBerry
    Replies: 5
    Last Post: 04-02-2010, 05:23 PM
  3. Full wap/mms settings cab for HTC flashed devices
    By YouMayLose in forum MetroPCS Flashing and Modding
    Replies: 129
    Last Post: 08-16-2009, 10:50 AM
  4. SalesCentral Pictures: proper settings for IE7?
    By GSXi in forum Sales Central
    Replies: 1
    Last Post: 04-11-2009, 03:33 PM
  5. Replies: 1
    Last Post: 01-30-2009, 10:19 PM

Bookmarks