Results 1 to 2 of 2

Thread: Earpiece sound goes in and out

  1. #1
    Join Date
    Jul 2006
    Location
    Southeast
    Posts
    1,025
    Device(s)
    Nexus One / SE Equinox TM717
    Carrier(s)
    T-Mobile
    Feedback Score
    0

    Earpiece sound goes in and out

    Anyone else had a problem with the earpiece on a TM717/Equinox? Starting today, the sound comes and goes on the earpiece. I've repaired a faulty earpiece connection on a Motorola and a Blackberry but I've never tried to crack open a Sony Ericsson before. The phone is a year and two days old today. A year's continuous use may be all this phone can take. I gave my older TM506s to my wife to use and she wore both of them out (but she is harder than I on a phone). My old Motorolas seemed a bit more hardy.

  2. #2
    Join Date
    Aug 2008
    Posts
    13,481
    Feedback Score
    0
    I've have two TM717's and haven't any problem yet. I don't know how difficult it would be to repair the connection. Since you have some experience you might give it a shot. In the meantime, you could use a handsfree device---I'm assuming the sound isn't affected when using one of those.

Similar Threads

  1. Replies: 1
    Last Post: 11-16-2009, 08:51 PM
  2. No sound from 707SC earpiece/speaker
    By turtledude558 in forum Others
    Replies: 4
    Last Post: 05-31-2009, 04:07 PM
  3. No sound from 707SC earpiece/speaker
    By turtledude558 in forum Japanese Phones
    Replies: 4
    Last Post: 05-31-2009, 04:07 PM
  4. No sound from earpiece i870
    By Lou420 in forum Motorola Phone Problems
    Replies: 0
    Last Post: 05-05-2009, 01:29 AM
  5. Temporarily had no sound through earpiece (N95 8GB)
    By Skarbro in forum Symbian/S60
    Replies: 0
    Last Post: 04-29-2009, 09:26 AM

Bookmarks