Results 1 to 3 of 3

Thread: 9650 is Dead? Blank screen, battery with red X

  1. #1
    Join Date
    Feb 2004
    Location
    West LA
    Posts
    1,528
    Phone
    EVO 4G
    Carrier
    Sprint (I'm new - please don't disappoint!)
    Feedback Score
    0

    9650 is Dead? Blank screen, battery with red X

    Hi All,
    I am freaking out. I charged my Sprint 9650 overnight, and when I woke up, the radio had an X over it (though I hadn't turned the radio off). Unplugged the charger, performed a battery pull. Upon replacing the battery, I get a blank screen with an empty battery symbol with a red X.

    The battery is not dead, and plugging the phone back into the AC adapter does not do anything. Phone will not respond. Lots of data on the phone, I am very worried. What's going on? Ever since I upgraded to OS 6 I've been having lag issues.
    Past phones: Samsung A530, Moto E815, LG VX8500, Samsung U600, Apple iPhone 8GB, Moto Razr2 V9M, iPhone 32GB 3GS, RIM BB Pearl 8130, BB 9700

  2. #2
    Join Date
    Mar 2007
    Location
    Billings, Montana
    Posts
    87
    Phones
    iPhone 4
    Samsung Glint
    BlackBerry Bold
    Carriers
    Alltel/AT&T
    Feedback Score
    0
    Quote Originally Posted by mongoos150 View Post
    Hi All,
    I am freaking out. I charged my Sprint 9650 overnight, and when I woke up, the radio had an X over it (though I hadn't turned the radio off). Unplugged the charger, performed a battery pull. Upon replacing the battery, I get a blank screen with an empty battery symbol with a red X.

    The battery is not dead, and plugging the phone back into the AC adapter does not do anything. Phone will not respond. Lots of data on the phone, I am very worried. What's going on? Ever since I upgraded to OS 6 I've been having lag issues.
    Try this: pull the battery and set it aside. Plug the phone into the charger. This will illuminate the red light. Wait for the red light to shut off and the no battery symbol to come up. Once you see this put the battery back into the phone. Let the phone charge all the way. (Its best to do this process at night so it has all night to charge). Once it is completely full the phone should turn on. If not, it sounds like it might be related to the OS upgrade. Keep us posted.


    Sent from my (null) using HowardForums

  3. #3
    Join Date
    Feb 2004
    Location
    West LA
    Posts
    1,528
    Phone
    EVO 4G
    Carrier
    Sprint (I'm new - please don't disappoint!)
    Feedback Score
    0
    Yes, this worked. Thanks. I'm at my wits end with this phone post-upgrade. Thinking about going back to EVO.

Similar Threads

  1. 3GS wont go past dead battery screen
    By rkoshack in forum Apple
    Replies: 13
    Last Post: 10-09-2009, 03:37 PM
  2. xv6700 Today screen blank/gone after dead batt...
    By conaire in forum Cricket/AIO
    Replies: 2
    Last Post: 06-20-2009, 10:40 PM
  3. N82 - Blank Screen HELP!
    By yakk00 in forum Symbian/S60
    Replies: 1
    Last Post: 02-14-2009, 11:07 AM
  4. Replies: 2
    Last Post: 01-14-2009, 06:18 PM

Tags for this Thread

Bookmarks