Results 1 to 13 of 13

Thread: Can't send SMS to numbers with +1 in front of them (or any country code)

  1. #1
    Join Date
    Feb 2004
    Posts
    3,379
    Phone
    Samsung Galaxy Nexus, Nokia 6230
    Carriers
    Alltel via Verizon
    Feedback Score
    0

    Can't send SMS to numbers with +1 in front of them (or any country code)

    This is really annoying.
    Coming from a blackberry I always had all my numbers formatted with +CC in front of them. Now I'm realizing that any number thats not just 10 digits will not receive my SMS. Samsung Fascinate is the phone. Tried a hard reboot, no luck.
    Verizon has no idea, I've spent over 2 hours with them, 4 different reps and they all just have me do a PRL update...

    Thoughts?
    If you can read this, thank a teacher. If you are reading this in English, thank a Veteran.

  2. #2
    Join Date
    Jun 2003
    Posts
    799
    Phone
    iPhone 5s
    Carrier
    VZW
    Feedback Score
    0
    Quote Originally Posted by hillstrubl View Post
    This is really annoying.
    Coming from a blackberry I always had all my numbers formatted with +CC in front of them. Now I'm realizing that any number thats not just 10 digits will not receive my SMS. Samsung Fascinate is the phone. Tried a hard reboot, no luck.
    Verizon has no idea, I've spent over 2 hours with them, 4 different reps and they all just have me do a PRL update...

    Thoughts?
    That's the format I use in my phone book... Every number has a +1 at the start of it. Using my Thunderbolt, I just sent a few test messages to make sure... They were received.

  3. #3
    Join Date
    Feb 2004
    Posts
    3,379
    Phone
    Samsung Galaxy Nexus, Nokia 6230
    Carriers
    Alltel via Verizon
    Feedback Score
    0
    seems to be a samsung specific issue.

  4. #4
    Join Date
    Jan 2004
    Location
    New York
    Posts
    7,449
    Phone
    Samsung Galaxy Note II
    Carrier
    Verizon
    Feedback Score
    0
    On another forum, there has been a number of people with Thunderbolts that are saying that their phones cannot SMS, MMS, or even call any numbers with a +1 in front of it. Apparently this may be a wider issue than just with the Samsung. I suppose this could be a huge problem for folks with contacts being sync'ed in Facebook as Facebook always appends phone numbers with the country code.

  5. #5
    Join Date
    Feb 2004
    Posts
    3,379
    Phone
    Samsung Galaxy Nexus, Nokia 6230
    Carriers
    Alltel via Verizon
    Feedback Score
    0
    Just tried to file a ticket with Verizon.
    They won't even process an issue about it because "the issue is because of the +1".

    Here's my problem. Some people work that are sync'ed with facebook AND have a +1, some people don't work even removing the +1, some people don't work who don't even have a linked facebook profile.

    When asked about when I go abroad, I was told that I'd have to manually add a +1 to any text I wanted to respond to. Isn't that why numbers are saved in international format to begin with?

    This is a really bad workaround if thats the case. I just wish the problem would actually be looked at.

  6. #6
    Join Date
    Oct 2005
    Location
    Pasadena, CA
    Posts
    407
    Phones
    3GS iPhone. Gone: 2G iPhone; 3G iPhone; Curve (2X); Dash (2X);
    Gone: European Treo 750; Treo 700wx; SDA; MDA; Treo 650 (2x); BB 7230; MPx220
    (It's a disease, isn't it?)
    Carriers
    T-Mobile and ATT (dialtone)
    Feedback Score
    0
    I will be moving over to VZW from ATT soon. The +1 problem matters to me because I travel. Is this a VZW system problem or a phone-specific problem?

  7. #7
    Join Date
    Feb 2004
    Posts
    3,379
    Phone
    Samsung Galaxy Nexus, Nokia 6230
    Carriers
    Alltel via Verizon
    Feedback Score
    0
    Another problem I'm having. Even if i remove the +1, certain people (my dad's number for instance) it re-adds them. For me to sms him, I have to manually send a new message typing in the 10 digits each time. Responding to a received one uses the auto-added +1. In addition, at least 1 person I know if, its re-adding the +1 yet they're getting the messages...

    Anybody @ VZW have any ideas?

  8. #8
    Join Date
    Feb 2004
    Posts
    3,379
    Phone
    Samsung Galaxy Nexus, Nokia 6230
    Carriers
    Alltel via Verizon
    Feedback Score
    0
    They're telling me to download chomp sms in order to successfully send messages. I get that this as a user-suggested temporary solution, but seriously this is what the carrier is suggesting? I'm told I've been added to the existing trouble tickets, they wouldn't create one for my particular case.

    I am very unhappy with their handling of this. Between telling me to "have your dad check his phone" (which is a verizon blackberry) to asking me to download a 3rd party ad-laden SMS app this really is poor handling of an issue.

  9. #9
    Join Date
    May 2004
    Location
    BTA027
    Posts
    16,535
    Phone
    iPhone 5
    Carrier
    American Telephone & Telegraph Company
    Feedback Score
    0
    I always thought the +CC format only works with GSM-based handsets. Is there even an option to enter a "+" sign on a CDMA phone? I mean of course on a smartphone you can enter any character on the keyboard, but I don't think ANSI even supports "+" as a dial-able character. Much less is the backend able to substitute "+" with the proper international dialing prefix, which needs to happen for this to work.

    VZW's web site specifically says in order to text Japan you have to enter "011 + 81 + 10-digits", not "+81 10-digits" as you would with a GSM handset. I think that's a system limitation with the ANSI core network, not a problem with a particular phone.

    http://b2b.vzw.com/international/Tex...fic/Japan.html

    PRL Interpretations
    XFF's AlphaTag software
    Cellular and PCS License Maps
    Quote Originally Posted by gpatrick900
    I am a little confused. My Verizon phone was able to roam on GSM because they used TDMA. Tell it was shutdown. The phone recognizes it as Analog. If PCS has TDMA, It could be technically be used on GSM.
    Quote Originally Posted by Tabla View Post
    Y'know, I'm used to hysterical 14-year-old ******** on the internet, but this is exceptional. Never before in human history have so many nerds hyperventilated so publicly over so little.

  10. #10
    Join Date
    Feb 2004
    Posts
    3,379
    Phone
    Samsung Galaxy Nexus, Nokia 6230
    Carriers
    Alltel via Verizon
    Feedback Score
    0
    Quote Originally Posted by XFF View Post
    I always thought the +CC format only works with GSM-based handsets. Is there even an option to enter a "+" sign on a CDMA phone? I mean of course on a smartphone you can enter any character on the keyboard, but I don't think ANSI even supports "+" as a dial-able character. Much less is the backend able to substitute "+" with the proper international dialing prefix, which needs to happen for this to work.

    VZW's web site specifically says in order to text Japan you have to enter "011 + 81 + 10-digits", not "+81 10-digits" as you would with a GSM handset. I think that's a system limitation with the ANSI core network, not a problem with a particular phone.

    http://b2b.vzw.com/international/Tex...fic/Japan.html
    Understood, then why did it work with a Droid Pro, Verizon Blackberry 9650 and some people (both Verizon and non-verizon customers) on this particular phone?

  11. #11
    Join Date
    Jun 2008
    Location
    Michigan
    Posts
    43
    Phone
    Blackberry 9650
    Carrier
    Verizon
    Feedback Score
    0
    Quote Originally Posted by hillstrubl View Post
    Understood, then why did it work with a Droid Pro, Verizon Blackberry 9650 and some people (both Verizon and non-verizon customers) on this particular phone?
    It works on my Blackberry 9650 also so I don't believe it is a CDMA issue. In fact my blackberry automatically adds the +1 to every contact I add to my phone. The only numbers I have in my contacts list that aren't formatted that way are people I saved after they called me or a few I synced over from my gmail account. Even with the people I have saved without the +1 the phone always shows a +1 in front of their number when ever an outgoing call from me is connecting. It looks like the blackberry just automatically adds a +1 to all outgoing calls.

  12. #12
    Join Date
    Feb 2004
    Posts
    3,379
    Phone
    Samsung Galaxy Nexus, Nokia 6230
    Carriers
    Alltel via Verizon
    Feedback Score
    0
    switched phones to a Thunderbolt. Issue has disappeared.
    The problem is I still don't know if it was the phone(s) themself (had 2 fascinates with the same issue) something about how it interacted with my account, or the fact that it was Android 2.1.

    Oh well, it works now.

  13. #13
    Join Date
    Nov 2003
    Posts
    129
    Phones
    Blackberry 8830
    Razr V3C
    Carrier
    Verizon
    Feedback Score
    0
    I had the same issue on my fascinate. I also moved from a blackberry where every number included a +1 because Outlook would add it.

    Prior to the switch I had moved my contacts to Google.

    I fixed the problem by:
    1. Export Google contacts to a CSV.
    2. Wipe the phone and turn it off
    3. Open CSV in Excel.
    4. Do a find and replace to remove all of the +1. (Search for "+1" and replace with "") (I also removed all of the spaces and hyphens from the numbers). SAVE IT WITH A DIFFERENT NAME IN CASE YOU MAKE A MISTAKE!!
    5. Erase all contacts on Google.
    6. Reimport Google Contacts from the CSV
    7. Turn on phone. Setup account again and sync.

    The process wasn't too painful but not understanding why my friends were ignoring my texts for 2 days was very annoying.

Similar Threads

  1. turn off country code dialing from phonebook
    By smokey2k4 in forum BlackBerry
    Replies: 5
    Last Post: 06-22-2011, 06:55 AM
  2. Replies: 4
    Last Post: 05-03-2010, 03:08 AM
  3. Country Code
    By tscallions in forum Apple
    Replies: 8
    Last Post: 07-09-2009, 04:00 PM
  4. Cheapo A237 Country Code
    By narcoleptic in forum Samsung
    Replies: 0
    Last Post: 03-25-2009, 09:19 PM
  5. e61i and phone numbers with added 1 in front
    By chlubb in forum Symbian/S60
    Replies: 2
    Last Post: 01-28-2009, 03:38 PM

Tags for this Thread

Bookmarks