Page 1 of 4 1 2 3 4 LastLast
Results 1 to 15 of 58

Thread: Straight Talk data problems

  1. #1
    Join Date
    Nov 2005
    Posts
    143
    Feedback Score
    0

    Straight Talk data problems

    Over the last two days, I've had really bizarre data problems.

    Mainly, my data works but certain domains don't work.

    For example, last night, youtube.com didn't work. But the youtube android app did.

    This morning I couldn't access my aol mail. I tried via mail.aol.com, aol.com, and IMAP through Android's mail app, none of them worked. Yet through a normal computer it worked fine, so the problem wasn't with aol.

    Two days ago I was playing pandora for a half hour or so, then it stalled. I restarted the phone, and the web browser worked, but Pandora then said No Data Connection. That lasted about an hour and it worked again.

    Same goes for Android Market. I'll be able to browse the web fine, and use skype, but then at the same time when I tried connecting to Android market I got No Data Connection.


    If it was just youtube, pandora, and android market, it would make sense that Straight Talk would block or throttle these domains. But the AOL mail thing has me perplexed. And throughout all this, by speedtests have remained about the same.


    Is it known whether or not Straight Talk throttles data coming from certain domains?

  2. #2
    Join Date
    Mar 2011
    Posts
    988
    Carrier
    Straight Talk
    Feedback Score
    0
    I've had similar problems for a couple days. Sometimes it will say no data connection in the web browser, then it will work. Certain websites wont open, then will. I have no idea.

  3. #3
    Join Date
    Aug 2011
    Posts
    17
    Feedback Score
    1 (100%)
    I have been having the same problem also. It drives me crazy when only half of what I want works

  4. #4
    Join Date
    Sep 2010
    Posts
    77
    Feedback Score
    0
    same problems here!!!

  5. #5
    Join Date
    Feb 2009
    Location
    California
    Posts
    1,888
    Carrier
    Sprint via RingPlus
    Feedback Score
    1 (100%)
    Odd. I was also having the same issue on Friday evening while streaming Pandora on my iPhone while driving. It worked throughout most of the drive, but sometimes there were 5 minute delays between songs. I was driving so didn't bother further checking into it.

  6. #6
    Join Date
    May 2011
    Posts
    43
    Feedback Score
    0
    Quote Originally Posted by Volaris View Post
    Odd. I was also having the same issue on Friday evening while streaming Pandora on my iPhone while driving. It worked throughout most of the drive, but sometimes there were 5 minute delays between songs. I was driving so didn't bother further checking into it.
    Perhaps it is Straight Talk's way of getting back at people that are abusing the system. I do not remember seeing in their TOS that you could stream music, let alone use an iPhone with their service. I am not trying to be mean or anything. Just saying.

  7. #7
    Join Date
    Oct 2010
    Posts
    4,210
    Carrier
    AT&T GoPhone
    Feedback Score
    0
    These glitches sound more like issues with AT&Ts DNS servers than any kind of "getting back at people abusing the system".
    If you have an Android or iPhone, you can easily set your DNS resolvers (ie use Googles).
    You can even use an Android app: https://market.android.com/details?i...e.setDNS&hl=en
    Just set the DNS server to 8.8.8.8 and 4.2.2.1
    The first one is Google and the second is Level3

    See if that helps fix the issue.

  8. #8
    Join Date
    Apr 2006
    Location
    Northwest Iowa
    Posts
    7,725
    Carrier
    Straight Talk Wireless
    Feedback Score
    0
    Similiar issues here. For about the last three days, on and off with Inspire and then Atrix. Usually seems to happen with market for me. I can browse facebook, web, search for apps and view screenshots in market, but when I actually click to install and get the download bar, it just hangs and hangs and hangs. Last night I went so far as to uninstall all market updates, clear caches, and switch radios, and nothing helped...then about 10 minutes after doing all that, it magically started working again all on its own.

  9. #9
    Join Date
    Oct 2010
    Posts
    43
    Carrier
    Straight Talk
    Feedback Score
    0
    Same issues here with an Atrix. No problems over WIFI, and only sporadic over cellular. I've noticed it switching between HSPA and UMTS pretty frequently when checking the status in the settings. Don't know if that may have something to do with it. Tried reboots, cycling data off/on. Still does it. Hopefully its resolved soon.

  10. #10
    Join Date
    Mar 2011
    Posts
    862
    Phones
    Nokia E71
    HTC Inspire 4G
    Samsung Infuse 4G
    Carrier
    Straight Talk
    Feedback Score
    0
    I've had issues too, although they seem to have gone away at the moment. I thought it was my phone at first. I wonder if this is specific to ST customers or if maybe other ATT MVNOs are having similiar problems.

    sent from my Straight Talk Samsung Infuse 4G using the Howard Forums app
    For instructions on using Androids with Straight Talk don't PM me....I don't usually answer....click here!
    http://www.howardforums.com/showthre...stop-asking%29

  11. #11
    Join Date
    Dec 2011
    Posts
    4
    Feedback Score
    0
    Same issue here too over the last few days. It seems to have completely killed iMessage on iOS 5. Also can't access work Exchange server and the Weatherbug app can't update. It's extremely annoying, especially since it interrupts iMessage. Does anyone have any idea if this is a deliberate change to "limit" data access by Straight Talk or just a mistake in the network routing.

    To get around it for now, I've started using the auto-connecting Hotspot Shield from the App store, it auto connects a VPN which all 3G data gets routed through. Not an ideal situation, but it works for the most part.

  12. #12
    Join Date
    Mar 2011
    Posts
    862
    Phones
    Nokia E71
    HTC Inspire 4G
    Samsung Infuse 4G
    Carrier
    Straight Talk
    Feedback Score
    0
    Checked a few things today on my phone. It still appears to be working ok as of yesterday. A couple of days ago the Android market was having issues, as was my weather widget. Also, pictures weren't loading on my Facebook feed. Hopefully it keeps working. I would hate to see us lose our loophole on these phones.

    sent from my Straight Talk Samsung Infuse 4G using the Howard Forums app

  13. #13
    Join Date
    Aug 2008
    Posts
    25
    Carrier
    at&t Go Phone
    Feedback Score
    0
    I am so glad to hear I'm not the only person experiencing the intermittent data issue, I first noticed it started on my samsung S2 on friday. I came close to doing a factory reset on my phone thinking that was the issue but then my data started to work again on saturday mysteriously & I was happy until it started today again.
    My hope is that this is just an isolated issue that will be resolved soon enough & not ST beginning to close out the loop hole we have all been enjoying

  14. #14
    Join Date
    Mar 2011
    Posts
    862
    Phones
    Nokia E71
    HTC Inspire 4G
    Samsung Infuse 4G
    Carrier
    Straight Talk
    Feedback Score
    0
    Quote Originally Posted by silentjudge View Post
    These glitches sound more like issues with AT&Ts DNS servers than any kind of "getting back at people abusing the system".
    If you have an Android or iPhone, you can easily set your DNS resolvers (ie use Googles).
    You can even use an Android app: https://market.android.com/details?i...e.setDNS&hl=en
    Just set the DNS server to 8.8.8.8 and 4.2.2.1
    The first one is Google and the second is Level3

    See if that helps fix the issue.
    Did this....appears to be ok so far. We'll see what happens.

    Note: The Android app apparently requires root, for those that are wondering.

    sent from my Straight Talk Samsung Infuse 4G using the Howard Forums app

  15. #15
    Join Date
    Dec 2011
    Posts
    4
    Feedback Score
    0
    I also thought it might be a DNS server problem. Unfortunately, you cannot set the DNS server on an iPhone for the 3G connection without a Jailbreak.

    However, it appears to be more than just a DNS server issue, since I directly used the IP address of my private VPN server and could not access it. It appears it may be something with blocking IP domain subsections (a main router problem) and / or blocking outbound ports. I don't have adequate tools to test these theories on the iPhone, but I hope we can get an answer to what is actually happening with the network.

    I know for a fact it definitely interrupts iMessage completely.

    I wonder if other ATT MVNO's are experiencing similar issues.

Page 1 of 4 1 2 3 4 LastLast

Similar Threads

  1. Straight Talk Data
    By Grateful4Advice in forum Straight Talk
    Replies: 30
    Last Post: 12-11-2012, 09:46 AM
  2. Straight Talk MMS Problem on iOS 5.0.1?
    By Jonathan Cruz in forum Straight Talk
    Replies: 1
    Last Post: 11-16-2011, 06:16 PM
  3. Blackberry Curve on Straight Talk network data problem.
    By julie83 in forum Verizon Wireless
    Replies: 14
    Last Post: 11-11-2011, 12:35 AM
  4. Straight Talk MMS Problems
    By jweav in forum Straight Talk
    Replies: 8
    Last Post: 06-22-2011, 01:30 AM
  5. Straight Talk Security problem ?
    By Tracfancier in forum Straight Talk
    Replies: 5
    Last Post: 05-07-2011, 04:06 PM

Tags for this Thread

Bookmarks