Page 1 of 4 1 2 3 4 LastLast
Results 1 to 15 of 52

Thread: Straight Talk BYOD (T-Mobile) MMS settings that actually work!

  1. #1
    Join Date
    Mar 2005
    Posts
    61
    Feedback Score
    0

    Straight Talk BYOD (T-Mobile) MMS settings that actually work!

    I called ST customer tech support. Outside of resetting my account, they were of no help to me getting MMS to work on my Nexus One.

    So I started hacking away at the APN settings that the ST site (http://www.straighttalksim.com/support.php) did not make mention of on my device. I finally learned that there were a couple other key APN settings that were important to making MMS work.

    Name: straight talk
    APN: wap.tracfone
    Proxy: <do not set>
    Port: 8080
    Username: <do not set>
    Password: <do not set>
    Server: <do not set>
    MMSC: http://mms.tracfone.com
    MMS Proxy: <do not set>
    MMS Port: <do not set>
    MCC: 310
    MNC: 260
    Authentication type: <do not set>
    APN type: default,supl,mms
    APN protocol: IPv4/IPv6

    Those highlighted above are values that the ST support site do not make mention of:
    http://www.straighttalksim.com/support.php

    My MMS messages were always timing out on delivery attempts until I changed "APN type" from <blank> to "default,supl,mms" and "APN protocol" from "IPv4" to "IPv4/IPv6", though I'm not sure if one, or both, are the key to success.

    As always, YMMV, but at least I have MMS back, no thanks to ST tech support.

  2. #2
    Join Date
    Aug 2010
    Location
    USA
    Posts
    972
    Carrier
    Straight Talk
    Feedback Score
    0
    Quote Originally Posted by fsnertz View Post
    I called ST customer tech support. Outside of resetting my account, they were of no help to me getting MMS to work on my Nexus One.

    So I started hacking away at the APN settings that the ST site (http://www.straighttalksim.com/support.php) did not make mention of on my device. I finally learned that there were a couple other key APN settings that were important to making MMS work.

    Name: straight talk
    APN: wap.tracfone
    Proxy: <do not set>
    Port: 8080
    Username: <do not set>
    Password: <do not set>
    Server: <do not set>
    MMSC: http://mms.tracfone.com
    MMS Proxy: <do not set>
    MMS Port: <do not set>
    MCC: 310
    MNC: 260
    Authentication type: <do not set>
    APN type: default,supl,mms
    APN protocol: IPv4/IPv6

    Those highlighted above are values that the ST support site do not make mention of:
    http://www.straighttalksim.com/support.php

    My MMS messages were always timing out on delivery attempts until I changed "APN type" from <blank> to "default,supl,mms" and "APN protocol" from "IPv4" to "IPv4/IPv6", though I'm not sure if one, or both, are the key to success.

    As always, YMMV, but at least I have MMS back, no thanks to ST tech support.


    I just went to try what you posted since i am having issues & I cant change mine to your settings. I do not have those choices in my settings? I Wonder why?
    Samsung Vibrant w Super Amoled Screen + Avatar =

  3. #3
    Join Date
    Mar 2012
    Posts
    16
    Feedback Score
    0
    Are you using the APN Backup and Restore app? If so you should be able to put in a completely new APN with all of those settings.

  4. #4
    Join Date
    Mar 2005
    Posts
    61
    Feedback Score
    0
    I'm running Android 2.3 Gingerbread on an unlocked Nexus One. These are the fields the APN edit screen presents to me.

  5. #5
    Join Date
    Aug 2010
    Location
    USA
    Posts
    972
    Carrier
    Straight Talk
    Feedback Score
    0
    Quote Originally Posted by fsnertz View Post
    I'm running Android 2.3 Gingerbread on an unlocked Nexus One. These are the fields the APN edit screen presents to me.
    OK. I am really confused here.

    I downloaded that app & all that seems to do is back your settings up? Why would I need that when I can enter them with ease just like when I set ST up?

    Next for "AUTHENTICATION TYPE" I have - NONE/PAP/CHAP/PAP or CHAP

    & "APN TYPE" I have - Internet & MMS/INTERNET/MMS

    I dont have APN PROTOCALL

    I go into SETTINGS/Wireless and Network/Mobile Networks/Access Point Names & set it from there, right?

    I am sooooooooo confused? Sorry

  6. #6
    Join Date
    Mar 2011
    Posts
    990
    Carrier
    Straight Talk
    Feedback Score
    0
    Quote Originally Posted by jkool View Post
    OK. I am really confused here.

    I downloaded that app & all that seems to do is back your settings up? Why would I need that when I can enter them with ease just like when I set ST up?

    Next for "AUTHENTICATION TYPE" I have - NONE/PAP/CHAP/PAP or CHAP

    & "APN TYPE" I have - Internet & MMS/INTERNET/MMS

    I dont have APN PROTOCALL

    I go into SETTINGS/Wireless and Network/Mobile Networks/Access Point Names & set it from there, right?

    I am sooooooooo confused? Sorry
    APN type needs to be one that has a combo type. Some phones vary. Some said default, supl and some have internet+mms, some phones have a drop down menu to choose and some you have to type manually. I'm running cyanogen cm7 on my infuse 4g and it put default, supl,mms by default.

    Sent from my SGH-I997 using HowardForums

  7. #7
    Join Date
    Aug 2010
    Location
    USA
    Posts
    972
    Carrier
    Straight Talk
    Feedback Score
    0
    OK, so do you have any idea how I figure out what to set what at to get MMS to work for my Vibrant or where i can find out?

    It has been days and ST tells me stuff like check my strength bars & make sure I put the email address in correct.

    Next thing ST is gonna say is do I have a battery in my phone?

    Thank you.

  8. #8
    Join Date
    Mar 2005
    Posts
    61
    Feedback Score
    0
    Quote Originally Posted by benjamin.kelley View Post
    APN type needs to be one that has a combo type. Some phones vary. Some said default, supl and some have internet+mms, some phones have a drop down menu to choose and some you have to type manually. I'm running cyanogen cm7 on my infuse 4g and it put default, supl,mms by default.

    Sent from my SGH-I997 using HowardForums
    I think that was the ticket for me. My APN type was blank, and data was entered as a plaintext field (not a selectable list).

    IMO that APN Backup and Restore app is not necessary for this exercise, so long as you can get into native Android's AP settings yourself. So, unless someone objects, I recommend you don't go down that rosy path.

  9. #9
    Join Date
    Aug 2010
    Location
    USA
    Posts
    972
    Carrier
    Straight Talk
    Feedback Score
    0
    Quote Originally Posted by fsnertz View Post
    I think that was the ticket for me. My APN type was blank, and data was entered as a plaintext field (not a selectable list).

    IMO that APN Backup and Restore app is not necessary for this exercise, so long as you can get into native Android's AP settings yourself. So, unless someone objects, I recommend you don't go down that rosy path.
    Name:  ap.jpg
Views: 20728
Size:  83.4 KB

    Here is what mine looks like & my settings I have entered....does anybody have any idea what i need to do?

    I usually send reminders/notes via text to my email address throughout the day & it is killing me not being able to do this.

    Thank you all for your help!

  10. #10
    Join Date
    Mar 2005
    Posts
    61
    Feedback Score
    0
    Shot in the dark #1: Change the casing of your AP name from "Straight Talk" to "straight talk". You never know...

    Shot in the dark #2: Your APN type of "Internet + MMS" might not be sufficient, where "default,supl,mms" is. But I can tell that your version of Android (is that ICS?) is prolly providing you a fixed set of options here. What other options do you have available for this value?

    Of course, if you are on ICS, this might be relevant to you:
    http://code.google.com/p/android/issues/detail?id=23233
    Could it be that Google has FUBAR'd you?

  11. #11
    Join Date
    Aug 2010
    Location
    USA
    Posts
    972
    Carrier
    Straight Talk
    Feedback Score
    0
    Well, tried re naming to straight talk.....nothing changed. I am running 2.2 froyo.

    And the choices are internet &mms/internet/mms

    Ps....must I restart phone if I change any settings?

    Sent from my SGH-T959 using Tapatalk

  12. #12
    Join Date
    Jan 2006
    Posts
    73
    Carrier
    T-Mobile
    Feedback Score
    0
    Sorry to be off topic , but why straightalk T mobile compatible ? get the prepaid TM SIM and a 30$ plan ...

    I think 99% of ST strenght is the att part , because real att prepaid plans suck (and that's if they exist)..

  13. #13
    Join Date
    Aug 2010
    Location
    USA
    Posts
    972
    Carrier
    Straight Talk
    Feedback Score
    0
    Quote Originally Posted by mahanddeem View Post
    Sorry to be off topic , but why straightalk T mobile compatible ? get the prepaid TM SIM and a 30$ plan ...

    I think 99% of ST strenght is the att part , because real att prepaid plans suck (and that's if they exist)..
    I looked into Tmobile plan.

    $30 has limits. 1 plan has only 100 minutes (i need at least 300 & that was strict monitoring!)

    So I was all set to go with the $50 unlimited all plan. (fine print is first 100mb 4g speeds, after that throttled to 100kb) people on TM boards were saying it is horrible.

    Believe me, I went over my options first.....unless you can tell me something I missed maybe?

  14. #14
    Join Date
    Aug 2010
    Location
    USA
    Posts
    972
    Carrier
    Straight Talk
    Feedback Score
    0
    Here is my latest reply from ST forums:

    Hi jkool. Straight Talk does not support the email feature on the phone but we do provide instructions because there are times that it will allow to do that. Do you have an option on the phone to configure your email? You may try that and check if that will work. Thanks!

  15. #15
    Join Date
    Feb 2012
    Posts
    182
    Carriers
    BYOD ST T-Mobile
    Feedback Score
    0
    Here are my setting for my GNex. I had no problems with MMS:
    My apn settings are:

    APN: wap.tracfone
    Proxy: empty
    Port: empty
    MMSC: http://mms.tracfone.com
    MMS proxy: 216.165.155
    MMS port: 8080
    MCC: 310
    MNC: 260
    APN type: default,supl,mms

    Edit: I hope this helps

Page 1 of 4 1 2 3 4 LastLast

Similar Threads

  1. Treo 750 Gmail settings that actually work?
    By pufftissue in forum WinMo
    Replies: 8
    Last Post: 01-17-2007, 12:52 PM
  2. [T-Mobile] MMS settings for Nokia 6600?
    By sempai in forum Symbian/S60
    Replies: 7
    Last Post: 12-02-2003, 05:59 PM
  3. Need T-Mobile MMS Settings
    By zoostar in forum Nokia
    Replies: 3
    Last Post: 10-23-2003, 04:36 PM
  4. Replies: 1
    Last Post: 07-12-2003, 04:28 PM
  5. T Mobile MMS Settings
    By Dark Knight in forum Nokia
    Replies: 1
    Last Post: 04-03-2003, 11:53 AM

Tags for this Thread

Bookmarks