Page 1 of 2 1 2 LastLast
Results 1 to 15 of 20

Thread: Nexus 4 Straight Talk AT&T APN settings

  1. #1
    Join Date
    Jan 2013
    Posts
    27
    Feedback Score
    0

    Nexus 4 Straight Talk AT&T APN settings

    Sorry if this has been asked before, which I'm sure it has, but I have been looking all over the Internet for a straight answer from people using the Nexus 4 on ATT ST: what are all of your APN settings? I've been finding most people saying this, and it's what I'm using, but MMS isn't working at all;

    Name: Straight Talk
    APN: att.mvno
    Proxy: not set
    Port:80
    Username: not set
    Password: not set
    Server: not set
    MMSC: http : / / mmsc . Cingular . com (remove spaces)
    MMS Proxy: 66.209.11.33
    MMS Port: 80
    MCC: 310
    MNC: 410
    Authentication type: not set
    APN Type: default,supl,mms
    APN Roaming Protocol: IPv4
    Bearer: unspecified

    Please help me, guys. I do not want to call ST and be put on hold all day again...

  2. #2
    Join Date
    Mar 2011
    Posts
    954
    Carrier
    Straight Talk
    Feedback Score
    0

    Re: Nexus 4 Straight Talk AT&T APN settings

    Change MMS proxy to 66.209.11.32 and try that.

    Also if your data stops working, change your APN from att.mvno to wap.tracfone as from what I told from customer service when my data MMS stopped working, these are the new edited APN settings being put into place. Instantly fixed mine. Att.mvno doesn't work anymore for me, neither does the 66.209.11.33 MMS proxy.

    Sent from my PantechP9070 using HowardForums

  3. #3
    Join Date
    Jan 2013
    Posts
    27
    Feedback Score
    0
    Still not working. Can send MMS but cannot receive. I called ST support, was put on hold for 45 minutes, then they told me there was nothing they could do since I do not have an alternate number they can call me on. I am pretty angry about that. I shouldn't have to constantly play with APN settings until I find something that works.

    If I can get this and the "this number is not a valid Straight Talk number" message when I try to check my balance issue resolved I'll be more than happy with ST service and I definitely love my Nexus 4.

  4. #4
    Join Date
    Feb 2013
    Posts
    3
    Carrier
    Straigth Talk
    Feedback Score
    0
    It will not let me send the link because it is my first post. What worked for me was the setting shown on the Wirevalley website. It shows two different APN settings, one for Talk and SMS and the other for MMS. Do a google search: Straight talk APN settings for Nexus 4. Article: "Ultimate APN Settings for Straight Talk With ANDROID". Hope this helps. It worked for me.



    _

  5. #5
    Join Date
    Jan 2013
    Posts
    27
    Feedback Score
    0
    I'll try that, thank you.

  6. #6
    Join Date
    Aug 2012
    Posts
    22
    Feedback Score
    0

    Nexus 4 Straight Talk AT&T APN settings

    Have you gotten MMS working? I noticed you put // in your MMSC section. Try it without the //. Here is the site I got the information from.

    http:// forum.xda-developers.com / showthread.php?t=1638290 (remove spaces)

    Let me know how it goes, I was thinking of getting a Nexus 4.

  7. #7
    Join Date
    Feb 2013
    Posts
    3
    Carrier
    Straigth Talk
    Feedback Score
    0
    Everything works on my Nexus 4 including MMS.

  8. #8
    Join Date
    Jan 2013
    Posts
    27
    Feedback Score
    0
    Tried the wirevalley "ultimate apn settings". Still no luck. I'm really getting tired of bothering folks asking them to send pictures to me to test this. And thanks for the helpful input, Robbie. Maybe next time you can share your settings if everything works?

  9. #9
    Join Date
    Jan 2013
    Posts
    27
    Feedback Score
    0
    Let me know how it goes, I was thinking of getting a Nexus 4.
    That goes to a thread about Rogers in Canada. Unless I'm entering it wrong. But you should absolutely get a Nexus 4. I LOVE mine. I was wanting another iPhone, but decided on the N4 since it's half the price and unlocked. Best decision I've made in a while. Best phone on the market. The N4 has all the little things I like about the iPhone like lock screen sounds, a great keyboard, solid build quality, good ringtones/notification sounds, buttery smooth operation, etc.

    The S3 turned me off of Android. Hated the UI, thought it was leggy on things like changing screen orientation, horrible system sounds, it kept destroying my sd cards... It was just bad. Glad I gave VANILLA Android a chance. Best phone in the world.

  10. #10
    Join Date
    Feb 2013
    Posts
    3
    Carrier
    Straigth Talk
    Feedback Score
    0
    I had to delete existing APN and try it again. I could not get it to work when I just edited it from the existing APN. It was not a seamless operation and took about an hour of tinkering before I had success.
    I checked my settings and they are identical to the "Ultimate APN Settings".

  11. #11
    Join Date
    Jan 2013
    Posts
    27
    Feedback Score
    0
    Hmm... Guess I just have to wait until a day where I am around another phone since they say they can't help while I'm on my phone and I'll also need a F'N hour to wait on hold for their horrible service. What a joke.

  12. #12
    Join Date
    Jun 2011
    Posts
    80
    Feedback Score
    0
    Here are my settings for my nexus 4. For me, it was important and the most successful to have the regular APN and a SEPARATE APN specifically for MMS.

    REGULAR APN:
    Name: Straight Talk
    APN: att.mvno
    Proxy: Not Set
    Port: Not set
    username: Not set
    password: not set
    server: not set
    MMSC: http://mmsc.cingular.com
    mms proxy: not set
    mms port: not set
    MMC: 310
    MNC:410
    Authentication type: not set
    APN type: default
    APN protocol: IPv4
    APN roaming protocal: IPv4
    APN enable/disable: N/A (greyed out)
    Bearer: Unspecified

    Menu>SAVE

    MMS APN:
    Name: Straight Talk MMS
    APN: att.mvno
    Proxy: Not Set
    Port: 80
    username: Not set
    password: not set
    server: not set
    MMSC: http://mmsc.cingular.com
    mms proxy: mms2.tracfone.com
    mms port: 80
    MMC: 310
    MNC:410
    Authentication type: not set
    APN type: mms
    APN protocol: IPv4
    APN roaming protocal: IPv4
    APN enable/disable: N/A (greyed out)
    Bearer: Unspecified

    Menu>save

    Reboot then Test out by sending yourself a pic message with WIFI off.

  13. #13
    Join Date
    Jun 2011
    Posts
    80
    Feedback Score
    0
    Just a tip, if you EVER need to call straight talk, you can call 866-667-6471 and you will get a rep in less than 5 mins. they will answer as tracfone but they can assist you.

    I hope i was able to solve your issue. =]

  14. #14
    Join Date
    Jan 2013
    Posts
    27
    Feedback Score
    0
    Quote Originally Posted by drivethrurecfan View Post
    Here are my settings for my nexus 4. For me, it was important and the most successful to have the regular APN and a SEPARATE APN specifically for MMS.

    REGULAR APN:
    Name: Straight Talk
    APN: att.mvno
    Proxy: Not Set
    Port: Not set
    username: Not set
    password: not set
    server: not set
    MMSC: http://mmsc.cingular.com
    mms proxy: not set
    mms port: not set
    MMC: 310
    MNC:410
    Authentication type: not set
    APN type: default
    APN protocol: IPv4
    APN roaming protocal: IPv4
    APN enable/disable: N/A (greyed out)
    Bearer: Unspecified

    Menu>SAVE

    MMS APN:
    Name: Straight Talk MMS
    APN: att.mvno
    Proxy: Not Set
    Port: 80
    username: Not set
    password: not set
    server: not set
    MMSC: http://mmsc.cingular.com
    mms proxy: mms2.tracfone.com
    mms port: 80
    MMC: 310
    MNC:410
    Authentication type: not set
    APN type: mms
    APN protocol: IPv4
    APN roaming protocal: IPv4
    APN enable/disable: N/A (greyed out)
    Bearer: Unspecified

    Menu>save

    Reboot then Test out by sending yourself a pic message with WIFI off.
    Thank you for going so in depth with everything, especially the sending to yourself part. I've switched to these settings, but does it make any sense whatsoever that I can send pics, I can receive pics from myself, but I cannot receive pics from other people? Tested it out, got 2 different people to try and send me pics. One on Verizon towers, other on Sprint.

  15. #15
    Join Date
    Oct 2011
    Location
    USA
    Posts
    152
    Carriers
    T-Mobile prepaid
    Page Plus Cellular
    Feedback Score
    0

    Nexus 4 Straight Talk AT&T APN settings

    This is likely not the problem but wanted to mention make sure you and the person sending to you are not using a google voice number, use the actual phone number at both ends.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 35
    Last Post: 03-16-2014, 12:33 PM
  2. Replies: 19
    Last Post: 09-12-2013, 06:34 PM
  3. straight talk APN settings
    By ziontnk in forum Straight Talk
    Replies: 31
    Last Post: 09-11-2013, 02:57 AM
  4. Replies: 21
    Last Post: 04-13-2012, 02:30 PM
  5. Replies: 1
    Last Post: 03-07-2012, 04:32 PM

Tags for this Thread

Bookmarks