Page 1 of 2 1 2 LastLast
Results 1 to 15 of 18

Thread: Correct apn for straight talk sim card off a samsung galaxy s2 straight talk branded

  1. #1
    Join Date
    Feb 2010
    Posts
    640
    Feedback Score
    0

    Correct apn for straight talk sim card off a samsung galaxy s2 straight talk branded

    Hi guys, I had a Galaxy S2 straight talk version (branded) and I took the sim card and put it in on an att phone and call and text works, however, when I try to make the web and mms work, I can't. Does anyone know the right APN for a sim card out of a galaxy s2 branded phone? I tried this:

    APN: att.mvno
    Proxy: proxy.mvno.tracfone.com (also tried att2.tracfone.com)
    Port: 80
    MMS: http://mmsc.cingular.com
    Proxy: 66.209.11.33 (also tried att2.trafcone.com)
    Port: 80

    I know this settings work for an Att sim card off the web cause I had one before, the "att2.trafcone.com" I copied from the Straight Talk branded phone.

  2. #2
    Join Date
    Jan 2013
    Posts
    225
    Feedback Score
    0

    Re: Correct apn for straight talk sim card off a samsung galaxy s2 straight talk

    Remove the proxy. Leave it blank.

  3. #3
    Join Date
    Feb 2010
    Posts
    640
    Feedback Score
    0
    Quote Originally Posted by thefisch View Post
    Remove the proxy. Leave it blank.
    I tried and didn't work :/

  4. #4
    Join Date
    Jan 2013
    Posts
    225
    Feedback Score
    0

    Re: Correct apn for straight talk sim card off a samsung galaxy s2 straight talk

    Did you the same settings as the St branded s2?

  5. #5
    Join Date
    Jan 2013
    Posts
    225
    Feedback Score
    0
    At one point, I did the same thing - took the activated sim from the ST branded S2 and put it in another phone (a TM SG2). Here were the setting I used that worked:

    name - AT&T MVNO
    apn - wap.tracfone
    proxy - blank
    port - 80
    username, pw, server - blank
    mmsc - http://mmsc.cingular.com
    mms proxy - att2.tracfone.com
    mms port - 80
    mnc - 410
    auth type - none
    apn type - internet + mms + supl

    When I had the proxy set to att2.tracfone.com, the data would crawl. Removing the proxy fixed that.

  6. #6
    Join Date
    Feb 2010
    Posts
    640
    Feedback Score
    0
    Quote Originally Posted by thefisch View Post
    Did you the same settings as the St branded s2?
    Yes, I tried and didn't work. Calling straight talk said that sim its only registered to the s2 and will not work on other phones but I don't believe that. If so, how come texts and calls work?

  7. #7
    Join Date
    Jan 2013
    Posts
    225
    Feedback Score
    0
    I was also told I could not use the S2 sim in another phone, but it did work for me. This was back in early January. you could try a factory reset, deleting existing apn profiles, or asking others for the apn settings they use for the same att phone (model?) that you are trying to use. good luck.

  8. #8
    Join Date
    May 2009
    Location
    Honolulu, Hawaii
    Posts
    2,829
    Phone
    SM-N900A on GoPhone LTE, Samsung SGH-I337 (Back-Up)
    Carrier
    AT&T
    Feedback Score
    0
    Quote Originally Posted by Haulero View Post
    Yes, I tried and didn't work. Calling straight talk said that sim its only registered to the s2 and will not work on other phones but I don't believe that. If so, how come texts and calls work?
    I think the sim is locked to the S2 similar to GSM devices Straight Talk sells.

  9. #9
    Join Date
    Feb 2010
    Posts
    640
    Feedback Score
    0
    Quote Originally Posted by thefisch View Post
    At one point, I did the same thing - took the activated sim from the ST branded S2 and put it in another phone (a TM SG2). Here were the setting I used that worked:

    name - AT&T MVNO
    apn - wap.tracfone
    proxy - blank
    port - 80
    username, pw, server - blank
    mmsc - http://mmsc.cingular.com
    mms proxy - att2.tracfone.com
    mms port - 80
    mnc - 410
    auth type - none
    apn type - internet + mms + supl

    When I had the proxy set to att2.tracfone.com, the data would crawl. Removing the proxy fixed that.
    Thank you so much! That worked! I knew straight talk was wrong

  10. #10
    Join Date
    Jan 2013
    Posts
    225
    Feedback Score
    0
    well the phone I got it to work in was another S2, a different model though. TM version T989 as opposed to the branded ST S2 i777. I used it successfully (calls, sms, mms, data) for about 6-7 full days. perhaps my case was unique.

  11. #11
    Join Date
    Jan 2013
    Posts
    225
    Feedback Score
    0
    Quote Originally Posted by Haulero View Post
    Thank you so much! That worked! I knew straight talk was wrong
    glad it worked! what phone did you put the S2 sim in?

  12. #12
    Join Date
    Feb 2010
    Posts
    640
    Feedback Score
    0
    Quote Originally Posted by Elpidio View Post
    I think the sim is locked to the S2 similar to GSM devices Straight Talk sells.
    Thefisch was right

  13. #13
    Join Date
    Jan 2013
    Posts
    225
    Feedback Score
    0
    if I recall, the model number on the S2 sim is the same as the one posted for the zte merit used to bring your own device before the byod program launched. of course, the S2 is an expensive phone compared to the zte merit if that is the only purpose. not a bad backup phone though. same rules apply - you need to keep the s2 for the sim to work, if you return it to walmart the sim will eventually be deactivated.

  14. #14
    Join Date
    Feb 2010
    Posts
    640
    Feedback Score
    0
    Quote Originally Posted by thefisch View Post
    glad it worked! what phone did you put the S2 sim in?
    I'm using the Sim card on a Samsung Galaxy Note now

  15. #15
    Join Date
    Feb 2010
    Posts
    640
    Feedback Score
    0
    But I had to do some changes, internet was working but picture messaging was not working, not sending, not recieving, so I had to make some changes to the settings "thefisch" provided:

    original settings he/she said:


    name - AT&T MVNO
    apn - wap.tracfone
    proxy - blank
    port - 80
    username, pw, server - blank
    mmsc - http://mmsc.cingular.com
    mms proxy - att2.tracfone.com
    mms port - 80
    mnc - 410
    auth type - none
    apn type - internet + mms + supl

    Had to change mms settings instead of "att2.tracfone.com" I changed to "proxy.mvno.tracfone.com" and it worked! Just in case someone is having the same problem

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 03-07-2012, 04:32 PM
  2. lookin' for a ROGERS SIM CARD
    By chanman87 in forum GSM phone Buy/Sell/Trade Archive
    Replies: 0
    Last Post: 06-21-2003, 01:52 PM
  3. Hi everyone i am looking for a new sim card for FIDO
    By whiteeskimo in forum Other Buy/Sell/Trade Archive
    Replies: 0
    Last Post: 03-03-2003, 09:34 PM
  4. Looking for a used sim card
    By fidog in forum GSM phone Buy/Sell/Trade Archive
    Replies: 3
    Last Post: 02-18-2003, 11:58 AM
  5. Looking for a Mike SIM Card for i90c
    By jay123 in forum GSM phone Buy/Sell/Trade Archive
    Replies: 1
    Last Post: 11-09-2002, 09:30 PM

Bookmarks