Results 1 to 9 of 9

Thread: iMessage Activation Issue on Roam Mobility

  1. #1
    Join Date
    Nov 2009
    Location
    Niagara Falls
    Posts
    8
    Device(s)
    Storm 9530
    Carrier(s)
    Bell
    Feedback Score
    0

    iMessage Activation Issue on Roam Mobility

    I'm having issues getting my iPhone 5 to activate the iMessage eveytime I use Roam. I just recently finally got the phone unlocked thru Bell, thank god, with the cheap new rules. I was using an iPone 3Gs before because it was too expensive to get my 5 unlocked. I had no issues with the 3Gs when on Roam Mob. using iMessage. But, now that I have the 5, everytime I hop over border, it keeps saying waiting to activate for the iMessage. I have tried everything. Log out of itunes and back in. turn on and off iMessage, reboot phone etc... I called Roam support, they have no idea why its not activating. Everything else works great. data, text, calls.

    Any thoughts??

    Thanks

  2. #2
    Join Date
    Apr 2006
    Location
    Mississauga, ON
    Posts
    886
    Carrier(s)
    Koodo
    Feedback Score
    1 (100%)
    I had the same issue in December... Stayed at "Waiting for Activation" for a whole week until I came back home. This was both on an iPhone 5s and 5c.

    However, back in August, it worked fine on my iPhone 5. Not sure what the issue is but this is really annoying.

  3. #3
    Join Date
    Jun 2008
    Location
    Toronto
    Posts
    109
    Carrier(s)
    Koodo
    Feedback Score
    0
    In DC, this past week I also had "Waiting for Activation" for several days before it changed to "activation failed".

    I was able to send and receive iMessages using my AppleID during my visit, but that I usually only send/receive on my 5s using the phone number. No idea whether this is an Apple or a Roam issue.

  4. #4
    Join Date
    Nov 2009
    Location
    Niagara Falls
    Posts
    8
    Device(s)
    Storm 9530
    Carrier(s)
    Bell
    Feedback Score
    0
    When you were using iMessage I assume you were sending with your email address through your Apple ID?

    My feeling is the iOS is what is causing the issue. I use to have an old 3GS and used in Vegas last year with no issues at all. As soon as I unlocked my 5 and tried it with the newer iOS 7 is when my issues started.


    via the HoFo App

  5. #5
    Join Date
    Jun 2008
    Location
    Toronto
    Posts
    109
    Carrier(s)
    Koodo
    Feedback Score
    0
    Yes, I ended up just using my email address/AppleID since my contacts all had iMessage.

  6. #6
    Join Date
    Jan 2013
    Posts
    25
    Feedback Score
    0
    yeah I would think if you only used your email address then there shouldn't be a problem. I would think the problem is that your current phone number is associated with your imessage and because you have another sim/number its causing problems. You can go into itunes and disable your current phone number and activate your roam number to be associated with the roam account. That may do it

  7. #7
    Join Date
    Dec 2007
    Posts
    48
    Feedback Score
    0
    FWIW I've had the same issue with both of my recent uses of Roam, including this week.

    I've not found a solution so far.

    Dave Ings

  8. #8
    Join Date
    Dec 2003
    Location
    Hamilton ON or Myrtle Beach SC
    Posts
    346
    Device(s)
    iPhone 6+ FIDO
    Feedback Score
    0
    Try removing / deleting all text messages. Reboot phone. When a new message comes in, it will have to recreate the imessage.
    FIDO Network


  9. #9
    Join Date
    Jun 2008
    Location
    Toronto
    Posts
    109
    Carrier(s)
    Koodo
    Feedback Score
    0

    it works now

    Was just in Seattle and my Roam number activated properly on iMessage, so this problem seems to have been solved. I could send and receive messages as the Roam number.

Similar Threads

  1. Ultra Mobile and iMessage activation
    By success2be in forum General Prepaid discussion
    Replies: 2
    Last Post: 08-22-2013, 09:57 PM
  2. iPhone 4S activation issues on Virgin Mobile USA
    By rizzrove in forum Virgin Mobile USA
    Replies: 44
    Last Post: 12-19-2012, 08:10 AM
  3. Weird US Roaming Issue With T-Mobile MyTouch 3G?
    By mastiff78 in forum Freedom Mobile (previously Wind Mobile)
    Replies: 28
    Last Post: 07-01-2010, 06:39 PM
  4. T-Mobile Activation, Issues with Letstalk.com
    By phongh in forum T-Mobile
    Replies: 2
    Last Post: 07-28-2006, 11:21 PM
  5. activate slider v5 (virgin mobile)
    By tbonecopper in forum Verizon Wireless
    Replies: 4
    Last Post: 12-03-2003, 11:04 PM

Tags for this Thread

Bookmarks