Results 1 to 3 of 3

Thread: Can't send SMS

  1. #1
    Join Date
    May 2015
    Posts
    7
    Feedback Score
    0

    Can't send SMS

    I got a SH-01G.
    SMS was working fine, but now I can't send sms.
    I can receive without problem. Phone call and internet is fine.
    I know Im suppose to change the number in the message center under sms setting but well its not there.
    How do I fix this?

    Thank you

  2. #2
    Join Date
    Sep 2007
    Location
    Bulgaria
    Posts
    1,446
    Device(s)
    Aquos Zeta SH-01G
    Carrier(s)
    Mtel Bulgaria
    Feedback Score
    1 (100%)
    Quote Originally Posted by BioFan View Post
    I got a SH-01G.
    SMS was working fine, but now I can't send sms.
    I can receive without problem. Phone call and internet is fine.
    I know Im suppose to change the number in the message center under sms setting but well its not there.
    How do I fix this?

    Thank you
    Since I don't (yet) have this phone, I can't say for sure where the SMS center setting is located in your standard menu.
    I have two suggestions, however, hope at least one works for you:

    1. Dial *#*#4636#*#*. The "Testing" menu should open. Go to "Phone information". Scroll down and you should see the "SMSC:" field, which should be blank. Type your carrier's SMS center number there, then tap "Update".

    2. Try installing an SMS app from Google Play. Handcent SMS is a popular one and it should either auto-detect the SMSC or allow you to enter it.
    Sharp mobile devices database & tips for Sharp smartphones: http://sharp.cheeseus.org
    Selling: Near mint Sharp SoftBank 005SH: SIM unlocked, permanent root, 16 GB microSD, leather case
    Selling: Sharp Aquos Phone 007SH – The Hybrid, SIM-unlocked, permanent root, 16 GB microSD, optimised.

  3. #3
    Join Date
    May 2015
    Posts
    7
    Feedback Score
    0
    Quote Originally Posted by cheeseus View Post
    Since I don't (yet) have this phone, I can't say for sure where the SMS center setting is located in your standard menu.
    I have two suggestions, however, hope at least one works for you:

    1. Dial *#*#4636#*#*. The "Testing" menu should open. Go to "Phone information". Scroll down and you should see the "SMSC:" field, which should be blank. Type your carrier's SMS center number there, then tap "Update".

    2. Try installing an SMS app from Google Play. Handcent SMS is a popular one and it should either auto-detect the SMSC or allow you to enter it.
    I tried the first suggestion, it doesn't work.
    Still finding the option to enter the SMSC in Handcent SMS.

    I figured the problem though. So the problem is that the handset is roaming. I asked my provider for a 128bit SIM card like you suggested and they don't offer it in my country. So I can't fix that problem. So if I want data connection, I have to turn on data roaming, but when data roaming is on, SMS is off. If I want to SMS someone, I have to turn off data roaming.
    Well it's not too big of a deal since I hardly SMS anyone. I will try this one last thing, otherwise I'll try to live with it.

    Thank you though Cheebus.

Similar Threads

  1. I can't send SMS but I can receive?
    By farfromuman in forum AT&T
    Replies: 1
    Last Post: 07-10-2002, 11:49 PM
  2. you can now send sms from rogers to fido
    By bigslut in forum Rogers Wireless
    Replies: 4
    Last Post: 07-04-2002, 02:26 PM
  3. Replies: 5
    Last Post: 04-30-2002, 11:22 AM
  4. Replies: 5
    Last Post: 12-24-2001, 04:22 PM
  5. Can't send SMS vCARDS with VS
    By jroberts321 in forum General Mobile Questions and Discussion
    Replies: 0
    Last Post: 10-12-2001, 07:15 AM

Bookmarks