Results 1 to 2 of 2

Thread: Motorola RAZR with H2O problem

  1. #1
    Join Date
    Jun 2014
    Posts
    54
    Feedback Score
    0

    Motorola RAZR with H2O problem

    I have an unlocked RAZR V3 cellphone. It was originally on ATT, got it unlocked, put it on Tmobile and it worked
    fine for 2 years. Now I wanted to put it on H2O. Installed their SIM, activated it.

    RAZR w/not connect (no bars, w/not ring when called. Put the SIM into another phone that was working on H2O, it worked fine. The previously working H2O SIM exhibited the same result in the RAZR. H2O t/s had no ideas.

    Thanks in advance for any help. I have 2 other phones on H2O with no problems.

  2. #2
    Join Date
    Jun 2014
    Posts
    54
    Feedback Score
    0
    The RAZR is a 2G phone.
    AT&T is shutting down 2G in 2017.
    H2O isn't activating any new 2G service.

    It would have been nice if their T/S could have told me this but I won't complain,
    they solved the situation for me with a discounted phone.
    I'll just put the old RAZR back on Tmobile.

    I answered my own question.

Similar Threads

  1. Replies: 3
    Last Post: 03-02-2007, 06:17 AM
  2. Motorola RAZR V3 Phonebook problem! Help!!
    By Michael D in forum Motorola FAQ (Now closed, check the wiki instead)
    Replies: 7
    Last Post: 10-01-2005, 10:43 PM
  3. Poor RF in Motorola RAZR With T-Mo
    By Alien Venom in forum T-Mobile
    Replies: 46
    Last Post: 09-12-2005, 10:01 AM
  4. Motorola RAZR V3 Phonebook problem! Help!!
    By Michael D in forum Motorola
    Replies: 1
    Last Post: 09-08-2005, 07:42 AM
  5. Motorola Razr V3 MMS problems!!
    By kidfash in forum Rogers Wireless
    Replies: 1
    Last Post: 01-08-2005, 12:11 PM

Tags for this Thread

Bookmarks