I'm still on beta 1 since my iTunes requires Mac OS X 10.5 or higher. I am on 10.4.11 and that is the error I get. I put in a 10.5 disc and it says It cannot be installed on this system.