My beloved Berry 7130e has gone amuck! I saw earlier on the forums that some free games are available from the site, and wanting to take advantage of them I d/l'd four of them to try. Upon using a couple of them, my data connection was messed up! I get the message across the top "Data connection refused." I tried a reset, but that didn't help. So I called tech support, followed a bunch of instructions, reset a couple of times, and it started working again. Thinking nothing further to be the matter, I went back to doing household chores and doing this and that with it again. Upon clicking on a game again, my connection is once again screwed! Same thing: "data connection refused", as if I were out of roaming area. Nothing at all wrong with the phone feature or SMS, but no web or email. I once again call tech support, do a couple more PRL updates, still nothing! Resets by removing and replacing battery do nothing. Tried the ##000000 thingy to manually program the networking, even sent in a Host Routing Table reset message from the Advanced menu. Still no change!

What in the heck went wrong and how to fix it? I'm NEVER going to download games again if that's what does this--and even so, why can't I use something that RIM themselves puts on their site? Is Verizon being vindictive for me not paying $2.99 each for them? Did I do something to offend the RIM gods? Should I have given some change to the bum outside the restaurant last night, or tipped the waiter more? I didn't miss church last week due to staying on my Berry too much, honest!