MMS:

Got MMS working on my Nexus One, here are the settings I used:

Settings -> Wirless & Networks -> Mobile Networks -> APNs

Create a new APN and input the following:

Name: Rogers MMS
APN: media.com
Username: media
Password: mda01
MMSC: http://mms.gprs.rogers.com
MMS Proxy: 172.25.0.107
MMS Port: 80
MMC: 302
MNC: 720
APN Type: mms


The important part was that APN Type, once you input MMS in there, the APN becomes unselectable in the APNs screen as a default APN (no more green/grey circle), and MMS will work.


WAP:

Haven't figured it out, yet

Internet:

I'm not sure as I'm on prepaid and don't want to use up my balance trying, but when I had the following settings I got an SMS from Rogers telling me I was trying to use Internet without a data plan:

Name: Rogers Internet
APN: internet.com
Username: wapuser1
Password: wap
MMC: 302
MNC: 720
APN Type: default, supl

At least I think that's what they were, I've played around with it so much by now haha.

Will update as necessary if I find settings that work.