Results 1 to 3 of 3

Thread: Help with debranding/flashing Nokia 5130?

  1. #1
    Join Date
    Apr 2009
    Posts
    3
    Feedback Score
    0

    Help with debranding/flashing Nokia 5130?

    Hi, I'm a relative newbie to flashing and debranding who has done a lot of research, but I'm stuck. I debranded a Nokia 5310 before and that was relatively simple, (unfortunately the phone broke later), and I thought 5130 was much the same, but this one is something else entirely where debranding is concerned!

    I have a Tmobile Nokia 5130, white and aqua, and I really need Opera on it, so I understand I'll have to debrand it for that to work.
    My firmware versions are:
    Nokia 5130c-2
    V06.68
    11-05-09
    RM-496
    Variant 33.02

    Now, I understand that for generic firmware that works I'd have to un-update from RM-496 to RM-495. I was trying to do this through Phoenix but I'm having trouble getting it to work.

    I got a productcode of 0571373 that is supposed to help flash the right firmware on it, and this post
    http://www.dotsis.com/mobile_phone/n...30c-2-a-3.html
    gave flash files and information on how to do it with Phoenix.

    I followed to try and make it work for me. Unfortunately the 2009 version of Phoenix never showed the 'Init' button that you're supposed to press after which you give in the flash file locations. When I installed the 2010 version I tried to follow this:
    1. Connect your phone in PC Suite Mode (Nokia Mode),
    2. File > Scan product,
    3. Tools > Image file download
    4. Press download, wait for it to finish, restart Phoenix.
    5. then click scan product-
    6. then go to flashing> firmware upgrade
    7. and then check"detect pcode automaticaly"

    Unfortunately this method also never automatically detects the pcode. Instead I get a message that 'Neither DP1.0 not DP2.0 was found for the product, or product can not be identified.'

    This post
    http://www.mygsmindia.com/vbb/showthread.php?t=40821
    told me to try to install files in c:\program files\nokia\product\Rm-495 or 496 (I tried both) and use c01 file for mcu , L01 for pmm , and u01 for cnt
    but unfortunately that didn't help either.

    I don't know what to do anymore. Does anyone here have experience with this and would be willing to point me in a new direction?

  2. #2
    Join Date
    Nov 2010
    Posts
    2
    Feedback Score
    0
    Amar,
    Were you able to get this to work? I am experiencing the same situation and looking for some help.

  3. #3
    Join Date
    Jun 2009
    Location
    Central Texas
    Posts
    6
    Carrier(s)
    AT&T
    Feedback Score
    0
    Thread, I command you: ARISE FROM THE DEAD.

    I tried in vain to install Opera Mini & the beta Nokia Browser on my 5130c-2 for hours today after receiving the dreaded "Certificate not on phone or SIM" message.

    Just go to www.m.opera.com using the native browser. The website will automatically present you with a link for a custom version for T-Mobile. It's older (version 5.1.22011), but it works. Debranding & updating the security certificates is not necessary.

Bookmarks