Results 1 to 11 of 11

Thread: Faking iOS version

  1. #1
    Join Date
    Oct 2005
    Posts
    81
    Feedback Score
    0

    Question Faking iOS version

    We have an edict at work from our exchange management people, move your firmware up to 4.3.2 or you can't get your work email anymore.

    Since I'm running a iphone 4 jailbroken 4.2.1 and there's no 4.3.2 jailbreak yet (or at least one I would trust).

    SO, my question is twofold:

    1) HOW can they check if what version you have? Is that via browser, exchange, phone itself?

    2) How can I fake it to them?

    I'm am aware of two places to fake it, but I don't know if that will be enough or if they will look at those two places. Place one is the browser - there's a Cydia app for that. Place two, there is a .plist file somewhere where you actually just change it in a text file.

    is that enough? Does someone know what the hell I'm talking about?

    Thanks.

  2. #2
    Join Date
    Nov 2009
    Posts
    616
    Device(s)
    iPhone 3GS 16GB Black
    Carrier(s)
    AT&T Wireless
    Feedback Score
    0
    Why not just jb with the newest tools from the dev team? You don't trust them?
    iPhone 6 64GB Space Gray, iOS 8.1.2 stock
    iPhone 5 32GB Black, iOS 7.0.4 stock
    Week 43 3GS 16GB Black, iOS 5.1.1 stock, preserved 05.13.04 BB

  3. #3
    Join Date
    Oct 2005
    Posts
    81
    Feedback Score
    0
    sorry didn't know that was out. Is that the same as greenp0ison or is redsnow or something else?

  4. #4
    Join Date
    Nov 2009
    Posts
    616
    Device(s)
    iPhone 3GS 16GB Black
    Carrier(s)
    AT&T Wireless
    Feedback Score
    0
    From what I've read, if you need to preserve baseband for unlocking purposes using a custom IPSW, use pwnagetool (Mac) or sn0wbreeze (Windows). If you don't care about unlocking you can use redsn0w for either Mac or Windows. Someone can correct me if I'm wrong.

  5. #5
    Join Date
    Jun 2010
    Location
    Edmonton
    Posts
    462
    Carrier(s)
    Bell Mobility
    Feedback Score
    0
    Quote Originally Posted by PatrickGSR94 View Post
    From what I've read, if you need to preserve baseband for unlocking purposes using a custom IPSW, use pwnagetool (Mac) or sn0wbreeze (Windows). If you don't care about unlocking you can use redsn0w for either Mac or Windows. Someone can correct me if I'm wrong.
    precisely
    10 chars

  6. #6
    Join Date
    Apr 2006
    Location
    Toronto, Canada
    Posts
    502
    Device(s)
    Launch Apple iPhone 11 Pro Max (Factory Unlocked)
    Carrier(s)
    Telus
    Feedback Score
    0
    Dude, the official jailbreak came out over a week ago already. I used redsnow on windows and don't have any issues with it at all.

  7. #7
    Join Date
    Oct 2005
    Posts
    81
    Feedback Score
    0
    Fantastic then. I have that same car, but 2001.5, boosted to oblivion...very fun

  8. #8
    Join Date
    Oct 2005
    Posts
    81
    Feedback Score
    0
    Assuming I don't want to upgrade though, is this possible? Does anyone know how Exchange Server would "know" my version.

  9. #9
    Join Date
    Jul 2004
    Location
    Downtown Chicago
    Posts
    3,260
    Device(s)
    Motorola Atrix HD Maxx / iPhone 5 (backup)
    Carrier(s)
    AT&T
    Feedback Score
    0
    Quote Originally Posted by gazoo66 View Post
    Assuming I don't want to upgrade though, is this possible? Does anyone know how Exchange Server would "know" my version.
    Yes. Most of the Cydia apps that fake your OS version only change one plist file the reports OS version. There are also browser user agent strings that contain the iOS version. This is transmitted to the Exchange server as well.
    Seems like it is cool to have these in your sig?

  10. #10
    Join Date
    Oct 2005
    Posts
    81
    Feedback Score
    0
    I loaded user agent faker and put in the agent of a 4.3.2 device under custom and it wouldn't get my mail anymore until I stopped it. I even changed the plist with the firmware version on it and no dice. The ban will be in effect on Friday and I'm running out of options. 4.3.3 came out and now I can't get 4.3.2 (actually don't know how) and there's no jb for that yet.

    I had my friend with 4.3.2 non jb go to whats my useragent dot com and used that exact string.

  11. #11
    Join Date
    Jun 2007
    Location
    Portland
    Posts
    642
    Device(s)
    iPhone 4 (iOS 6.1.2)
    Carrier(s)
    AT&T
    Feedback Score
    0
    If you have your blobs, you can install an older iOS. However, there is a JB for 4.3.3. Check the dev team's site for details.

Similar Threads

  1. Replies: 5
    Last Post: 10-02-2010, 01:23 PM
  2. Replies: 1
    Last Post: 09-23-2010, 08:51 PM
  3. Replies: 8
    Last Post: 07-28-2010, 02:08 PM
  4. Replies: 9
    Last Post: 07-28-2010, 02:08 PM
  5. Verizon software update issues (leaked version to official version)
    By Eric N. in forum Windows Mobile (Before 7)
    Replies: 3
    Last Post: 07-29-2009, 11:14 AM

Tags for this Thread

Bookmarks