Results 1 to 13 of 13

Thread: iPhone 5 iOS 6.1.4 Straight Talk AT&T Issues

  1. #1
    Join Date
    Jun 2013
    Posts
    8
    Feedback Score
    0

    iPhone 5 iOS 6.1.4 Straight Talk AT&T Issues

    I just recently purchased an Unlocked Brand New iPhone 5 and a Straight talk AT&T sim card.
    I have iOS 6.1.4.

    I watched tons of videos and read many posts and was able to get ALMOST everything to work.
    I can make phone calls, send text, send pictures, and browse the internet.

    The ONE thing I cannot do is RECEIVE PICTURE MESSAGES, but I can send picture messages just fine.
    The only settings that worked for me are as follows:
    Net10 Carrier APN Settings (tfdata)
    Cellular Data
    APN tfdata
    MMS
    APN tfdata
    MMSC http://mms-tf.net

    MMS Proxy mms3.tracfone.com:80
    MMS Max Message Size 1048576
    Use these values for the Net10 AT&T Compatible SIM

    Finally I used the tfdata settings (Under part 10 under notes) and before resetting my phone, while at the settings menu, I turned on Airplane Mode then turned it back off off again before resetting my phone. I think this helped me save my settings. Anyway long story short everything working great now!

  2. #2
    Join Date
    Jun 2013
    Posts
    6
    Feedback Score
    0

    Can send but not receive MMS iPhone Straight Talk AT&T

    So I'm confused, and am having the exact same issue where I can send but not receive MMS.

    Are you saying that when you enabled/disabled airplane mode before rebooting the phone, this fixed it? (EDIT: I tried this also and am still not able to receive MMS, although send continues to work fine.)

    I've tried everything and have not been able to receive MMS using the provided settings.


    Quote Originally Posted by RoysElement View Post
    I just recently purchased an Unlocked Brand New iPhone 5 and a Straight talk AT&T sim card.
    I have iOS 6.1.4.

    I watched tons of videos and read many posts and was able to get ALMOST everything to work.
    I can make phone calls, send text, send pictures, and browse the internet.

    The ONE thing I cannot do is RECEIVE PICTURE MESSAGES, but I can send picture messages just fine.
    The only settings that worked for me are as follows:
    Net10 Carrier APN Settings (tfdata)
    Cellular Data
    APN tfdata
    MMS
    APN tfdata
    MMSC [...]

    MMS Proxy [...]
    MMS Max Message Size 1048576
    Use these values for the Net10 AT&T Compatible SIM

    Finally I used the tfdata settings (Under part 10 under notes) and before resetting my phone, while at the settings menu, I turned on Airplane Mode then turned it back off off again before resetting my phone. I think this helped me save my settings. Anyway long story short everything working great now!
    Last edited by Andromedo; 06-15-2013 at 04:37 PM.

  3. #3
    Join Date
    Jun 2013
    Posts
    8
    Feedback Score
    0
    Negative. That is my issue STILL. I can do everything, except send picture messages. Can anyone help or have any insight?


    Quote Originally Posted by Andromedo View Post
    So I'm confused, and am having the exact same issue where I can send but not receive MMS.

    Are you saying that when you enabled/disabled airplane mode before rebooting the phone, this fixed it? (EDIT: I tried this also and am still not able to receive MMS, although send continues to work fine.)

    I've tried everything and have not been able to receive MMS using the provided settings.

  4. #4
    Join Date
    Jun 2013
    Posts
    6
    Feedback Score
    0
    Wait, you mean you can do everything except RECEIVE MMS, right? That is what you said in your first post, and the issue I can't seem to resolve.

    Quote Originally Posted by RoysElement View Post
    Negative. That is my issue STILL. I can do everything, except send picture messages. Can anyone help or have any insight?

  5. #5
    Join Date
    Jun 2013
    Posts
    8
    Feedback Score
    0
    Andromedo, Correct. I REALLY hope someone else can chime in and help.

  6. #6
    Join Date
    Jun 2013
    Posts
    6
    Feedback Score
    0
    Quote Originally Posted by RoysElement View Post
    Andromedo, Correct. I REALLY hope someone else can chime in and help.
    To save others the trouble, here are a few things I've tried that didn't fix the issue:

    • Using the legacy att.mvno settings published everywhere in both data and MMS sections (didn't work at all, although this is the only one I would try again)
    • Using tfdata settings for the primary apn and the att.mvno settings for MMS (data worked but MMS not at all)
    • Using the tfdata APN, but legacy mms2.tracfone.com:80 MMS proxy (could send MMS but not receive, same behavior as the published mms3 settings)
    • Using the tfdata APN, but 66.209.11.33:80 proxy (could send MMS but not receive, same behavior as the published mms3 settings)


    This is a factory unlocked iPhone 5, running non-jailbroken iOS 6.1.4, using the inactive T-Mobile SIM/multitask trick to gain access to the Mobile Network APN settings.

  7. #7
    Join Date
    Jun 2013
    Posts
    6
    Feedback Score
    0
    Adding another wrinkle... Yesterday the phone seemed to have dropped the APNs I programmed using the above method (even though they survived the original power cycle I did after entering them) for no apparent reason.

    For now I am using the profile installed from http iapnupdatetfdata dot straighttalk dot com through Safari. Data works, but as advertised, MMS does not work at all.

    I guess I am going to wait for a jailbreak for 6.1.4 and go from there.

    Pretty despicable that a full-price "unlocked" iPhone isn't really thus.
    Last edited by Andromedo; 06-18-2013 at 07:24 PM.

  8. #8
    Join Date
    Apr 2009
    Posts
    175
    Feedback Score
    0
    Recently I was given an AT&T unlocked i5 to use and I have a AT&T sim from Straight Talk the i5 ios is 6.1.4 so I used the tmobile sim to input the APN,
    Cellular Data
    apn-att.mvno
    MMS
    apn-att.mvno
    MMSC-http://mmsc.cingular.com
    MMS Proxy-66.209.11.33:80
    MMS MAX-1048576
    MMS UA PROF URL-http://www.apple.com/mms/uaprof.rdf
    This has been working fine and can send receive pic's But once in a while I do have to input the settings again.I don't do airplane mode or reboot I just test and seems to work fine.
    I did notice in that first post said they were using Straight talk AT&T sim,why put net10 apn setting's in?

  9. #9
    Join Date
    Jun 2013
    Posts
    6
    Feedback Score
    0
    For newly (re)activated SIMs, they are pointing us to APNs that look a lot like the ones for NET10.

    The old att.mvno settings don't seem to work at all for newly activated SIMs. In addition to a brand-new one, I had one that had expired under the old settings. When I reactivated I had to use the "tfdata" APN or it didn't work.

    The new ones are listed at http www dot straighttalksim dot com slash support.php

  10. #10
    Join Date
    Jun 2013
    Posts
    6
    Feedback Score
    0
    I found another thread where this seems to be an issue for people on the new APN:

    http:<slashslash>forum.xda-developers.com/showthread.php?t=2310215&page=3

    No fix as of yet as far as I'm aware, but it looks to be an issue on the ST side, based on one gentleman's logcat output.

  11. #11
    Join Date
    Apr 2009
    Posts
    175
    Feedback Score
    0
    I sat up last night and updated to IOS 7 and did sim swap with the settings I posted and sent some mms to some friends and they sent them back those settings are working fine. I go to home screen and pop Tom ole sim in then go to cellular (iOS 7 a little different in setting's) it takes a minute or so to show APN then pop sim out put ST SIM in and input the settings close out and open messages and send text pic ask them to send some pic's. That's it I don't use the airplane mode ,don't hit reset cause that will wipe the settings you just entered. Don't reboot just use it. The only thing I've had to do is input settings once a month

  12. #12
    Join Date
    May 2012
    Posts
    28
    Feedback Score
    0
    Straight talk also uses AT&T Network and that is why iTunes never shows you confirmation of phone unlocked.

  13. #13
    Join Date
    Apr 2009
    Posts
    175
    Feedback Score
    0
    Straight talk also uses AT&T Network and that is why iTunes never shows you confirmation of phone unlocked.

    That is incorrect,I just restored from IOS 7 B2 to IOS 6.1.2 on iTunes 11.04 and it show Congratulation your phone has been unlocked. It's an AT&T i4 I've had for couple years and had AT&T unlock it when they first agreed to do so.

Similar Threads

  1. Replies: 111
    Last Post: 04-22-2014, 10:59 PM
  2. Replies: 4
    Last Post: 01-10-2013, 10:44 AM
  3. Replies: 9
    Last Post: 08-21-2012, 09:18 PM
  4. Verizon iphone 4g/4gs used with Straight Talk?
    By iSteve in forum Straight Talk
    Replies: 1
    Last Post: 07-14-2012, 10:15 PM
  5. Help with Iphone 3gs Straight Talk AT&T 3g issues
    By Justin Miltz in forum Straight Talk
    Replies: 4
    Last Post: 01-07-2012, 08:43 PM

Tags for this Thread

Bookmarks