Results 1 to 4 of 4

Thread: Can't sign into Simple Mobile account

  1. #1
    Join Date
    Feb 2012
    Location
    Roanoke, TX
    Posts
    50
    Carrier(s)
    MintSIM
    Feedback Score
    0

    Can't sign into Simple Mobile account

    Anyone else having account based issues? I attempted to sign in earlier and got a message that my username or password is incorrect, yet I am positive it is correct. I called up support and they reset my password and sent a new one to my account, however it still gives me an incorrect username or password error when I try and sign in. I had my sister who also has Simple Mobile try to login and got the same error. My account is fully paid and my end of the month isn't till the 26th so it definitely isn't a lapse in service. Anyone else having this problem?

  2. #2
    Join Date
    Sep 2012
    Posts
    1,804
    Feedback Score
    0
    Time to switch to a better T-Mobile MNVO.

  3. #3
    Join Date
    Jan 2014
    Location
    North Florida
    Posts
    590
    Device(s)
    Samsung Galaxy S8 Active
    Carrier(s)
    T-Mobile, Lycamobile, Sprint, Tello, Freedompop
    Feedback Score
    0
    Quote Originally Posted by nick944 View Post
    Anyone else having account based issues? I attempted to sign in earlier and got a message that my username or password is incorrect, yet I am positive it is correct. I called up support and they reset my password and sent a new one to my account, however it still gives me an incorrect username or password error when I try and sign in. I had my sister who also has Simple Mobile try to login and got the same error. My account is fully paid and my end of the month isn't till the 26th so it definitely isn't a lapse in service. Anyone else having this problem?
    It seems unlikely, but have you tried a different browser? Last year or two ago, back when I had a relative on SM their OLAM site was cranky about certain browsers. Try Palemoon Palemoon.org for a change, I have been trying it out. It's a fork of Firefox.

  4. #4
    Join Date
    Feb 2012
    Location
    Roanoke, TX
    Posts
    50
    Carrier(s)
    MintSIM
    Feedback Score
    0
    Quote Originally Posted by Vertabrae View Post
    It seems unlikely, but have you tried a different browser? Last year or two ago, back when I had a relative on SM their OLAM site was cranky about certain browsers. Try Palemoon Palemoon.org for a change, I have been trying it out. It's a fork of Firefox.
    Nope, wasn't a browser issue. I found several others with issues signing in. In the end it was an issue on their end with accounts, they didn't admit it, but a day later I could sign in just fine.

Similar Threads

  1. Replies: 2
    Last Post: 10-02-2006, 10:02 PM
  2. hmm can't get into my blogger account.
    By ken.vs.ryu in forum SonyEricsson
    Replies: 5
    Last Post: 08-19-2006, 01:58 PM
  3. Replies: 2
    Last Post: 05-19-2006, 07:05 PM
  4. Replies: 3
    Last Post: 12-02-2003, 03:30 PM
  5. Problems signing into MSN Mobile on my 8390
    By PacoMonkey in forum Rogers/Fido/Chat-r
    Replies: 9
    Last Post: 10-05-2003, 06:48 PM

Tags for this Thread

Bookmarks