Hi all,

Around the time of the upgrade to Jellybean this winter my mobile payment functionality stopped working on my Bell Mobility HTC One M8 using the RBC app. Have tried everything I can think of including a recent factory reset and Bell, RBC and HTC techs have no answers for me. Was just looking to see if anybody with the phone has exactly the same problem after the Jellybean upgrade, or can otherwise shed some light on things?


-Mobile payments were working fine for me from time of purchase in October to around late January/early February
-Phone/Data is read by point-of-sale machines but rejected with 'Card not accepted' or 'No valid application' type errors (a Moneris website documents those errors as being related to purchases exceeding the amount for tap limits, but my actual card will tap fine after the phone fails)
-NFC otherwise functioning as per other apps like Card Readers

-new SIM (twice) from Bell
-cleared RBC app data and cache and uninstalled/rebooted/reinstalled multiple times
-deleted and reactivated payment cards within app
-HTC tech had me boot into an alternate menu and clear some cached files related to the OS upgrade
-on a fresh install on the app had my son use his RBC credentials and try his debit card with the same result, which should eliminate my account as the source of the issue
-tried to get Bell to allow me to put my SIM into one of their other phones temporarily to try a payment at a business next door but they had no process that would allow that/make that possible

I don't want to send my phone away and get some refurb only to have it all still not work. This very much feels like a software or process problem, though my knowledge of how everything works together in mobile payments is limited.