Results 1 to 11 of 11

Thread: IPhone 7+ cannot connect to LTE

  1. #1
    Join Date
    Jun 2006
    Posts
    379
    Feedback Score
    0

    IPhone 7+ cannot connect to LTE

    Hopefully an expert can help me here. I have a factory unlocked iPhone 7+ bought from Apple that I used on Straight Talk/ATT successfully with full LTE service for months.

    Last week I switched to ATT GOPHONE for the North America roaming, more data and lower price. After porting, the phone never connected to LTE and only shows 4G with slower speeds.

    I've had no less than 6 phone calls with ATT USA based advanced tech support and they tell me they've tried everything to provision the phone or the account properly. I've heard excuses that porting can take 3 days to fully finish or the system is not recognizing my IMEI. I've changed SIM cards and even took this SIM card and put it into an actual GOPHONE to test - and still 4G on ATT's own phone. I know it's not my phone.

    I'm hoping someone here knows what to do next. Should I cancel the account and have them create a fresh account and port my number over? I've already wiped network settings multiple times, been reprovisioned multiple times and even wiped and restored the entire phone. I can't manually edit the APN and have no way of knowing if I have the correct NEXTGENPHONE APN and the unlockit.nz.co website APNs are out of date and don't fix my problem.

  2. #2
    Join Date
    Jun 2006
    Posts
    379
    Feedback Score
    0
    For reference, my speed test is 3mbs down and 0.21 up across 4 different tests.

  3. #3
    Join Date
    May 2007
    Location
    SID 246
    Posts
    2,656
    Device(s)
    iPhone XS, Galaxy S9, iPhone SE
    Carrier(s)
    MetroPCS, T-Mobile, RedPocket Verizon, Tello
    Feedback Score
    0

    IPhone 7+ cannot connect to LTE

    Quote Originally Posted by bocastephen View Post
    Hopefully an expert can help me here. I have a factory unlocked iPhone 7+ bought from Apple that I used on Straight Talk/ATT successfully with full LTE service for months.

    Last week I switched to ATT GOPHONE for the North America roaming, more data and lower price. After porting, the phone never connected to LTE and only shows 4G with slower speeds.

    I've had no less than 6 phone calls with ATT USA based advanced tech support and they tell me they've tried everything to provision the phone or the account properly. I've heard excuses that porting can take 3 days to fully finish or the system is not recognizing my IMEI. I've changed SIM cards and even took this SIM card and put it into an actual GOPHONE to test - and still 4G on ATT's own phone. I know it's not my phone.

    I'm hoping someone here knows what to do next. Should I cancel the account and have them create a fresh account and port my number over? I've already wiped network settings multiple times, been reprovisioned multiple times and even wiped and restored the entire phone. I can't manually edit the APN and have no way of knowing if I have the correct NEXTGENPHONE APN and the unlockit.nz.co website APNs are out of date and don't fix my problem.
    1. It can't be the APN as if it was with the way AT&T is you wouldn't get data at all.

    2. What was the actual gophone you tested it with? Not all GoPhones are LTE compatible. If it was indeed an LTE device then yes something is screwed up.

    3. How long has it been since port? And you can receive texts and calls right? That's a sign that the port is done.

    4. You can't port your number to the same carrier. You can only port out to another carrier.



    What do you see under Settings, Mobile Data, Mobile data options, enable LTE? What 3 settings do you see there?


    Sent from my iPhone using Tapatalk
    Current Phone: AT&T XS Silver 256GB. T-Mobile / MetroPCS
    Android device : Galaxy S9 RedPocket Verizon

    I am no longer a U.S.Cellular User.
    Speedtest in Knox.TN EvDo Rev.A

    My Photography www.hunterspad.com

  4. #4
    Join Date
    Jun 2006
    Posts
    379
    Feedback Score
    0
    I tested with the free Samsung phone they gave me. The box has the 4G/LTE logo.

    The port was done on Thursday and I was able to get calls and texts almost right away.

    For the LTE settings I have Off, voice and data or data only and I've tried toggling those on and off endlessly.

    Can they create a fresh account with a new SIM and transfer my phone number and account balance?

  5. #5
    Join Date
    May 2007
    Location
    SID 246
    Posts
    2,656
    Device(s)
    iPhone XS, Galaxy S9, iPhone SE
    Carrier(s)
    MetroPCS, T-Mobile, RedPocket Verizon, Tello
    Feedback Score
    0
    Yeah it should be good to go then.

    And for the settings I was just making sure Go Phone was still the same as AT&T just make sure it's always set to data or voice and data only.

    Not sure on that one they might can move it. But I doubt they'd be willing to. But I've never done that

    Very strange it's definitely something going with your account area for two phones to not work on LTE. Have another AT&T sim or prepaid sim to test in that same place? Or go to an AT&T store and show them.

    Its most likely some sort of weird provisioning problem. Only issue I've had in that way was just VoLTE when changing between iPhone and Android.


    Sent from my iPhone using Tapatalk

  6. #6
    Join Date
    Feb 2014
    Location
    Los Angeles or Santa Cruz during the school year
    Posts
    1,242
    Device(s)
    AT&T iPhone Xs
    Carrier(s)
    AT&T
    Feedback Score
    0
    Get the IMEI of an iPhone at the AT&T store, then call AT&T and say you've changed phones, give them that IMEI. Then take the sim out of your phone, reboot it and try to turn LTE on. This should work, if not take the phone to Apple and try and get a warranty replacement

    Sent from my SM-G950U using Tapatalk

  7. #7
    Join Date
    Jul 2004
    Posts
    621
    Device(s)
    iPhone 7 Plus
    Carrier(s)
    Verizon Wireless, AT&T
    Feedback Score
    0
    I had the same problem when I ported my lines to att back in October. All of them were Verizon iPhones so they were unlocked. All only got 4G no LTE. Multiple call to tech support and finally new SIM cards and some magic from them and all is working. So it's prolly a network issue in their side.
    Alex
    Teamsters Local 399
    "American by birth, teamster by the grace of God"

  8. #8
    Join Date
    Jun 2006
    Posts
    379
    Feedback Score
    0
    Thanks everyone. I went back to the store and they imputed a IMEI from the sales reps own iPhone then we changed the SIM card one more time and it finally worked!

  9. #9
    Join Date
    Feb 2014
    Location
    Los Angeles or Santa Cruz during the school year
    Posts
    1,242
    Device(s)
    AT&T iPhone Xs
    Carrier(s)
    AT&T
    Feedback Score
    0
    Quote Originally Posted by bocastephen View Post
    Thanks everyone. I went back to the store and they imputed a IMEI from the sales reps own iPhone then we changed the SIM card one more time and it finally worked!
    Glad to hear! How are your speeds now?

    Sent from my SM-G950U using Tapatalk

  10. #10
    Join Date
    Jun 2007
    Location
    Greater Los Angeles
    Posts
    10,168
    Device(s)
    iPhone 11 Pro Max Series 4 Apple Watch
    Carrier(s)
    T-Mobile USA
    Feedback Score
    15 (100%)
    Quote Originally Posted by nicothetechguy View Post
    Get the IMEI of an iPhone at the AT&T store, then call AT&T and say you've changed phones, give them that IMEI. Then take the sim out of your phone, reboot it and try to turn LTE on. This should work, if not take the phone to Apple and try and get a warranty replacement

    Sent from my SM-G950U using Tapatalk
    That is what I did. Countless calls to tech support sent me nowhere.

    I went to my local AT&T store. Asked the rep to use a demo IMEI then activate a new SIM. In that order.

    If I would of known it was that easy I would have never called countless CSR's to begin with.
    “The Internet wasn’t meant to be metered in bits and bytes, so it’s insane that wireless companies are still making you buy it this way. The rate plan is dead — it’s a fossil from a time when wireless was metered by every call or text.” John Legere 1/5/2017

  11. #11
    Join Date
    May 2015
    Posts
    248
    Carrier(s)
    verzion
    Feedback Score
    0
    When you change Sims cards did the phone do a carrier update

    Sent from my VS987 using HoFo mobile app

Similar Threads

  1. iPhone 5 Cannot connect to iTunes store
    By tang2007 in forum Apple
    Replies: 1
    Last Post: 09-22-2012, 12:54 AM
  2. Replies: 13
    Last Post: 06-24-2009, 05:42 AM
  3. iPhone EDGE issue after phone call "cannot connect to cellular network?"
    By mach1andy in forum iOS Jailbreaking and Unlocking
    Replies: 2
    Last Post: 08-08-2008, 06:03 PM
  4. Replies: 1
    Last Post: 04-28-2008, 05:13 PM
  5. Itunes cannot connect to iphone
    By cohen11 in forum iOS Jailbreaking and Unlocking
    Replies: 2
    Last Post: 02-01-2008, 04:21 PM

Bookmarks