I have been using my Sprint unlimited 4G LTE plan for over a year, upgrading from a Franklin R850 to a Sierra Wireless MC7455 miniPCIe 4G LTE modem, which is installed in an Oley USB adapter, downloaded some firmware, moved the SIM card to the USB adapter, then connected it to a ZBT WE826 Router, which is running LEDE.

I bought a couple of ASUS RT-AC68U routers, and have a mesh network in my house. The router has a provision for a 4G USB WAN mode, as well as a dual WAN setup. Problem is, my modem isn't on the list of compatible modems, and I have tried manually setting it up, with no success. Could it be the router is not connecting to the USB modem because it needs to be in QMI mode instead of MBIM?

I tried to find the pertinent AT commands to change it over from MBIM to QMI mode, just to see if it works, but cannot find the command I need. I was able to log in on the router page, but the AT!USBCOMP command is about all I know. Sierra Wireless has a 200 page manual, which was way more than I need.

Any ideas?