Results 1 to 4 of 4

Thread: My experience with T-Mobile in Playa Del Carmen, Mexico

  1. #1
    Join Date
    Feb 2016
    Posts
    2,398
    Device(s)
    Sonim XP8, iPhone XS, Pixel 3 XL
    Carrier(s)
    SouthernLINC, T-Mobile, Verizon
    Feedback Score
    0
    vBActivity - Stats
    vBActivity - Bars

    My experience with T-Mobile in Playa Del Carmen, Mexico

    Just returned home from 7 days at a resort in Playa Del Carmen, QR, MX and thought I’d share my experience with T-Mobile and AT&T..

    I have the One Plus International feature which is grandfathered, but I was able to have T-Force add it on my tablet line and one other new line.

    When we landed at the Cancun airport my phone connected to Telcel LTE. The shuttle ride between the airport and resort landed me on HSPA+ a few time.

    Overall speeds were consistent at the resort hitting speeds of over 100Mbps on LTE and 16Mbps on HSPA+. I also had working VoLTE.

    Telcel uses B4 for LTE and 850MHz for HSPA+ so walking deep through the resort landed me on HSPA+ a few times.
    I did find my phone connecting to Movistar a few times but a manual network selection change quickly fixed that. Movistar was 4-5Mbps on 1900MHz.

    I also had an AT&T US Postpaid line on my eSIM and let me just tell you, the experience was horrible. AT&T ran LTE on B5 and HSPA+ on Band 4. Speeds were consistently 1-2Mbps dipping down to 200kbps during peak times and roaming on Telcel was throttled to 128Kbps.

    I turned off my AT&T line most of the time.

    Verizon roamed on Telcel LTE but no VoLTE and speeds throttled at 500MB per day.
    Sprint only connected to Movistar HSPA+.

    Interesting note to add is that I had VoLTE and HD calling back to the US to other T-Mobile subscribers with minimal latency.

    I used 25GB of roaming because the WiFi at the resort was inconsistent compared to Telcel.





    And as you can see AT&T was terrible.



    Sent from my iPhone using HoFo
    Last edited by CircuitSwitched; 06-17-2019 at 04:40 PM.

  2. #2
    Join Date
    Aug 2008
    Posts
    14,527
    Feedback Score
    0
    vBActivity - Stats
    vBActivity - Bars
    Quote Originally Posted by CircuitSwitched View Post
    Overall speeds were consistent at the resort hitting speeds of over 100Mbps on LTE and 16Mbps on HSPA+. I also had working VoLTE.
    Great report.

  3. #3
    Join Date
    Aug 2010
    Posts
    1,358
    Device(s)
    iPhone XS Max
    Carrier(s)
    T-Mobile
    Feedback Score
    0
    vBActivity - Stats
    vBActivity - Bars
    Scary ping no Fortnite for you huh?


    Sent from my iPhone using Tapatalk

  4. #4
    Join Date
    Feb 2016
    Posts
    2,398
    Device(s)
    Sonim XP8, iPhone XS, Pixel 3 XL
    Carrier(s)
    SouthernLINC, T-Mobile, Verizon
    Feedback Score
    0
    vBActivity - Stats
    vBActivity - Bars
    Quote Originally Posted by p6B5Nm5b View Post
    Scary ping no Fortnite for you huh?


    Sent from my iPhone using Tapatalk
    Don’t game whatsoever 🤷*♂️. The latency was high but not nearly as noticeable as the 800ms on ViaSat.

    Web browsing and watching lectures for class and uploading photos weren’t really affected by that.

    I even attended my class virtually via video and the delay wasn’t extremely noticeable.


    Sent from my iPhone using HoFo

Similar Threads

  1. My Experience with ECO Mobile
    By Churchland in forum General Prepaid discussion
    Replies: 26
    Last Post: 01-16-2017, 11:27 AM
  2. My Experience with Wind Mobile
    By wwwkris in forum Freedom Mobile (previously Wind Mobile)
    Replies: 12
    Last Post: 06-10-2011, 04:39 PM
  3. My Experience with Simple Mobile
    By fuzed in forum General Prepaid discussion
    Replies: 107
    Last Post: 07-22-2010, 03:46 AM
  4. My experience with T-Mobile Tracfone
    By progvsmetal in forum Tracfone/Net10
    Replies: 3
    Last Post: 10-22-2008, 08:30 PM
  5. what's your experience with t-mobile in MN like
    By timhorton1998 in forum T-Mobile
    Replies: 1
    Last Post: 09-26-2002, 11:02 PM

Bookmarks