Page 3 of 3 FirstFirst 1 2 3
Results 31 to 43 of 43

Thread: Cannot login to PPC

  1. #31
    Join Date
    Aug 2012
    Posts
    74
    Feedback Score
    0
    Quote Originally Posted by rpz1 View Post
    That's what mine always looks like, not your first example. On your screen shot the log in button is already hi-lited so you shouldn't need to reload capcha.
    Just got off an extensive chat session (transferring a number and balance to another phone) and going through my account which has 4 phones to confirm all was correct. No issues. Always https. Sometime the capcha pictures to select pop up before the red log in button hi-lites, sometime it's already hi-lited to click with no capcha needed, sometime i need to click reload capcha to get the red button to hi-lite. Win7, Firefox. (I don't use their app on a phone).
    So I guess this Captcha anomaly has nothing to do with the root cause of my problem. Thanks for confirming that!

  2. #32
    Join Date
    Mar 2013
    Posts
    19
    Feedback Score
    0
    I've been having this exact problem since August. I've called PPC many times, they are no help and say there is nothing they can do. I'm about to just find another MVNO, sad.

    Anyone find a solution?

  3. #33
    Join Date
    Sep 2016
    Posts
    1,297
    Feedback Score
    0
    Quote Originally Posted by mEnTL32 View Post
    I've been having this exact problem since August. I've called PPC many times, they are no help and say there is nothing they can do. I'm about to just find another MVNO, sad.

    Anyone find a solution?
    It's not Page Plus, it's your browser or ISP configuration. If you don't think that's the case, explain why so many of us have no issues? I had to change my Tracking settings in Firefox in order to chat. I had to do the same thing on the TW website and even my local phone company. It's not PPC unique. Others have done other things which had nothing to do with PP. Look back at the posts. Good luck, and I'll continue to keep my fingers crossed.

  4. #34
    Join Date
    Mar 2013
    Posts
    19
    Feedback Score
    0
    Quote Originally Posted by rpz1 View Post
    It's not Page Plus, it's your browser or ISP configuration. If you don't think that's the case, explain why so many of us have no issues? I had to change my Tracking settings in Firefox in order to chat. I had to do the same thing on the TW website and even my local phone company. It's not PPC unique. Others have done other things which had nothing to do with PP. Look back at the posts. Good luck, and I'll continue to keep my fingers crossed.
    I also stopped receiving emails from PagePlus around the same time. Just to check, I had my email admin go through the logs and sure enough there have been zero emails since August. This matches the time others have started complaining.

    In addition, when I call to make changes to my account the rep has to wrestle with it for about 10 mins. Last night, they finally gave up and said they couldn't cancel my monthly autopay due to "an error their tool was giving."

    I do appreciate the response, but I don't think my browser settings are causing all this. I really do wish this was the case. For completeness, I tried it this morning on an Ubuntu VM w/ Firefox. Same deal.

    I've been a customer for 8 years. I hate to have to leave them but I have tried everything.

  5. #35
    Join Date
    Aug 2012
    Posts
    74
    Feedback Score
    0
    Quote Originally Posted by rpz1 View Post
    It's not Page Plus, it's your browser or ISP configuration. If you don't think that's the case, explain why so many of us have no issues? I had to change my Tracking settings in Firefox in order to chat. I had to do the same thing on the TW website and even my local phone company. It's not PPC unique. Others have done other things which had nothing to do with PP. Look back at the posts. Good luck, and I'll continue to keep my fingers crossed.
    I don't think so. It happens on multiple devices and ISP's, including on the cell phone utilizing cellular data for the connection. Also as previously mentioned, the customer service representatives seem to be getting similar errors trying to access parts of the account (such as password reset) using their tools. No errors accessing other things like chat or any other websites.

    It must be something to do with the account age or plan setup or something else related to account properties, which is why it doesn't affect everyone. When it does affect someone, it is a hard brick wall.

  6. #36
    Join Date
    Apr 2004
    Posts
    7,079
    Device(s)
    Moto Z4 (Vzw), Moto Z Play (PP)
    Carrier(s)
    Verizon Wireless, Page Plus
    Feedback Score
    0
    I make sure I do the Captcha first. If you don't get the Captcha popup quickly, wait for it. If you wait a long time (I never had), possibly click on the Captcha re-load?

    Once you pass the Captcha test, then enter your email and password.

  7. #37
    Join Date
    Sep 2016
    Posts
    1,297
    Feedback Score
    0
    Quote Originally Posted by cparke View Post
    I don't think so......................
    Thx. That's why I continue to keep my fingers crossed. So far, so good.

  8. #38
    Join Date
    Mar 2013
    Posts
    19
    Feedback Score
    0
    Just checking in one last time.. anyone have any luck? I still can't log in and I got my US Mobile SIM today.

    ETA: Forgot to mention that when I contacted them today they originally had my number as "not part of their network." Simple mistake or more symptoms? Anything is possible. They said this AFTER asking for my PIN.. so strange. Eventually they "found" my account.

  9. #39
    Join Date
    Aug 2012
    Posts
    74
    Feedback Score
    0

    Finally!

    Today I tried to login to Page Plus again, just to see if there was any progress.

    Eureka!

    Looks like they finally fixed the issue, or it just went away by itself after 2 months. When I finally got into the website, for the first time ever, I found there was no phone number registered. Maybe that's how they fixed it (by removing the phone)?

    Like all things related to América Móvil, you can try all you want to try to get them to fix an issue, but in some cases there's really nothing you can do but just wait and pray!

  10. #40
    Join Date
    Apr 2016
    Posts
    279
    Feedback Score
    0
    Quote Originally Posted by rpz1 View Post
    It's not Page Plus, it's your browser or ISP configuration. If you don't think that's the case, explain why so many of us have no issues? I had to change my Tracking settings in Firefox in order to chat. I had to do the same thing on the TW website and even my local phone company. It's not PPC unique. Others have done other things which had nothing to do with PP. Look back at the posts. Good luck, and I'll continue to keep my fingers crossed.
    Would you say what that is and what that means? (See the italicized bold.)

  11. #41
    Join Date
    Sep 2016
    Posts
    1,297
    Feedback Score
    0
    Quote Originally Posted by joseg2016 View Post
    Would you say what that is and what that means? (See the italicized bold.)
    Turn off Enhanced Tracking Protection for the website in FireFox. Right click the little shield symbol to the left of the web site address.

  12. #42
    Join Date
    Apr 2016
    Posts
    279
    Feedback Score
    0
    Quote Originally Posted by rpz1 View Post
    Turn off Enhanced Tracking Protection for the website in FireFox. Right click the little shield symbol to the left of the web site address.
    I believe you mean, "left-click" the little shield to the left of the site address. I say this because while I have FireFox open, I began to try your instructions.

  13. #43
    Join Date
    Sep 2016
    Posts
    1,297
    Feedback Score
    0
    Quote Originally Posted by joseg2016 View Post
    I believe you mean, "left-click" the little shield to the left of the site address. I say this because while I have FireFox open, I began to try your instructions.
    Yes correct, it's left click. Thx.

Page 3 of 3 FirstFirst 1 2 3

Similar Threads

  1. I cannot login on PPC website.
    By salsal in forum Page Plus Cellular
    Replies: 1
    Last Post: 08-22-2017, 02:03 PM
  2. Cannot Login To My T-Mobile.Com Account
    By nyctechogirl in forum T-Mobile
    Replies: 11
    Last Post: 07-02-2014, 11:15 AM
  3. Cannot login to WAP site
    By Alan_S in forum Forum Feedback & Help
    Replies: 3
    Last Post: 11-18-2008, 05:40 AM
  4. Cannot login to Tmobile site
    By dangerkick in forum Danger
    Replies: 1
    Last Post: 04-16-2005, 02:37 PM
  5. cannot login to online account
    By acizurqpid in forum Verizon Wireless
    Replies: 5
    Last Post: 02-03-2004, 10:40 PM

Tags for this Thread

Bookmarks