Page 1 of 2 1 2 LastLast
Results 1 to 15 of 18

Thread: HELP! Notifications of any kind not showing up when receiving texts (moto g power 2020)

  1. #1
    Join Date
    May 2011
    Posts
    116
    Feedback Score
    0

    HELP! Notifications of any kind not showing up when receiving texts (moto g power 2020)

    As title says, I get nothing, nothing. I've gone into notifications, sounds, and every inch of the phone including reading online how to alert me when I have a text message. One youtube shows I should get an icon on bottom of screen (when sleeping) that stays there until I wake it up, and I should get a banner display on top of the woken up screen with the text. I don't even get a #1 or 2 or number of texts I might have by the message icon. I get none of this. One thing I did see is a half a second tiny pop up dot that popped up so fast and went away never to return. Can't even tell what it was for.

    I tested this 8 times so far with someone sending me texts, upon checking all my settings and I would not have known I received said texts if I didn't know they were coming. I get them but only see them if I open the text message icon and SEE them there. This is not good. I'm a caregiver for my elder mom so I need to hear and see at a glance when texts come in via notification and I don't even get a sound (thought I want more than a sound).

    Perfer not to download a different app for texts.

    Anyone know the precise settings, though I have all mine on. Somethings not right. I even rebooted the phone, and have the latest software version. HELP!! BTW, got the phone from HSN if that matters.

  2. #2
    Join Date
    Jul 2008
    Location
    Virginia
    Posts
    3,862
    Feedback Score
    0
    Install Textra from the Google Play Store. It is a lot simpler than the original Messages and just gets to the point. Texts and MMS, no fancy clutter. Then try again.

    https://play.google.com/store/apps/d...?id=com.textra

  3. #3
    Join Date
    Jul 2016
    Location
    The Swamp
    Posts
    1,422
    Device(s)
    Moto G Stylus, Moto G4 Play
    Carrier(s)
    Liberty Wireless, FreedomPop, Red Pocket (AT&T & Verizon)
    Feedback Score
    0
    What do you see when you go into settings and look under;
    Sound/Advanced/Default Notification Sound?

    Also does the phone ring when you get a phone call.

    Sent from my moto g stylus using HoFo mobile app

  4. #4
    Join Date
    Oct 2014
    Posts
    8,258
    Device(s)
    LG Q7+, LG Journey, LG Stylo 4+
    Carrier(s)
    TF/AT&T, TF/Verizon, FreeUp
    Feedback Score
    0
    I don't have a Moto G, so I'm offering this info based on my Moto E6.

    - Run the Messages app, touch the 3 dots in the upper-right corner, select Settings-->Notifications. Make sure the notifications that you want are turned on.
    - If the Chat feature is turned on, turn it OFF. When it's on, it does weird things, like sending even plain text as MMS which requires Data to be on, not notifying you of incoming messages until Data is turned on, etc.

    Name:  Moto-E6-Message-Settings-1.jpg
Views: 64
Size:  28.8 KB

    Name:  Moto-E6-Message-Settings-2.jpg
Views: 63
Size:  23.3 KB

    Name:  Moto-E6-Message-Settings-3.jpg
Views: 64
Size:  25.3 KB

  5. #5
    Join Date
    May 2011
    Posts
    116
    Feedback Score
    0
    Quote Originally Posted by Digital Rules View Post
    What do you see when you go into settings and look under;
    Sound/Advanced/Default Notification Sound?

    Also does the phone ring when you get a phone call.

    Sent from my moto g stylus using HoFo mobile app
    The default notification sound is set to the moto sound.

    The phone rings with a customer sound I set it to so they are not the same sound.

  6. #6
    Join Date
    Feb 2009
    Location
    West Central Iowa
    Posts
    1,278
    Device(s)
    Galaxy J7 Sky Pro SM-S727VL, Galaxy J3 Sky SM-S230VL, ZTE Z723EL, ZTE Z233VL
    Carrier(s)
    Straight Talk, Total Wireless
    Feedback Score
    0
    RCS aka chat settings does use the data or LTE side because it is a part of the IMS system that even does VoLTE and other things.

  7. #7
    Join Date
    Sep 2011
    Location
    California Gold Country
    Posts
    7,919
    Feedback Score
    0
    I have the same problem of no notifications for missed calls and voicemail, but do get them for texts. The missed calls do show in my dialer history, and voicemails are in the VVM folder. I used to get a red dot in the dialer icon, an audible notice, and a visual notice in the notification bar with unread calls and voicemail. This would all work even when the phone was woke up from Airplane mode or being turned on. Stopped about 6 months ago, and should work from all the notification settings. Moto G5 Plus with Android 8.1 and stock dialer.

  8. #8
    Join Date
    May 2011
    Posts
    116
    Feedback Score
    0
    Quote Originally Posted by hpham View Post
    I don't have a Moto G, so I'm offering this info based on my Moto E6.

    - Run the Messages app, touch the 3 dots in the upper-right corner, select Settings-->Notifications. Make sure the notifications that you want are turned on.
    - If the Chat feature is turned on, turn it OFF. When it's on, it does weird things, like sending even plain text as MMS which requires Data to be on, not notifying you of incoming messages until Data is turned on, etc.

    Name:  Moto-E6-Message-Settings-1.jpg
Views: 64
Size:  28.8 KB

    Name:  Moto-E6-Message-Settings-2.jpg
Views: 63
Size:  23.3 KB

    Name:  Moto-E6-Message-Settings-3.jpg
Views: 64
Size:  25.3 KB
    The settings in Moto G Power are very different, so hard to follow. There is no chat to turn on or off with this phone. Still trying to find a solution.

  9. #9
    Join Date
    Oct 2014
    Posts
    8,258
    Device(s)
    LG Q7+, LG Journey, LG Stylo 4+
    Carrier(s)
    TF/AT&T, TF/Verizon, FreeUp
    Feedback Score
    0
    Quote Originally Posted by djkkk View Post
    There is no chat to turn on or off with this phone.
    The Chat feature is part of the Messages app. Its setting (if exists) is among the Settings for the Messages app. On my phones, it's the 1st one in the Settings for Messages.

  10. #10
    Join Date
    May 2011
    Posts
    116
    Feedback Score
    0
    Quote Originally Posted by hpham View Post
    The Chat feature is part of the Messages app. Its setting (if exists) is among the Settings for the Messages app. On my phones, it's the 1st one in the Settings for Messages.
    Ok. I see where the chat feature is and turned it off. Still no notification SOUND of a text received, no # showing at the message icon that there is a message, or a notification when screen is sleeping that there is a message. The only notification I see is a banner that just says "1 junk message". Not sure why it won't send me a sound to alert me.

    Just had my # transferred today so I've been playing. This one might be going back if I can't find a fix.

    Thanks all for your replies.

  11. #11
    Join Date
    May 2011
    Posts
    116
    Feedback Score
    0
    Here's a short video that shows how text message notifications should work with the Moto G Power. What is shown here is exactly what I want to see with my phone, but I don't. https://www.youtube.com/watch?v=gkkVUXgTrDM
    Last edited by djkkk; 02-08-2021 at 08:55 PM.

  12. #12
    Join Date
    Jun 2007
    Location
    Seattle
    Posts
    659
    Device(s)
    NUU X6 Plus
    Carrier(s)
    Hello Mobile, US Mobile
    Feedback Score
    0
    I have a similar issue with the installed apps on my nuu x6 plus with what looks like stock Android 10. (Aka no obvious nuu bloatware)

    Sent from my S6003L using HoFo mobile app
    Drako Swiftclaw

    Webmaster for Drako's Website Services
    Review Team Member for Drako's Wireless Review
    Independent Tech for DTech Seattle

  13. #13
    Join Date
    Jun 2007
    Location
    Seattle
    Posts
    659
    Device(s)
    NUU X6 Plus
    Carrier(s)
    Hello Mobile, US Mobile
    Feedback Score
    0
    Found out Android 10 has TWO locations that control notifications. The first is the obvious one in the Notifications settings, the second is called DuraSpeed - which controls which apps are allowed to run in the background. If the app is not able to run in the background, it is unable to send you push notifications until the app opens up.

    I went into the DuraSpeed options in the settings and turned on all apps to run in the background and now I'm getting all my notifications.

    Though if you have apps on your device you'd rather not get notifications from (or you consider bloatware) you can leave them turned off and they won't run in the background or send notifications. (Helpful if you have apps that do things you don't want, like change your lock screen.)

  14. #14
    Join Date
    May 2005
    Location
    San Francisco
    Posts
    2,211
    Device(s)
    LG G4, Galaxy S7 Edge, Note 4
    Carrier(s)
    T-Mobile, FreedomPop, TracFone
    Feedback Score
    0
    Quote Originally Posted by jmac32here View Post
    Found out Android 10 has TWO locations that control notifications. The first is the obvious one in the Notifications settings, the second is called DuraSpeed - which controls which apps are allowed to run in the background. If the app is not able to run in the background, it is unable to send you push notifications until the app opens up.

    I went into the DuraSpeed options in the settings and turned on all apps to run in the background and now I'm getting all my notifications.

    Though if you have apps on your device you'd rather not get notifications from (or you consider bloatware) you can leave them turned off and they won't run in the background or send notifications. (Helpful if you have apps that do things you don't want, like change your lock screen.)
    I never heard of DuraSpeed so I Googled it and it seems like its not part of Android, but a third party task killer app from MediaTek that Motorola, LG, Nokia and possible others pre-install on some phones. Android doesn't need task killers, I recommend that you uninstall or disable it if you can.
    Find and compare prepaid plans at https://prepaidcompare.net

  15. #15
    Join Date
    Jun 2007
    Location
    Seattle
    Posts
    659
    Device(s)
    NUU X6 Plus
    Carrier(s)
    Hello Mobile, US Mobile
    Feedback Score
    0
    Quote Originally Posted by Yeswap View Post
    I never heard of DuraSpeed so I Googled it and it seems like its not part of Android, but a third party task killer app from MediaTek that Motorola, LG, Nokia and possible others pre-install on some phones. Android doesn't need task killers, I recommend that you uninstall or disable it if you can.
    Then why is it fully integrated into the settings on Android 10, is also on Android 9+, and is not listed as an APP?
    For my Android 10, its a System App V 3.0 and not something shown in the App Store. Makes me wonder if Google adopted it.

    So apparently, its a MediaTek system service so any device using MediaTek hardware will get it as a system service:
    "On Mediatek-based devices, HMD has baked in DuraSpeed as a system service. There is no user-facing control, or whitelist; this Mediatek-developed task killer terminates all background apps without prejudice."
    https://dontkillmyapp.com/nokia

    It appears that Nokia is the bigger brand that gets DuraSpeed as a system service on devices using MediaTek chips, but apparently it's not limited to Nokia since I have noticed several other brands having it as a system service as well. So it must be any device using MediaTek chips.
    (My NUU X6 Plus uses the MediaTek MT6761D processor.)

    Since it is a system service on devices using MediaTek chips, you can disable it, but not uninstall it. However, disabling it or turning it off in the settings as been proven to not be permanent - and it will restart itself if you reboot the device.

    Did find out the updated version I have actually does have "prejudice" since you can now decide which apps are allowed to run in the background, and there is not permanent option to disable it as a system service. However, if you do have a version like mine, allowing apps to run in the background is considered part of the settings and will stay set as you set them even after a reboot.
    (I simply decided to allow all apps on my device to run in the background myself.)

    Now I'm curious.. and it looks like its a hardware to system service sort of thing.

    So now, I would suggest going through all settings and any apps to see if any are preventing apps from running in the background. Seems its becoming a common thing. Adaptive Battery, Put apps to sleep, ect.
    Last edited by jmac32here; 02-12-2021 at 09:27 PM.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 06-10-2010, 03:03 PM
  2. Replies: 3
    Last Post: 04-23-2010, 12:08 PM
  3. Replies: 2
    Last Post: 11-30-2007, 01:58 PM
  4. Replies: 9
    Last Post: 02-17-2005, 01:08 AM
  5. Contacts Names not showing up when they call
    By Chris8169 in forum General Nextel Discussion
    Replies: 9
    Last Post: 04-10-2004, 01:12 AM

Bookmarks