boom! Mobile

I was looking around the portal this morning. I watched one of the videos in the instructions section. It was showing how to change info in your profile. When they showed how to change it from the account tab section, where all the info is on the left of the screen, when they clicked save...it reverted to what it was before the change!!!!
And at least in my account, the save button from the profile section accessed from the "My Profile" button when you click the profile picture doesn't do a thing. I can't change anything there. And I still can't change the password.
Also, the old system had a pin that you could change. I see no area for a pin.

Sent from my moto g stylus 5G (2022) using HoFo mobile app
 
When you go to the Boom home page before you log-in you get the pic of the race car. After you log-in I still get my home page that is blank. Nothing except the menu items on the top. I hope they're still working on it.
 
When you go to the Boom home page before you log-in you get the pic of the race car. After you log-in I still get my home page that is blank. Nothing except the menu items on the top. I hope they're still working on it.
Their video under instructions shows that there will be things to click on, on that page, to get info.
It's definitely still under construction, I have found way too many issues for something supposed to be live.

Sent from my moto g stylus 5G (2022) using HoFo mobile app
 
I think would be porting to US Mobile if it wasn't after noon on a Friday (where I'm at). I'm loath to port going into a weekend.

Didn't the PIN used to be the last 4 digits of your phone number?
 
I think would be porting to US Mobile if it wasn't after noon on a Friday (where I'm at). I'm loath to port going into a weekend.

Didn't the PIN used to be the last 4 digits of your phone number?
Yes, that is what the pin was.
Agreed, this is not the time to start a port!

Sent from my moto g stylus 5G (2022) using HoFo mobile app
 
retail page works, customer page doesn't(24 hours for me).
Boom didn't autopay on 1st, they did next day, but I was without data for a day without being able to access customer page with WiFi.
If I had called they probably would have paid the bill.
 
Folks using Boom may want to check to see if their voicemail box is working. Realized today that my voicemail box generates a busy signal and people are unable to leave a message. No idea how long this has been happening as I usually answer the phone. Not able to access the voice mail box either by *86 or calling my own number from my cell phone. Get a busy signal. Box isn't full (only four messages, which are playable through the VVM app on Android). Put in a Boom support ticket to see what the issue is.

Edit: Boom support "refreshed" the voicemail and had me turn off the phone for 10 minutes. Can now access the voice mail box via *86 and by calling my phone number, but now the Android Call app voicemail feature cannot connect to voicemail mail box. Indicates to contact customer service at (800) 922-0204 and tell them error code is 9004. Or a slightly different message that says its error code 9999. Boom support bumped the issue up to "IT support".
 
Last edited:
Folks using Boom may want to check to see if their voicemail box is working. Realized today that my voicemail box generates a busy signal and people are unable to leave a message. No idea how long this has been happening as I usually answer the phone. Not able to access the voice mail box either by *86 or calling my own number from my cell phone. Get a busy signal. Box isn't full (only four messages, which are playable through the VVM app on Android). Put in a Boom support ticket to see what the issue is.

Edit: Boom support "refreshed" the voicemail and had me turn off the phone for 10 minutes. Can now access the voice mail box via *86 and by calling my phone number, but now the Android Call app voicemail feature cannot connect to voicemail mail box. Indicates to contact customer service at (800) 922-0204 and tell them error code is 9004. Or a slightly different message that says its error code 9999. Boom support bumped the issue up to "IT support".
Checked my VM. Working normally. I appreciate the heads up though!
Oops! Spoke too soon, the voicemail feature in the app gives the message about not connecting to my voicemail. And, I can't leave a voicemail, got the busy signal. But I could call and check messages. Guess I'll be contacting support.

Sent from my moto g stylus 5G (2022) using HoFo mobile app
 
Checked my VM. Working normally. I appreciate the heads up though!
Oops! Spoke too soon, the voicemail feature in the app gives the message about not connecting to my voicemail. And, I can't leave a voicemail, got the busy signal. But I could call and check messages. Guess I'll be contacting support.

Sent from my moto g stylus 5G (2022) using HoFo mobile app
And now it's totally down. Interesting that originally I had no problem checking my voicemail.

Sent from my moto g stylus 5G (2022) using HoFo mobile app
 
Checked a few minutes ago and the Android calling app still cannot correctly access voicemail. It now displays the following message:

"Activating visual voicemail
You might not receive voicemail notifications until visual voicemail is fully activated. Call voicemail to retrieve new messages until voicemail is fully activated."
 
Checked a few minutes ago and the Android calling app still cannot correctly access voicemail. It now displays the following message:

"Activating visual voicemail
You might not receive voicemail notifications until visual voicemail is fully activated. Call voicemail to retrieve new messages until voicemail is fully activated."
I haven't gotten that one yet. Regular retrieval and leaving of messages is working. I'm just getting the message with the 9004 error. I have contacted boom support.

Sent from my moto g stylus 5G (2022) using HoFo mobile app
 
Now it's gone back to showing the 9004 error and to call service.
 
I have been going back and forth with support. They had me reset all the network connections. Yay for having to put in all the saved passwords and reconnect Bluetooth devices. It partially solved the problem. It now seems to work as long as I'm on cellular data. But I get nothing, no notification at all of any kind while connected to a WiFi network. As soon as I turn off the WiFi connection I receive the notifications and have the ability to play the voicemails within the app.
They tell me this is the way it's supposed to work and they can't help. I thought it might be a vpn issue but I turned it off.
Pretty disappointed in boom. Unfortunately I made the decision a few weeks ago to use one of their annual plans. I should have just switched to us mobile.

Sent from my moto g stylus 5G (2022) using HoFo mobile app
 
Apparently VVM is broken when on WiFi even with cell data still enabled. Bah. At least I can get a VM notification when on WiFi as long as I keep VVM off.

Sent from my moto g stylus 5G (2022) using HoFo mobile app
 
Back
Top