CORRECT TMobile GPRS/t-zones settings for Microsoft Smartphones

dupasquier

New member
Joined
Nov 6, 2001
Messages
508
Location
New York City
Carrier(s)
T Mobile & Swisscom
Device(s)
Blackberry 7100T
I have owned a MPx220 since last November and my biggest frustration has been my inability to access my TMobile t-zones page (wap.myvoicestream.com) with the connections settings I had. Multiple phone calls to TMobile didn't help and I was starting to think that the MPx220 was the cause of my inability to access this page as I could connect to any other html or wap site with the connections settings I had.

After researching this board, I found a few threads that have the correct settings and I thought I should (re)post them as a picture tutorial as I think some of you might have the same issue I used to have and also for every new Microsoft Smartphone user who have a TMobile plan.

ALL the credit of these settings should go to HoFo members jleecong (first one to post the settings on HoFo), fuzzie (for the port 8080 info) and vinayp (for additional DNS info). In addition to this tutorial, you can find jleecong's tutorial here, for alternative settings.

1. Go to Start - Settings - Data Connections
Settings_DataConnections.bmp



2. Menu - Edit Connections
editconnections.bmp



3. GPRS Connections
gprs0.bmp



4. Delete every GPRS connection already set in this window (having another connection might cause problems).
5. Menu - Add
gprs1.bmp



6. Fill up as follow
gprs2.bmp

gprs3.bmp



6. Press Done and you will have the following screen
gprs4.bmp



7. Press Done and go to Proxy Connections
proxy0.bmp



8. Delete every Proxy connection already set in this window (having another connection might cause problems).
9. Menu - Add
proxy1.bmp



10. Fill up as follow
proxy2.bmp

proxy3.bmp



11. Press Done and you will have the following screen
proxy5.bmp



12. Press Done twice and set as follow
dataconections.bmp



13. Press Done twice, open Internet Explorer, Menu, Options, Connections and set as follow
ie_connections.bmp



14. Press Done twice and you should be ready to go!


Some of you might wonder why the TMobile/t-zones wapsite (wap.myvoicestream.com) is so important to me and to other TMobile customers.
I think this is one of TMobile's most underrated feature as one can customize from it's computer, on the TMobile website (go to www.tmobile.com, login, click "communication tools", click "Add or edit on-demand alerts", click "t-zones settings") which information (local weather, movie schedule, stocks, news, scores, horoscopes and lottery) one can access in a few seconds on his cellphone.

For instance, it takes me less than 20 seconds to find out at what times "Constantine" is playing at my local movie theater (as shown below). Just for the Movie feature alone, the t-zones wapsite is fantastic!

t-zones_mytheaters.bmp

z-zones_mytheaters1.bmp

t-zones_mytheater2.bmp
 
Worked like a charm! First time in months I've seen the ole t-zones site. Thanks!
 
Great! I am glad you tried them.
I have asked a Mod to make this thread "sticky", not sure which Mod to ask though as we don't have any mod here...
 
It was the bit about setting the connections to "Automatic" and IE to "WAP Network" that burned me before. Never even thought about either setting. If you haven't, you should post this (with pix) over at www.modaco.com Or if you'd prefer, I would be happy to do so for you, giving proper credit, of course.
 
markgamber said:
It was the bit about setting the connections to "Automatic" and IE to "WAP Network" that burned me before. Never even thought about either setting. If you haven't, you should post this (with pix) over at www.modaco.com Or if you'd prefer, I would be happy to do so for you, giving proper credit, of course.
I actually have these already posted at MoDaCo but they never got stickied.

http://www.modaco.com/index.php?showtopic=119111
 
Great work!:haveadrin I needed tzones to check my balance. Anyway how did you get that movie thing....i never seen that before.
 
10651 said:
Great work!:haveadrin I needed tzones to check my balance. Anyway how did you get that movie thing....i never seen that before.
You should be able to setup your local movie theaters using the TMO website and then check the times of your local theaters from your handset.

From the T-Zones homepage.
My Settings
My Movies
 
Just and FYI.... I just got my unlocked MPX220 and followed these instructions after trying many other suggestions. I still could not browse though....well, the problem is that NO ONE with only t-zones access will be able to browse on this phone. Once I upgraded to an actual internet plan, everything works great! It sucks to pay 19.99 a month, but maybe I can get the MPX to serve as a modem for my laptop too now.

Thanks for the info...I'm glad I finally got this thing working.

Chad
 
I can acess espn and google and other sites but can access t-zones page. It says

your request for a service could not be fullfilled. Please try again or contact your operator if the problem persists.
 
Racerinlsl said:
Just and FYI.... I just got my unlocked MPX220 and followed these instructions after trying many other suggestions. I still could not browse though....well, the problem is that NO ONE with only t-zones access will be able to browse on this phone.
Incorrect!

It is post like yours that we now have a sticky of how to get the internet working with 4.99 T-Zones.

Here is a blog entry I found sending traffic to my T-Zones config page.
blog.jpg



4.99 Internet works with Microsoft Smartphones so long as it's setup correctly.
 
jleecong said:
Incorrect!

It is post like yours that we now have a sticky of how to get the internet working with 4.99 T-Zones.

Here is a blog entry I found sending traffic to my T-Zones config page.
blog.jpg



4.99 Internet works with Microsoft Smartphones so long as it's setup correctly.

Okay, well the settings above, as well as all others I can find would not work. So can you refer me to the correct settings? Mine would not work no matter what, but the day I upgraded to the 19.99 plan, everything worked fine. Help!
 
Racerinlsl said:
Okay, well the settings above, as well as all others I can find would not work. So can you refer me to the correct settings? Mine would not work no matter what, but the day I upgraded to the 19.99 plan, everything worked fine. Help!
LOL

If you only knew how many hours I have put in on this topic. I've done my time and welcome others work (dupasquier) as when I got it working I stopped playing with settings.

Long story short I'm fine for you to say setting don't work for you. I have had a few people that no matter what I told them to try it wouldn't work. I have had 100s more that is HAS worked for.

The problem I have is when you state "NO ONE with only t-zones access will be able to browse on this phone." because that is false and causes confusion just like the author of the blog article.

Check the port 80 sticky (pg 3,4) and you can read a lot more on how things started.
http://www.howardforums.com/showthread.php?s=&threadid=518666&perpage=15&pagenumber=3
 
Can someone help he access the t zones site?

I now can access a lot of sites, even complex sites with full graphics I can see which is really awesome! but for some reason I dont get the simple t zones wap site. I didnt use the net on the phone much (I have unlimited t zones for 2.99) but now that I can use most of the web on the go, I'll use it everyday.
 
Stupid Question

I've entered all the settings as shown -- no connection. Now here's the stupid question: Do I need to insert a username and password?
 
Re: Stupid Question

jsamuels said:
I've entered all the settings as shown -- no connection. Now here's the stupid question: Do I need to insert a username and password?
No.
 
jleecong said:
LOL

If you only knew how many hours I have put in on this topic. I've done my time and welcome others work (dupasquier) as when I got it working I stopped playing with settings.

Long story short I'm fine for you to say setting don't work for you. I have had a few people that no matter what I told them to try it wouldn't work. I have had 100s more that is HAS worked for.

The problem I have is when you state "NO ONE with only t-zones access will be able to browse on this phone." because that is false and causes confusion just like the author of the blog article.

Check the port 80 sticky (pg 3,4) and you can read a lot more on how things started.
http://www.howardforums.com/showthread.php?s=&threadid=518666&perpage=15&pagenumber=3

Is it really a problem for you? Do you have to be so snide? Did I hurt your feelings?

Look, I've tried these settings with 4 different phones, 4 different users, and it didn't work for any of us. Okay, I guess these settings do work for others w/ 4.99 t-zones, but no body that I know. :doh:
 
Racerinlsl said:
Is it really a problem for you? Do you have to be so snide? Did I hurt your feelings?

Look, I've tried these settings with 4 different phones, 4 different users, and it didn't work for any of us. Okay, I guess these settings do work for others w/ 4.99 t-zones, but no body that I know. :doh:
You lying isn't a problem for me. Just don't post your lies where I can see them or I will feel the need to correct you. Again I'm fine for you to say "doesn't work for me" but "can't be done with 4.99 T-Zones" is a flat out lie and you should be correct.

Not trying to be derogatory in a mean way. (Did I hurt your feelings?)

As I said before check the port 80 thread in the T-Mobile forum. I've already gone to great lengths to prove it works for people like you who just can't seem to believe it's possible. I'm not trying to be nasty, belittle you, or put you down in any way. If you would like to send me your phone I will guarantee it works in my area.

If the setting don’t work for you do what dupasquier, fuzzie, vinayp, or myself did and and figure out the correct settings.

If you would like to continue this we should move it to PMs per HoFos Rules.
 
When I first read this thread, nothing was said about if this was supposed to work w/ 4.99 t-zones or not. Now that I've read the links you posted to modaco, I see what's been going on. I am late to the argument. I'm not sure what I should try though. I had my setting identical to those at the top of this thread and it just wouldn't work. I called to upgrade, and the next morning, it was working. I think I'll go back to the 4.99 plan and try to make it work again. It's not worth 19.99 just to access my email at this point. If you have any tips, let me know....am I wrong in having my settings EXACTLY as they are posted in the first post of this thread?
 
Racerinlsl said:
When I first read this thread, nothing was said about if this was supposed to work w/ 4.99 t-zones or not. Now that I've read the links you posted to modaco, I see what's been going on. I am late to the argument. I'm not sure what I should try though. I had my setting identical to those at the top of this thread and it just wouldn't work. I called to upgrade, and the next morning, it was working. I think I'll go back to the 4.99 plan and try to make it work again. It's not worth 19.99 just to access my email at this point. If you have any tips, let me know....am I wrong in having my settings EXACTLY as they are posted in the first post of this thread?


I am using the $4.99 T-zones in SoCal on my MPX220 and I can access everything. The settings on the first post are wrong for me, and didn't work, but maybe they work for others in other parts of the coutry. I went through the whole gamut of settings for a week and could not get it to work, but then I finally saw something else I hadn't tried, tried it, and boom!, it worked

Here's my settings (I wish I knew how to insert screenshots but I don't): If your like me, you have messed around enough with these settings that you know exactly where they are.


Under data Connections: everything set to "automatic"

Edit -

Create GPRS Connection
Connects To: Wap Network
Access Point: wap.voicestream.com
Primary DNS: 0.0.0.0
Secondary DNS: 0.0.0.0
everything else blank

Create Proxy
Connects From: WAP Network
Connects To: The Internet
Proxy: 216.155.165.50:8080
Type: HTTP
Everything else blank

In IE under Options, Connections:
check Automatically detect settings
Select Network: The Internet

It should work, let me know if you have any questions.

Michael
 
Last edited:
Thank you for sharing a different option Michael, just a question though, can you access the t-zones homepage (wap.myvoicestream.com) with your settings? Also, missing in your settings is how you set your Data Connections (if they are all set on "Automatic" or if you set them differently).

I can certainly understand how one can get frustrated in the process of finding the RIGHT settings that enables him/her to use the data connectivity to it's full capacity. Meaning sending and receiving email, mms, sms, synchronizing with Microsoft Server Exchange wirelessly, surfing every html and wap page (including wap.myvoicestream.com) without limitations and without having to change the settings in order to complete one or the other functions mentioned above.
For me, the settings posted on page 1 of this thread are the only settings that FULLY work. Other settings might allow me to connect, but not to the full extend of the capacities offered by TMobile. I recommend everyone to follow the instructions scrupulously, as for instance, having 2 different GPRS connections listed will block you from connecting. Any minor difference might and will probably disable you from connecting properly. That is why I recommend to keep the same connections names as used in the tutorial, double check if not triple check every typed letter, number or space before concluding that the settings don't work.

Again, I can thank jleecong and vinayp enough to share their findings on this board. I firmly believe that IF THEIR SETTINGS ARE ENTRED PROPERLY, you will be able to use TMobile's data connectivity to it's full capacity anywhere in America. I don't thinks the rule "different region=different settings" is true as my settings have yet to failed me anywhere I have been in the country.
 
Back
Top