Obi202 Kaput

mframe

Active member
Joined
May 30, 2003
Messages
2,381
Location
Western MA
Carrier(s)
H2O, TMO, AT&T, Visible, PagePlus, TracFone
Device(s)
S24+/A32/A23 5G, Pixel 8/7/6a, Moto Edge+ 2023/One 5G Ace/G Power 5g 2023, iPhone SE3
Well, I think my Obi202 with Google Voice has finally quit. I left it unchanged after support ended last December, and I wondered how long it would keep working. A few days ago, I noticed my cordless phone displaying "Check Tel Line". My modem, WiFi router, and phone number (checked via cell phone app) are all fine.

For now, I plugged my house devices into a Verizon home phone box with a cheap Verizon-based MVNO SIM/plan that the Google Voice number is forwarded to. Clumsy work-around for calling out using GV number (unless I use a cell phone), but I would prefer to keep the number on GV to be able to use it on a cell phone, as well (with WiFi or data). That house line does not get much use, anyway.

Has anyone else's Obi device finally given up the ghost?
 
I have 2 GV lines on my OBI and they to working. work fine. Have you tried rebooting the OBI?

Sent from my SM-T500 using Tapatalk
 
I have 2 GV lines on my OBI and they to working. work fine. Have you tried rebooting the OBI?

Sent from my SM-T500 using Tapatalk


Did you try to reconfigure your OBI on obitalk website? I did and it worked. :clapping: I almost threw the obi away. thinking it stopped working after December 2023
 
My Obi 200 is still working fine, and I have two backups I pre-configured (purchased at sale prices over the last couple of years before any announcement of support ending) on the ObiTalk website that I pretested as good before the website deadline was reached (in case one goes down due to electronic/mechanical reasons).

@echance20: When did you last visit the ObiTalk website to do any configuration tweaking? That was supposed to be over and done with, and even confirmed so here somewhere, I thought. I haven't visited it recently to check, but I assume the site can be reached, just no changes take hold.
 
I did reboot the Obi but it was still the same. I did not know the ObiTalk website was still up, although I do not know if reconfiguration is possible or even needed. I will check it out, anyway.
 
Just a couple of basic troubleshooting tips: Take a look at the Settings in the GV app on any phone you might have it installed on (if any), and be sure the Obi device is displayed and toggled on. And if you have any other fully corded phone, trying using just that plugged into the Obi's RJ11 jack instead of your cordless phone base, to rule out that phone set being the source of the problem (even though it appears to work with your Verizon Home device).
 
My Obi202 shows as connected on the ObiTalk website and the configuration is good (unchanged), but it still doesn't work.

I checked the Google Voice website settings for the line and noticed that the Obi device is no longer listed as a forwarding device. I don't know how that happened. I can't add it back since it doesn't have a regular phone number to receive a text/call verification.

Oh well. :(
 
Thanks for letting me post.

My Obi200 with GVoice started having similar symptoms on 3/30/24. After t-shooting a few days I'm guessing this is not a hardware issue because I can get the Obi200 to work for short periods of time.

It would have been nice to get an "end-of-life" email notification from Obihai/HP/Poly. I had no idea any of this was happening until a few days ago.
--------------------
Symptoms, t-shooting details if this may be helpful :

-I started getting Anveo E911 "SIP Offline" emails and "check tel line" messages on my wireless analog phone I use with the Obi200.

-I can put the Obi200 back online by powering off/on the Obi200. It will then connect to Obitalk temporarily. Tel line and dialtone works.

-Sometimes Obitalk will show Obi200 connected but Panasonic wireless phone shows "check tel line" and no dialtone.

-I see "line in use" and "check tel line" cycling and sometimes periods of no error messages at all, with line working.

-Sometimes I can get a dialtone when Obi200 is connected on Obitalk by attempting to make a call and leaving the phone off the hook until I hear a bit of static and two short low frequency tones (G2 on piano, a bit under 100Hz). A few seconds afterwards, there is a dialtone and I've been able to make a call to my cell phone. Not sure if a longer call would be disconnected or not.

-Sometimes I can get Obi200 connected by saving it's Obitalk config page.

-Sometimes the only way to get connected is reboot Obi200. Sometimes after rebooting I get dial tone immediately.

-I occasionally can access the Obi200 admin page but most of the time get "unable to connect" in browser. I had been thinking of flashing the firmware re the "obifirmware.com" page but am not sure how to access the Obi200 admin page now. This firmware is supposed to help connect to GVoice without using the Obitalk portal - but I have not done much research on this yet.

-After disconnecting my router and Obi200 from the internet and rebooting both, I was able to reboot the router and Obi200 and gain access to the Obi200 hardware admin web page directly and back up it's configuration. So it looks like I should be able to flash the firmware if I decide to try that after looking into it.

Trying to figure out what to do at the moment. Assume that the Obi200 hardware is OK and port my GVoice # to Anveo or another VoIP provider? At least GVoice still forwards to my cell #.

I was thinking of doing a hard reset on Obi200 but was not sure what would happen with Obitalk config - whether it would reset the Obi200 OR remove the GVoice config from the Obitalk portal and not allow re-registering the Obi0200.
 
I think the comment about your Anveo Alerts may be telling. I have them as my E911 service in my SP2 slot. I've gotten those alerts whenever I've had power outages or Internet service problems, especially if they affect the connectivity between my separate cable modem and router (power comes back but the timing is off with how the modem offers DHCP and the router lost its IP address and can't get another until I manually intervene.

Also, even though you likely configured Anveo through the ObiTalk portal, it should not be subject to what's going on with Google Voice servers. The thing that is disappearing/has disappeared is the portal's functionality. Once you're configured, as far as GV goes, it's a matter of what's happening with them, and there's no influence from Obi, unless a setting got changed, which is unlikely since the portal should be non-functional.

On the other hand, the ObiTalk device should be configurable and usable with other SIP-based services using the embedded web page of the device, and any manual settings known for that service that can be applied through that (I think most services have a user base that has already figured this out—using an Obi without access to the portal). So there shouldn't be a reason the Anveo service got interrupted even if Google shut off their connection to it (for GV, and there's plenty of testimony that hasn't happened). The device is hardware and should work with conventional SIP services independent of the GV thing.

So in your case (perhaps unlike the other guys), there might be something else going on. Maybe cabling to your router, or the RJ45 jack on the router (is there another one available?). Any other connected devices exhibiting problems? Have there been any power events that might have affected either the Obi itself or even it's AC adapter (power supply)? DC voltage at its output correct and fairly clean (no excess ripple that would cause problems in the Obi)? That would require an oscilloscope to analyze; not something just anyone would have around.

I'd venture that if the Anveo is going out and coming back, something along those lines, or the device itself failing, could be the reason.
 
My Obi200 with GVoice started having similar symptoms on 3/30/24.
Your description sounds exactly like mine. If you log into the website for your Google Voice line, is the Obi shown as a forwarding device?
 
Thanks, whacker!

Funny you'd mention - I do have a Tek 2236 sitting on the shelf here. Used it for the first time in 20 years or so checking ripple on an audio mixer power supply I had to rebuild last year.

I've got everything on a UPS here, so no issues with power problems or surges. I did check ethernet cable in different router port and also swapped for a different cable. Have had no previous problems with the devices connecting after bringing the UPS back up after a power outage here.

I've got Anveo E911 on SP2 as well and before the recent problems would occasionally get "SIP off line" "Sip back on line" emails overnight. Probably internet service problem as you mentioned, someone rebooting their servers. If the Obitalk portal was having problems, maybe that would have something to do with both the SIP dropping GVoice and Anveo E911? But I had been wondering if it was hardware.

I think there might be a way to check power to the Obi using the hardware admin web page but would have to figure out a way to check with the scope when the power supply was under load from the Obi but probably a good idea to check ripple on the power supply connector as well.

This does seem like an interesting coincidence and timing with mframe's problem though.
 
mframe - My Google Voice settings are showing 2 devices, "Web" and the Obi. Your issue did sound really similar to what I'm seeing here, and the timing is suspicious as well. Going to think about this a bit more and try to figure out what my best option is!
 
>whacker : AC adapter (power supply)? DC voltage at its output correct and fairly clean (no excess ripple that would cause problems in the Obi)? That would require an oscilloscope to analyze; not something just anyone would have around.

Don't have time for the scope this morning but I did a quick DMM voltage check :
11.72VDC and .002 AC ripple. If this is a hardware issue, it has to be the Obi itself although I'm not sure what the DC voltage is under the Obi200 load.

If I can determine that a factory reset is NOT going to delete my Google Voice SIP registration on the ObiTalk website, I'll probably try that next I think.

I can still coax a connection/dial tone out of the Obi.
 
I have 2 obi's here, 200 and 202. One from 2016 (200) other from 2017. Both been in service since then. Both fully operational as of today with no glitches to GV or callcentric.

Both have had the modded fw with offline gv config ever since the fw became available (2018?). I haven't touched the obiportal in that long as well. The way both are configured, neither attempts to connect to obi portal for any provisioning - there's an admin option to disable this. Even if they attempted, specific firewall rules block it any way.

However, issues with anveo should not be related to anything gv. Do you have a backup xml from the device config? I would attempt to factory reset the device, divorce it from obitalk then restore the xml. Note if you have any configured gv slots, those will be reset and will need to be provisioned. You will need to reach out to naf on dslr to obtain how to instructions and download the modded fw from obifirmware.com.
 
GPz1100 - Good info - much appreciated, thanks!

I'm still not sure whether this is an Obi hardware problem or not. I'm now sure it's not a power supply or cable problem.

I did several typical things that usually help determine heat or other related physical issues that can cause problems with these low voltage, low current devices.

If the Obi hardware is dying, doing the modded firmware is a moot point. If the problem is elsewhere and can be fixed, I've already got the obifirmware mod downloaded and will contact "naf" for instructions.

The Howard forum was the only forum I could find so far where someone had an Obixxx with similar symptoms as mine.

The Obi200 now continuously cycles between normal, to "line in use", to "check tel line" and back to normal again. It will do this for different periods of time then it will disconnect and need to be powered off/on to reconnect. I can usually make calls until it fully disconnects. I get the Anveo SIP offline alert when the Obi disconnects. The problem is a bit different than at first - so again, maybe dying hardware.

I was able to save the xml config yesterday but to do that I had to remove internet from my router and Obi200 then reboot both. I was not able to access the Obi admin web page when online.

I looked at the xml config and saw the Google and Anveo proxy server addresses embedded, so with a factory reset and then reloading the xml file, and maybe the Obitalks Google Voice registration will be preserved. Then I could see if the factory reset helped the problem or not and proceed accordingly.
:)
 
This thread reads much like the dslr thread - https://www.dslreports.com/forum/r33859777-Obi200-replacement-for-google-voiice-personal . I don't know if you or the OP are the same people who posted there as well.

With respect to gv/obi, there are hidden entries that are NOT backed up. You could probably determine what they are if you ssh into the device (with the modded fw) and run the param_dump utility. On a stock obi, this is not possible given there is no ssh access. Perhaps you could then share with the rest of the class what these hidden entries are.

With naf's firmware, he does some other modding so it doesn't really matter what they are, the correct client_id and secret is provided. All you have to do is generate your refresh token to put in the authpassword field. Stock obitalk provisioning stores these values elsewhere, or perhaps not even accessible by param_dump.

There should be no reason why you can't access the obi gui while online. I never encountered this myself. What exact issues are you running into when trying to access its ip? The only issue i've had with the obi20x has been with dhcp. That is, if internet goes down, but link between obi/switch stays up (which it should, obi is connected to a switch, not to firewall/router directly), it (obi) seems to lose network connectivity until it's rebooted. To counter this I assigned static ip's in each device. This fixed that problem now for a number of years.

On one hand i can't wait for gv/obi to finally die, on the other, it's still free phone service. Pick your battles.

Edit; as i mentioned in one of the dslr obi threads, if device is dying, but still accessible, now's a good time to grab the certs before it craps out entirely.
 
Last edited:
This thread reads much like the dslr thread

Edit; as i mentioned in one of the dslr obi threads, if device is dying, but still accessible, now's a good time to grab the certs before it craps out entirely.

HA - no, that's not me on the other thread. But I did see it and it was helpful, thanks!

On/off hook voltages are about the same here.

A comment down the thread reminded someone gave me an iPhone7 with cracked screen and old battery. I didn't like it - too big - so I didn't fix it and don't have a SIM in it. But it works and unlike the iPhone5 I use for power outs and emergencies, the phones OS is still being updated. Last night I got the GV app working using WiFi and now have a working GV phone again. This buys some time before I have to come up with a more permanent solution.

I'm not as concerned about losing the possibly still working Obi200 now and am willing to experiment. I'm more than happy to help this group if I can. I have to help landlord on a project but will try to squeeze some time in when possible.

I'm a total novice on this subject but I was a recording and radio tech/engineer for most of career and am not a bad trouble shooter. Did have some experience with phone systems in radio stations but have not been in a station in 20 years and VoIP is WAY over my head. Will definitely need instructions to do the firmware flash - I'd already dl'd what I think is the right one but am not sure. What's the best way to proceed?

I never had a problem getting into the Obi admin/config web page until recently. It's why I'm not totally convinced that this is a hardware problem. I didn't use the Obi config for any more than checking call history.

Now, I typically get "unable to connect" in browser window. Very rarely, I could get the login window and could login and get the admin web page GUI but it's glitchy and some parts are not accessible and "reboot" button doesn't work. Even more rare, I can get the page without even logging in - just comes up in the browser but it's still not very functional.

Removing the router and Obi from the internet and rebooting fixed that problem and the config features I looked at seem to be available - and reboot works.

I've never had any kind of problem with Obi (or anything else here) not connecting after a power outage - and there can be quite a few of those here, especially in the winter. I do have the important electronics on UPS's here but only cable modem, router, Obi and a bricked Grace radio come on when power comes back. I don't run anything on UPS, just use to keep stuff from surges and allow time to shut down.

I agree on your GV/Obi take! I still have an Obi110 that got bricked for GV and had to spend time looking around and found the "Simon" fix. I hate having to junk stuff that works but that's the digital age for you.
 
^^Are you trying to access the correct device IP address? I would verify what your dhcp server is handing out, you can also see what the device is set to by dialing ***1 from a connected handset.

Finally you could try setting the parameters to static as well (ip, subnet mask, gateway ip, dns ip's). It'd be pretty bizarre, but perhaps you can't access it because it doesn't have an ip¿?
 
^^Are you trying to access the correct device IP address? I would verify what your dhcp server is handing out, you can also see what the device is set to by dialing ***1 from a connected handset.

Finally you could try setting the parameters to static as well (ip, subnet mask, gateway ip, dns ip's). It'd be pretty bizarre, but perhaps you can't access it because it doesn't have an ip¿?

Something very strange going on here! I want to disable all of the auto-provisioning that links the Obi200 to the ObiTalk site and see how things work.

There were several sections in the Obi200 admin config that seemed obvious to disable but I'd like to know exactly what to disable besides the firmware update and the ObiTalk portal.

I want to make sure that the ObiTalk portal is not talking to the Obi200! Not sure if this will lose the ObiTalk GVoice registration but at this point, I dont care if it does.

Maybe something is gummed up in the box that requires a factory reset? Or the box is toast?

Something has changed today and it may not be a hardware issue. I'm wondering if something is coming from the ObiTalk portal that might be causing the "line in use" and "check line" issues on the cordless phone. I would just like to eliminate this possibility altogether and see what the box does.

The Obi LED's all look to be acting normally but I'm seeing network activity that may be causing the changing state of the cordless phone. Either there is some kind of IC or other part going nuts in the hardware or maybe getting something is coming from the outside world. Even a bad solder connection I've seen cause stuff like this.

I also got new NiMh rechargable's for the two phones just in case although the older batteries seem to be OK and discharge and charge up in a stand alone battery charger I use.

Obi IP is always 192.168.1.100 in my router - very rarely can log in when connected to internet - can always log in after disconnecting router from cable modem and rebooting router and Obi. That is, until a little while ago. I tried ***1 but am not sure what would show the IP #.

And I was actually able to get into the config web page GUI today. When clicking on various sections, would get an "unable to connect" the first time or two, then another click or two and the section would be populated with data.

Example, looked at "Call History" and got "unable to connect". Another click on Call History the page came up but with nothing there, "call history not ready". Third click, Call History was populated with phone #'s I dialed. Then I closed the config page and could not get back into it again. I was getting more access to the config sections then I was over the weekend but it's still glitchy. The "reboot" button was not grayed out although I didn't try it.

Last night the Obi stayed connected for quite long periods of time hours, before I had to reboot. This morning I had to reboot 3 or 4 times in less than an hour. This afternoon it's staying connected for so far, 2 1/2 hours. It can take up to 40 seconds or so to get a dialtone when using the cordless phones base station to seize the line but so far I can get one. Sometimes dial tone is there immediately.

Time to go run and think about this. One of the weirdest computer related issues I've seen so far.
 
Back
Top