PHP Pix Place Server available!

Humpa

New member
HoFo Member
Joined
Nov 6, 2004
Messages
16,653
Location
Dallas
Carrier(s)
VZW - Headsets:
Device(s)
TBolt, DroidX, Incredible, Droid1, Omnia II, HTC Imagio, BB Tour, BB Storm,Touch,Dare,Voyager
I have a php Pic Server here: humpa_mms.zip
Read the readme.txt - there is nothing to edit, though you will have to chmod 777 the pics and videos directories!
However, you may want to set Your Name and email address (this is only used as the From addy when sending pic as email, and is not needed).

It should work without any modifications.
It saves pics and videos, and it will also forward to an email address.
If you attach a voice record to the pic message, that is saved too.
If you include text, it is saved as the caption (for pics and videos) - if there is no text, but there is a Subject, then that becomes the caption.
I have customized it a bit for the V710 (I only have it check for 3g2 videos and qcp audio attachments), but pics and captions should work with any phonecam.

I use a variation of this on my phonecam page (in my signature), but here is a test of my humpa_mms package:
www.humpa.com/humpa_mms
 
I meant to tell you last night that I got that running smoothly.
Thanks again for your help!
 
perfecto!

just downloaded to my laptop (in class). unzipped, uploaded to server at home. set up setting on v710. took picture. sent picture. downloaded picture from home to laptop. viola!
 
PHP PIx Server help!!!

What do i need to get this working? Please help with phone settings and server setup.

-Thanks

JM2005
 
Re: PHP PIx Server help!!!

JM2005 said:
What do i need to get this working? Please help with phone settings and server setup.

-Thanks

JM2005

You need to install a webserver (Apache preferably, but IIS would work). Also, you need to install PHP and then configure the webserver to use PHP.

Of course, being able to contact your computer is also dependent that it is on publically available on the internet, not behind a router or NAT. Also, if you have any sort of firewall-ing (explicit or implied through ISP or NAT), you'll need to forward port 80.

Am I forgetting anything?
 
Can someone please post step by step instructions for how to do this. Thank You.
 
This assumes your webserver is good to go (PHP, Apache, etc...):

1. go to your public_html directory and create a directory (call it what you want...I called mine "mms". We'll call your's "mms" as well for this setup example.

2. unzip humpa's files and dump them into your "mms" directory. Those files should include 2 folders (pics and videos), and 4 .PHP files (class.phpmailer.php; get_public.php; index.php; mmslib.php)

NOTE: now you need to CHMOD the "Pics" and "Videos" subdirectories. There are a number of different ways to do this. Basically right click each folder in your FTP program and you should see CHMOD. Click it and make sure they say 777. It'll make sense if you see it.

3. [you may need a seem edit (or two)for this step -I'll assume it's already done. This also assumes you have a working web session]

Menu>Messenging>Message Setup>Pix Message Setup>Server Info>Menu>Edit. Then:
Service Name: "whatever you want
Server Name: http://www.yourdomain.com/mss/get_public.php
Web Session: Choose your personal Web session. If you have multiple sessions, just pick one.

*obviously "yourdomain" is the name of your website!

4. That's all! Send pics to email addresses or to your Pix Place. Your Pix Place is found at http://www.yourdomain.com/mss

5. You'll see that the email portion may be customized to humpa's settings. You may edit these to fit your own likings. Such edits include:

-in class.phpmailer.php, lines 61 and 67

-in get_public.php, lines 12, 13, 129-136, 140, 144, 149, 156, 158, 160

Hope that helps and please anyone, fill in any gaps I left out :beer:
 
Last edited:
Thanks for the help Guys! I didnt know i had to edit the seem? i need to learn about that then before i setup the rest.

Thanks for your help.
 
Awesome!

It worked flawless

Now if only you could make this a plugin for WordPress.org Blog software :)

Jef
 
Interesting enough whe n Iadd multiple pictures only one works. Even though I see 4 links, each time I click it does not seem to choose a new picture.

http://www.jeftek.com/1/mms
 
Honey Dijon Chicken....from the Cafe at work. It's actually quite good. :)
 
Jef said:
Interesting enough whe n Iadd multiple pictures only one works. Even though I see 4 links, each time I click it does not seem to choose a new picture.

http://www.jeftek.com/1/mms
Perhaps I should know why this is not working, but I don't. One thing I do know, however, is that this is on a Windows server. And I only know that because otherwise it would work! :D

I suspect it is something to do with Register Globals. Make sure Register Globals is set to "On" in your php config.
 
Last edited:
Wirelessly posted (Mozilla/4.0 (compatible; MSIE 4.01; Windows CE; PPC; 240x320))

Humpa[/i] [b][QUOTE][i]Originally posted by Jef said:
Interesting enough whe n Iadd multiple pictures only one works. Even though I see 4 links, each time I click it does not seem to choose a new picture.

http://www.jeftek.com/1/mms
Perhaps I should know why this is not working, but I don't. One thing I do know, however, is that this is on a Windows server. And I only know that because otherwise it would work! :D

I suspect it is something to do with Register Globals. Make sure Register Globals is set to "On" in your php config.[/b][/quote]

ick! change the code so that $picnumber is instead read as $_GET['picnumber']. and no more problems! actually i might take a look at it and see if i can optimize and enhance it ;)
 
Jef said:
Interesting enough whe n Iadd multiple pictures only one works. Even though I see 4 links, each time I click it does not seem to choose a new picture.

http://www.jeftek.com/1/mms
I edited the code, like whysanity mentioned. That should fix it for you.
You can download it again, or just add these 2 lines to the beginning of the file:
$pic = $_GET['pic'];
$video = $_GET['video'];


whysanity said:
ick! change the code so that $picnumber is instead read as $_GET['picnumber']. and no more problems! actually i might take a look at it and see if i can optimize and enhance it ;)
:haveadrin
 
Thanks! That worked just fine. :)

Yes it is a Windows server....thank god! ;)
 
can someone send me a copy of get_public.php file. The way my host is set up, I do not have one, but I can send pics fine.

ras1108@yahoo.com
 
shooters said:
can someone send me a copy of get_public.php file. The way my host is set up, I do not have one, but I can send pics fine.

ras1108@yahoo.com
The send.php is the get_public.php file. I had an earlier version, and that is what I had called the file. That seemed like an odd filename, so I renamed it to send.php (since that is where you have your phone send your MMS pics to!)
justincase says to point your phone to get_public.php, but that isn't correct. He has that earlier version is all.
Just use the URL to the send.php file for you Pix Place server address.
 
thank you. it works just fine
 
Back
Top