Possible to get USB tethering and WiFi hotspot to work on (A&T) X Venture?

Shplad

New member
Joined
Apr 14, 2008
Messages
20
Hi everyone:

I have an X Venture originally from AT&T that is already carrier unlocked. I'm using it on another carrier, and in general, it works fine. However, the USB tethering and WiFi hotspot functions don't work at all, and I'm fairly sure it's because they're somehow locked to AT&T.

Can someone please confirm or deny this and also let me know if this can be undone/unlocked/worked around?

Thanks
 
Last edited:
I am willing to bet that your current carrier hasn't provisioned your account to use those features and that is why they don't work. I doubt it has anything to do with unlocking. What carrier are you using it with and can you make/receive phone calls currently?
 
My current carrier is Koodo, the budget brand of Telus. General data works fine on Koodo. So does voice. I just can't get the above two functions working.

I'm on the phone with AT&T. They claim there are still some locks on it that they are "working on". I'm not sure how true that is.
 
At&t, from my prior experience as a CS rep for 14 years can only blacklist a phone from all usage, not just block certain features. I suspect Koodo has to provision the account with those features to resolve it. They may need to speak with At&t to resolve the issue internally. Seems perfectly true to me.
 
Ah, okay. Well, I can't argue with that kind of experience. AT&T said they'd finish unlocking it in about an hour. They appeared to be quite cooperative. Hopefully, that changes something. But Koodo swears they have no limitations on my data other than my having to pay more if I use more. I'll keep posting back with my findings. THANK YOU.
 
And....AT&T hasn't called me back when they said they would. I called in, and the rep. told me that without
a reference number, I can't speak to the rep. who first said she was going to fix the problem.
Ah, US telecom companies...SO MUCH FUN.
 
I understand your frustration, but if they are having difficulty provisioning your account, they have to file a "trouble ticket" internally to have a rep with higher level access to manually add some features. You talked to a Tier 1 rep and the rep I am referring to is referred to as Tier 2. You will only have access to Tier 1 and you cannot request to speak with Tier 2, as they do not take customer service calls.
 
Who is provisioning my account? I'm not with AT&T, I never was. Also, all I asked when I phoned again was to speak
with the level 1 rep. with whom I first spoke, or to leave her a message. But apparently that's impossible. If I were
signing up for a new service, I'm sure it wouldn't be.
 
I am not sure if it is Koodo or At&t (in the background) doing the account update. You first point of contact is Koodo customer service. You do not contact At&t directly for help. Koodo doesn't own their network and ultimately relies on one (I am assuming At&t) for all background assistance with account features and troubleshooting that they cannot resolve directly.
 
Telus won't speak to me, I've already tried. Koodo level 2 support insists that there is no reason why this function wouldn't allow these functions on the network. These days everyone's answer is "buy another xxx".
 
I will confess that I didn't realize that Koodo was a Canadian provider. Clearly, At&t is not supporting their service as I thought it did. In your case, you cannot speak to TELUS directly and must deal with Koodo directly to resolve this issue. Sorry for any confusion on my part. I was only trying to help but my suggestions do generally apply to your situation. I do hope it does get resolved sooner than later.
 
Hey, no worries. I appreciate the help. As someone who used to be an IT tech, I know
things are constantly changing and no one can keep up with all of it. Just suffice it to
say that you folks south of the border get a much better deal on wireless than we do.
 
I wonder if my carrier can do some sort of packet trace that might help us figure
out what's going wrong?
 
Back
Top