AT&T Samsung i637 Jack Tips & Tricks

tonyguar said:
P.S.

I changed the other Jack predefined keys such as the GPS key and the ATT MediaNet key by editing the .lnk (shortcut) in the windows directory and redirecting it to the program I wanted.

Now when I press the GPS key it opens Google maps and when I press the MediaNet key it opens the Wireless manager so I can turn the wifi on and off. I haven't found the program name that turns wifi on and off, so I just have it start the wireless manager.

The name of the two shortcuts are:

MediaNet
AT&T Navigator
I did the same but used the Medianet as just a link to IE with MY predefined homepage, not to the medianet page...
 
tonyguar said:
For all looking to change the predefined function keys set by ATT, here is what worked for me (I do not take any responsibility for the registry editing you do):

1) Unlock the phone and get a registry editor. Here is a good tutorial on how to unlock the phone and reg edit: http://www.1800pocketpc.com/2009/06/10/unlock-the-security-on-the-samsung-jack.html

2) open the registry (I use mobile Registry Editor)

3) go to: HKEY_LOCAL_MACHINE => Software => Samsung => KeyRun

Note: "Key Run" is where the definitions for the function keys are set and where you need to do the editing. Once again, you are responsible for the editing you do. It is best to back up the registry before editing. Or at least record the previous settings before changing.


4) you will see each letter of the alphabet. Select the letter you want to change for example "C"

********************************************
If you want to remove the key settings so you can program it via Jack's Settings menu, do the following:

a) Delete all settings except (Default) and (Order)
b) Change the value of (order) to 0
c) close editor
d) on the Jack run: Settings => 7 More... => 6 Key Settings => 1 FN Key Settings => Show List
e) you will see that "C" is no longer there
f ) select: Menu => Add
g ) select the key you would like to assign the function (example "C")
h ) In the Value box select the program to run (example "calculator")
i ) now when you press "function C" the calculator will run.
*****************************************

To change the key in the editor: After selecting the letter you want to change in the registry, you need to edit each value as listed below:

AppPath: this is the .exe that you want to run (make sure you put in the full path): you can also enter the .lnk, for example: "\Windows\Start Menu\Organizer\Calculator.lnk" for the calculator

AppTitle: This is the name that will show in the list. If you set it to "0" or leave it blank, it should be the name of the .exe or the .lnk (in the above example "Calculator" will show)

Argument: this is any extra arguement that you want to run with the program (in most cases leave it blank)

Order: this is the order that it shows up in the list of Function keys (do not duplicate order numbers except for 0)


That is it, Good Luck


Hey... I tried all that and all of those worked. Thanks a lot.

Do you by any chance know how to fix the timezone issue? I'm in Vancouver, using an unlocked Jack on Fido. If my time zone is set to GMT-8 Pacific US, my outgoing text msg's show the correct time but my incoming text msg times are off by 4 hours and my world clock shows the correct times.

If I change the time zone to GMT-4 Atlantic, and take off auto update, my incoming and outgoing text msg times show up correctly but my world clock is off.

So do you know if there is a fix for it? Is there something I can do in the phone registry?

Any help would be appreciated.
 
Also:

1) I couldn't find the registry to change the length of ringtones.
2) When composing a text message, I can only send it to 10 ppl at once, is there a way to change that limit from 10?

Any other tricks or tweak would be helpful.
 
Lol ok I don't know what or how I did it but now when I'm in a text msg, I can't scroll up to see the previous msg's. I can't move up out of the box where you type the msg. The navigation keys work everywhere else(home screen, internet, scrolling up & down contacts, scrolling up and down and side to side in the menu). So basically when I'm in the type msg box, I cant scroll up to see the previous msg's or down, left or right. Not being able to scroll up to view the previous msg's.... it's really starting to frustrate me. Someone please help!!!
 
I somehow managed to figure everything else out. Thanks for the tip on changing the shortcut keys, I have made the changes and everything works well.

I had another question if someone can maybe help me out with. When you're in the text message screeen, if you want to send a group text, you can only send it to 10 people at once. Is there a way to increase this limit? Is there a way to get rid of the boxes that pop if you're sending the text to multiple recipients? Would getting rid of these boxes help me send a text out to more than 10 people at once?
 
Thanks for the tips everyone. I'm considering buying a 2 day old "used" Jack for $70. Is it worth upgrading from a BJII? Not interested in a touchscreen and love my BJII... I'm on the old Mediamax $20 unlimited data plan so that shouldn't be affected when I pop my SIM in, should it?
 
Any idea how to access MediaNet from IE?

If I open IE I get the "The Page Cannot Be Found" when I try to go to MediaNet. The only way I can access it is if I go to the Start Menu and select MediaNet.

It appears that my connection settings in IE will not stay on WAP Network.

What gives?
 
CPTek said:
Any idea how to access MediaNet from IE?

If I open IE I get the "The Page Cannot Be Found" when I try to go to MediaNet. The only way I can access it is if I go to the Start Menu and select MediaNet.

It appears that my connection settings in IE will not stay on WAP Network.

What gives?


Ok I went to the store and the demo did the exact same thing.

1. You cannot access MediaNet or related pages from Internet Explorer. You get "The Page Cannot Be Found".
2. In IE if you go to Tools > Options > Connections and change it from "The Internet" to "WAP Network" then you can access MediaNet in IE. HOWEVER, the setting will not save once you exit IE.
3. If you go to the Start Menu and select MEDIANET then you can access MediaNet and related sites.

This is a fairly stupid glitch. I am hoping someone has a solution to the issue. I hate having to switch between the IE icon and MediaNet icon to browse the web & at&t content. Considering IE and MediaNet are both in IE.
 
It's not a glitch. The 'Internet Explorer' icon on the phone is wired to call a different program (wifi browser or something like that) which modifies IE settings before launch IE. This is for the purpose of using AT&T wi-fi hotspot. Hence the need to bypass AT&T proxy. If you can create a true IE shortcut to replace the IE icon, you will get what you wanted. Media Net icon is a shortcut to Media Net URL which will launch IE and load Media Net home page.
 
nugs said:
Thanks for the tips everyone. I'm considering buying a 2 day old "used" Jack for $70. Is it worth upgrading from a BJII? Not interested in a touchscreen and love my BJII... I'm on the old Mediamax $20 unlimited data plan so that shouldn't be affected when I pop my SIM in, should it?

I upgraded from the BJ2 to the Jack. It's a little bit of a readjustment, but I've been very happy. The speed improvement is huge going from 260 MHz to 500+, and they finally implemented proper GPS boosting from the cell network, so getting a GPS lock is an order of magnitude faster. The battery doesn't last quite as long, but it's enough for my use, which is pretty heavy.
 
Foxbat121 said:
It's not a glitch. The 'Internet Explorer' icon on the phone is wired to call a different program (wifi browser or something like that) which modifies IE settings before launch IE. This is for the purpose of using AT&T wi-fi hotspot. Hence the need to bypass AT&T proxy. If you can create a true IE shortcut to replace the IE icon, you will get what you wanted. Media Net icon is a shortcut to Media Net URL which will launch IE and load Media Net home page.


Ah ha. Well it is a stupid setup. The average user will open IE on a WM device. Once opened Favorites seem like a good place to start. Hence MediaNet and then hence the error message.

I brought it to the store and they had no idea. Nor did support. All they did is Master Reset the phone. Blah.

I will fix it then.
 
CPTek said:
Ah ha. Well it is a stupid setup. The average user will open IE on a WM device. Once opened Favorites seem like a good place to start. Hence MediaNet and then hence the error message.

I brought it to the store and they had no idea. Nor did support. All they did is Master Reset the phone. Blah.

I will fix it then.

Well, average Joe may not want to use cell data connection. In this case, if they open IE with proxy enabled but using wi-fi will never be able to connect.

So, if you want to use Media Net, use the Media Net icon. If you want to use wi-fi, use the fake IE icon. This is a much better setup to help reduce support calls.
 
Security Configuration Manager has stopped working.

Does anyone know why I keep getting a "Security Configuration Manager has stopped working" error when I try to run it? I'm using Vista 64-bit with SP2. I've tried running it in compatibility mode for XP SP2 and Windows 2000 and also running it as administrator. This is the only thing holding me back from unlocking the security on my Jack so any help would be greatly appreciated. Thanks. :2thumbs:
 
I'm using an unlocked AT&T Jack i637 on the Fido network. For some reason my call display doesn't seem to be working properly.

-When someone with a Fido # calls me, my call display works.
-When someone with a Rogers # calls me, my call display works.
-When someone with a Telus or Bell # call me, it comes up as UNKNOWN, even if the person is in my contact list.
-And lately, some Rogers #"s are also showing up as UNKNOWN.

I called Fido and they can't help me out with it.

Does anyone know if there is a solution to this?
 
I don't know about Canada. But here is US, caller ID rarely show up with names from other carrier. Only phone numbers. The phone, Samsung Jack, only uses phone number to match the contact list to show the actual caller name. Make sure your contacts' phone numbers are correctly stored the same as the incoming calls.
 
Hey,

Well it shows is UNKNOWN, I don't get a name or a #. I would be happy even just to see the # if I can't see the name. But yeah the # doesn't show up. Normally I don't pick up private calls but kind of have to right now because I don't really have a choice.

It's just weird how some of my contacts using Rogers have they're name & # show up but some don't. And pretty much no Telus or Bell #'s show up.


There is no phone setting I can change or make a change in the registry?
 
Caller ID is a network thing. Nothing you do on the phone will affect it. You get better chance just call your carrier and ask why there is no caller ID from others.
 
Back
Top