Simply "Make A Payment" if FreedomPop is "suspended" or "Billing information is required" or ...

andyk88

Member
Joined
Dec 23, 2017
Messages
233
Simply "Make A Payment" if FreedomPop is "suspended" or "Billing information is required" or ...

It seems FreedomPop deleted payment information on all the accounts/lines I manage.
(I only have one line per account. In November, I already made sure each line has a unique credit card number.)


A GSMA 100/100/100 line showed "Your account is suspended" in red, and "Airtime Expired".
I clicked on "Make A Payment" and re-subscribed (using the line's same unique credit card number that FreedomPop deleted).
After about a minute, the line became active again on a new billing cycle.

My only GSMT line showed "Billing information is required" in red, but still active.
I also clicked on "Make A Payment" and re-subscribed (using the line's same unique credit card number that FreedomPop deleted).
The line was still active and the billing cycle was not changed.


For GSMA 100/100/100 and GSMT, even if a line is still active,
make sure the line has an active subscription (Automatic Payments should not be Inactive).
The line is not likely to auto renew without an active subscription.

For GSMA 10/10/25, enter credit card information during manual renewal.


I hope FreedomPop merely wanted to make sure each line has a unique credit card number.

Nevertheless, compared to November, it feels better now that I have Vegolink pSIMs in case something worse happens.
https://www.howardforums.com/showth...SIM-spotted-at-target?p=17263093#post17263093


Update:
Right after "Make A Payment", the GSMA 100/100/100 line had a 3/13 renewal date.
Some time later the renewal date became 2/12 by itself.
The line did not auto renew the night of 2/12.
This morning (2/13) I got "Your account is suspended" again (after refreshing the webpage).
I clicked on "Make A Payment" > Cancel > SUBSCRIBE.
It's now showing Active with a 3/14 renewal date.
 
Last edited:
My active free FP lines, 2 T-Mo and 1 AT&T, are all in the same FP account. However, I do have different payment methods for each line. Since all the phone #s are still working, I think I'll leave those lines / that account alone.

But if I decide to activate any more AT&T lines, I'll be safe and use a new account for each.
 
It seems FreedomPop deleted payment information on all the accounts/lines I manage.
(I only have one line per account. In November, I already made sure each line has a unique credit card number.)

.

After reading this post, I decided to check my 2 FP accts. One GSMT and one GSMA on separate emails.

The GSMT renewed automatically on 2/2/24 successfully in Payment History with "Recurring renewal F000FPGTr event. Status:Success Code:1" but after logging it, it says "suspended" on top with next renewal date of 3/2/24

When I go to "Manage your Lines" and click on "Make a Payment" it takes me to "Auto Pay $0.00" and when I click Subscribe, it takes me to payment details but after entering in CC number, it gives me error, "Internal Error, account is missing! "

Tried various CC and same error each time. CC email shows attempt of $0.00 charge but still "Internal Error, account is missing"

For now, the GSMA is still active and no messages about suspension. But who know if it will go the same way as GSMT in a few weeks.

Not sure what's going on here. Should I wait until 3/2/24 and see if it actually renews or contact someone at FP?
 
Last edited:
@hapollo8 can you make & receive calls, texts, data? That's what counts.
 
After reading this post, I decided to check my 2 FP accts. One GSMT and one GSMA on separate emails.

The GSMT renewed automatically on 2/2/24 successfully in Payment History with "Recurring renewal F000FPGTr event. Status:Success Code:1" but after logging it, it says "suspended" on top with next renewal date of 3/2/24

When I go to "Manage your Lines" and click on "Make a Payment" it takes me to "Auto Pay $0.00" and when I click Subscribe, it takes me to payment details but after entering in CC number, it gives me error, "Internal Error, account is missing! "

Tried various CC and same error each time. CC email shows attempt of $0.00 charge but still "Internal Error, account is missing"

For now, the GSMA is still active and no messages about suspension. But who know if it will go the same way as GSMT in a few weeks.

Not sure what's going on here. Should I wait until 3/2/24 and see if it actually renews or contact someone at FP?

Suspended usually means the phone # won't have service. Does the phone # currently work, or not? If not, I think you should contact FP.
 
@hapollo8 can you make & receive calls, texts, data? That's what counts.

Suspended usually means the phone # won't have service.


Busy morning today.. so just got the chance to log in again to check status. Now without doing anything since last night, I shows ACTIVE. However, as soon as I logged in, a popup shows "Welcome to Freedompop" along with a banner on top to enter billing information.

Used the same credit card info from last night and it took immediately, showing I am now subscribed to the $0.00 - 30 Day- 300 Minutes, 1000 Messages, 100MB Data plan.


Not sure what happened but going to figure the same people who program TF systems are the same who program FP. Either that or they hire high school interns to program their systems. Any glitch since last night seems fixed. The pop up "welcome to Freedompop" makes it seem like they transferred the back end system or something yesterday.

Guess like everything else TF or FP related, we're good for now or until the next glitch.

As far as testing the phone... can't right now as I loaned it to a family member around New Year when they visited who is currently away on business and don't have the phone with them.

As another data point, when I entered various CC info last they all triggered an email from the CC company of $0.00 pending charge. When I updated just 10 mins ago and it took successfully, there was no pending $0.00 email triggered. Go figure.

A part of me now wonders if I didn't read this thread last night would things be the same suspended state today or would I never have noticed anything different with the glitch?
 
Last edited:
Just checked my two FP GSMT accounts. Each line is still active (not suspended) but there was a red prompt that Billing Information Is Required. I reentered the cc info that was in the account before and everything is fine again. It did require me to use a different cc for each account.
 

Attachments

  • Freedompop-Renewal-1.jpg
    Freedompop-Renewal-1.jpg
    38.2 KB · Views: 101
  • Freedompop-Renewal-2.jpg
    Freedompop-Renewal-2.jpg
    36.6 KB · Views: 106
  • Freedompop-Renewal-3.jpg
    Freedompop-Renewal-3.jpg
    28 KB · Views: 100
  • Freedompop-Renewal-4.jpg
    Freedompop-Renewal-4.jpg
    47 KB · Views: 109
As another data point, after entering a new credit card, nothing shows up in payment history and renewal date did not change from original 3/2/24, so slightly different than andyk88 where things seems to have changed where renewal date shifted.
 
Hpham, I poked around a bit earlier and couldn’t figure out how to enter/re-enter my credit card info. I’m pretty sure I never figured out how to get to your “success” screen shot. Any tips or suggestions?
 
Hpham, I poked around a bit earlier and couldn’t figure out how to enter/re-enter my credit card info. I’m pretty sure I never figured out how to get to your “success” screen shot. Any tips or suggestions?

On the screen where you enter billing name and address, there's a grayed out tiny icon of a credit card. Click on the right of that icon and it'll open up the space to enter card numbers.
 
Thanks, I eventually found it. I'm pretty sure it was "Make a Payment" -> "Subscribe" -> Enter payment deals in the grayed out CC field.

In the "Subscribe" step it showed the plan details with 300 mins/1000 msg/100 MB for $0.00.

Clear as mud!
 
Thanks to all who contributed to this thread. My single GSMT line was affected and my experience was similar to that described by @hpham in his screen captures. I entered the same CC info and I no longer see the message in red and the renewal date is unchanged.
 
My Target GSMA 100/100/100 account got suspended a few days ago. I chatted with a CSR, and was told the account was reactivated. Unfortunately, it turned out it wasn't when I checked later. I chatted again today. I went to "make a payment", next page said my account was active, then hit "cancel", hit "subscribe", re-entered payment info, ticked the box agreeing to TOS, and entered. Then, my account was active again.
 
Last edited:
As posted in post #8 above, I updated payment info in my two FP GSMT accounts on 2/13/24 and they seemed to be OK. Today 2/22/24 I found out one of the accounts was suspended again on 2/20/24 when it tried to Auto Renewed. I tried to enter the payment info as I did before, but after submitting the card info I kept getting this error message ""Error. You passed an empty string for 'customer'. We assume empty values are an attempt to unset a parameter; however 'customer' cannot be unset. You should remove 'customer' from your request or supply a non-empty value".

I worked with a Chat agent named Sonia. She had me try different browers, in Incognito mode, etc. but that made no difference. Finally, she told me to Cancel Auto Renew, which placed the line in Inactive status. That triggered a slightly different box to enter payment info which was accepted without error. Then I re-enrolled in the FREE plane and the line is working again.
 
Last edited:
"Error. You passed an empty string for 'customer'. We assume empty values are an attempt to unset a parameter; however 'customer' cannot be unset. You should remove 'customer' from your request or supply a non-empty value".

How DARE you! Lol! Such a meaningful message for a customer to see! Good job, FP! 🙄

I had that same situation on 2/20, and same error when I tried to remedy it. On 2/21, I decided to do what the FP CSR told you, and it also worked for me.

You'd think FP was related to TF! Maybe they share IT personnel? Lol!
 
No issues YET since re-entering the purged payment info. Plan is set to autorenew on Sunday. Will see if it encounters the same issue as hpham above.

Guess FP even after the sale to RP, they're back to their old tactics OR hired the same programmers as TF.
 
I went through the cancel/subscribe process, but my line still showed as canceled. I did it a second time but logged out and back in after canceling, and used a different credit card; that worked. We'll see for how long.
 
As posted in post #8 above, I updated payment info in my two FP GSMT accounts on 2/13/24 and they seemed to be OK. Today 2/22/24 I found out one of the accounts was suspended again on 2/20/24 when it tried to Auto Renewed. I tried to enter the payment info as I did before, but after submitting the card info I kept getting this error message ""Error. You passed an empty string for 'customer'. We assume empty values are an attempt to unset a parameter; however 'customer' cannot be unset. You should remove 'customer' from your request or supply a non-empty value".

I worked with a Chat agent named Sonia. She had me try different browers, in Incognito mode, etc. but that made no difference. Finally, she told me to Cancel Auto Renew, which placed the line in Inactive status. That triggered a slightly different box to enter payment info which was accepted without error. Then I re-enrolled in the FREE plane and the line is working again.

I'm getting this same glitch, and also seeing the "Error. You passed an empty string for 'customer'" message.

You say the CSR told you to "Cancel Auto Renew." I can't find that option/wording anywhere. Where do you see it? Or, is it the same as/do you mean the "Cancel recurring Subscription" button?
 
You say the CSR told you to "Cancel Auto Renew." I can't find that option/wording anywhere. Where do you see it? Or, is it the same as/do you mean the "Cancel recurring Subscription" button?

I just looked at the chat transcript and the rep was using "Cancel Auto Renew" and "Cancel Auto-refill Subscription" interchangeably. After I did the cancellation, I reported that "Automatic Payment now shows Inactive".
 
Back
Top