t-mobile hotspot fails with unlocked Samsung S3

school-tech

New member
HoFo Member
Joined
Dec 1, 2015
Messages
2
I bought a used unlocked GSM Samsung S3. I like it very much, everything works well except for one thing: I cannot make any hotspot app work. I get the message "Mobile data is not available or invalid SIM." I have googled this message and it seems to be related to the fact that the phone was originally an AT&T phone, not a t-mobile phone. So even though it is unlocked, something is still locked to AT&T. I went to a t-mobile store and they told me to buy a new phone! I'd appreciate any advice. I do not want to root my phone.
 
Are you hotspotting within the official terms of your plan, or are you trying to bypass T Mobile's restrictions?
Which hotspotting apps have you tried?
What have you got against rooting?
 
Are you hotspotting within the official terms of your plan, or are you trying to bypass T Mobile's restrictions?
Which hotspotting apps have you tried?
What have you got against rooting?

1. Within official terms of plan. On my old phone (HTC-One) on the same plan, t-mobile hotspot worked fine.
2. In addition to t-mobile hotspot, I tried FoxFi, HotSpot widget, OpenGarden, Wifi Hotspot tether.
3. If I knew for sure that rooting would work, I'd do it. But rooting is complicated for a naive user like myself.

thanks.
 
I bought a used unlocked GSM Samsung S3. I like it very much, everything works well except for one thing: I cannot make any hotspot app work. I get the message "Mobile data is not available or invalid SIM." I have googled this message and it seems to be related to the fact that the phone was originally an AT&T phone, not a t-mobile phone. So even though it is unlocked, something is still locked to AT&T. I went to a t-mobile store and they told me to buy a new phone! I'd appreciate any advice. I do not want to root my phone.

Most Hotspot issues I have encountered are due to incorrect APN settings.

Here is T Mobile APN Settings. Also Make sure you input the apn type correctly that can cause issues with the hotspot as well.

Name: T-Mobile
APN: fast.t-mobile.com
Proxy: <Not set>
Port: <Not set>
Username: <Not set>
Password: <Not set>
Server: <Not set>
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS proxy: <Not set>
MMS port: <Not set>
MMS protocol: WAP 2.0
MCC: 310
MNC: 260
Authentication type: <Not set>
APN type: default,supl,admin,dun,mms
 
Back
Top