V9M and MAC OS X

hhuser

New member
HoFo Member
Joined
Sep 26, 2005
Messages
15
I've been able to get the phone to communicate through bluetooth. Transfer of files has been great! I used the iSync file provided at the below URL to be able to sync contacts (not calendar, however). The only other thing on my list of NEEDS is DUN over bluetooth.

Anyone been successful at getting it to work? It seems that when I add the v9m as a device in my Bluetooth Settings, it finds it ok and pairs fine , However, says that it could not find any services associated with the phone. I'm curious as to how this could be and if there are any known ways to get this thing working.

If I could just get this work, I'd say this phone is just as good for me as the E815!...

Any other MAC related tips?

http://codewhomp.com/v9m-resources.html
 
Find and follow the iSync plugin edits / hacks for the Maxx.

I had a Maxx phone for about a week before I got my v9m. I had to add and modify this file (RAZRV6.phoneplugin) in my /Library/PhonePlugins to get DUN working on my Maxx. When I got the v9m, it just worked ... I believe b/c of my work to get the Maxx to work. Here is whats listed for my v9m:

Device Name: Motorola Phone

Device Address: xx-xx-xx-xx-xx-xx
Device Type: Phone
Device Services: A2DP Source, AVRCP Target, OBEX Push Transfer, OBEX File Transfer, Dial-Up Networking Gateway, Headset Voice Gateway, Handsfree Voice Gateway

Paired: Yes
Configured: Yes
Favorite: Yes
Connected: No
Serial Port: Yes

HERE is where I got the plugin. I forget exactly how I got it to work. Give it a try maybe someone else can help out.
 
V9m and iSync

I got iSync to sync contacts and the calendar with the v9m. The only strange thing is that you can't get them to sync at the same time. However, you can do each separately. A little annoying, but not that bad. Here's the code snippet I dropped into the plist.

<!--
insert this in the /Applications/iSync.app/Contents/PlugIns/ApplePhoneConduit.syncdevice/Contents/PlugIns/PhoneModelsSync.phoneplugin/Contents/Resources/MetaClasses.plist
file (under the top-level <dict> element)
-->
<key>com.motorola.razorv9m</key>
<dict>
<key>Identification</key>
<dict>
<key>com.apple.gmi+gmm</key>
<string>Motorola CE, Copyright 2000+Motorola CDMA V9m Phone</string>
</dict>
<key>InheritsFrom</key>
<array>
<string>com.motorola.usb-bt.0x22B8/0x4902</string>
</array>
<key>Services</key>
<array>
<dict>
<key>ServiceName</key>
<string>com.apple.model</string>
<key>ServiceProperties</key>
<dict>
<key>ModelName</key>
<string>RAZR V9m</string>
<key>PhoneIcon</key>
<string>MOTV3-black.tiff</string>
</dict>
</dict>
</array>
</dict>
 
peripheral, if you were a woman and were with me now, I would kiss you!... my isync and bluetooth work wonderfully now.... its official for me... this phone does everything my e815 did that I need and in a much more attractive package...

Now another question... When I connected my e815 to the internet through bluetooth dun, it only charged me minutes.. Came in useful when I was in a hotel that charged 20 bucks a day for internet.... will this be the same way? Anyone know? I only have the regular 40 dollar americas choice voice plan... has anything changed?
 
You have two options to make that work again.

1. Disable EVDO so the phone is forced into 1XRTT mode. (No software or USB cable required)
2. Hack the phone to change your NAI from "@dun.vzw3g.com" to "@vzw3g.com" This will allow you to use the faster EVDO network. (USB cable and software required)

On my v9m, I was able to get EVDO disabled via test mode and get online the way you mention. You'll just be charged minutes as you were previously. This is still technically not allowed with Verizon, but if you don't abuse it you should be fine. I only use it when traveling and in hotels that charge for access like
you said.

Here is a thread that details how to disable EVDO: (Mark's site is full of information)
http://mark.cdmaforums.com/DisableEVDO-V3C.htm

Here is a thread that details doing the NAI change: http://www.howardforums.com/showthread.php?t=938352

and another: http://www.howardforums.com/showthread.php?t=1018585
 
I put together an isync plugin as an alternative to editing the isync plist. Just drop the folder into your user library. It works for both contacts and calendars.

Download here V9m insync plugin
 
iSync and EVDO tethering via Bluetooth worked flawlessly for me for several weeks. Now my MacBook no longer recognizes my V9m for either iSync or DUN. In the past when Bluetooth broke I was able to delete the device in the Bluetooth Preferences and re-pair the phone and all worked again. Now when I add the device my MacBook does not find either service (iSync or DUN) on the phone. I tried deleting the Bluetooth plist through terminal and doing a Master Clear on the phone. Any other troubleshooting tips?
 
iSync and DUN are working fine via USB cable, it's just Bluetooth that's broken. Any ideas for troubleshooting Bluetooth?
 
Last edited:
Fixed. All it took was a Master Clear.
 
try command-s next time it happens

madadam, wierd as life is, literally i had run into the same problem you were experiencing though have an E815 & MacBook Pro... either way, i was able to Dun & iSync nicely via BT then "poof"... i hadn't restarted the laptop in a few weeks and the E815 as well.... so, i repaired permissions, rebooted the mac, at chime held down Command + S (did "fsck -fy" - exit/reboot), and restarted the phone... and voila all repaired simply.
good luck, hope this helps

Thanks for your plug-in, as i'm getting the Moto V6tv and heard it'll work fine w/this fone.
peace
 
hghlndr said:
i repaired permissions, rebooted the mac, at chime held down Command + S (did "fsck -fy" - exit/reboot), and restarted the phone... and voila all repaired simply.
Restarting the computer and phone has worked for me in the past. This time I could not re-pair until I did a Master Clear on the phone. First I mistakenly did a Master Reset, which did not help. When I finally did the Master Clear I was able to re-pair no problem.
 
USB cable, isync and other BT software

Hey guys!
i just got the Moto Z6tv and the reason i'm posting in this thread is i've gotten good info here about isync, since it looks like the V9m & Z6tv have similar software. - I'll be putting those mods/plugins to good use tonite! Thanks.
Questions
1. Any drivers found to work for the USB cable to mac? If so, any mac user able to have the computer "see" the connnection in Network config? Either, my old drivers for the E815 aren't compatible or the cable i'm using doesn't work.
2. Any mac user purchase VZW's connect pack w/moto cable and it work out of the box w/their V9m?
3. I used pacifist & pulled this extension from the contents of VZ Access Manager: SMSIWirelessUSB.kext Would this work to find the USB cable if i dropped it in the extensions folder?
5. Finally anyone using OnSync or BluePhoneElite2 w/their V9m? No luck w/my the V6tv.
Hope these aren't too many questions, and if they are, at least it spurs discussion on possibilities to further enhance your phones.
Peace.
PS: MacBookPro C2D 2.33 10.4.10
 
Update

I used this driver: SMSIWirelessUSB.kext ,(from VZaccess/V9m), i found, and my non-moto USB cable charges the Z6tv and tethers perfectly!
In case any of you Use Onsync - it'll work w/cable, not BT as of yet.
As for BPE2, it'll connect though none of the services are of any use... until the software gets upgraded.
There's another thread in the Moto forums re iSync & the Z6tv so i'll be discussing my difficulties there....
Thanks Madadam for your support!
Peace
 
Isync stopped working

madadam said:
Restarting the computer and phone has worked for me in the past. This time I could not re-pair until I did a Master Clear on the phone. First I mistakenly did a Master Reset, which did not help. When I finally did the Master Clear I was able to re-pair no problem.

I had iSync working with my Verizonv9m by editing the metaclasses.plist file as referenced in an earlier post. Then it stopped syncing and after trying almost every suggestion on various forums, iSync also stopped working. After reinstalling tiger (now 10.4.10), iSync runs however it still doesn't work with the v9m and the modified metaclasses file that worked previously. I have recently tried the v9m plugin in my user library (with the original metaclasses file) without success. Each time I pair the v9m, I get the message "There were no supported services found on your phone." and iSync says unsupported device. I've done the reboots and permission repairs with the same results. How do you do a "master clear" on the v9m? Any other suggestions?
 
Here are instructions for doing a master clear. You may also want to restore iSync's metaclasses.plist and try the plug-in.

HOW TO CLEAR OR RESET THE V9M USING TEST MODE
Enable Test mode...
#073887*
for security code enter 000000
press OK.
arrow down to test mode...
press right soft menu key to select.
Highlight Enabled and press select.
Press and hold END to exit out and power off...

Power the phone on... You will be brought to a white screen with a "blue" FTS in the top center.

When in test mode... on the OS Featr Opt page... is Master Reset and Master Clear (last items, seen as Mstr Clr/Reset. Select that, then can pick either.... It doesn't warn you or ask you to confirm...

Press the CLR key quickly followed by the left soft menu key to exit.

Disable Test Mode...
#073887*
for security code enter 000000
press OK.
arrow down to test mode...
press select.
Highlight DISABLE and press select.
Press END to exit out of all...
 
Peripheral's Script worked perfectly and I was able to use isync to sync both calendar and contacts on my V9M. I just upgraded to Leopard, inserted the code but it doesn't work - any ideas??
Thanks
 
Try the plug-in. Just drop the folder into your user library.

Download it HERE
 
V9M and Leopard

Thanks for the suggestion but it's still not working. iSync says it can't locate the plug-in. I dropped it in the library, in phone within library without success. I'm new to MAC so it's quite possible I'm doing something wrong. I also have the script I used in Tiger in the metaClasses.plist, I could be shooting myself in the foot.
 
I don't have Leopard, and don't know whether this has changed, but in Tiger the plug-in (MOTRAZRV9m.phoneplugin) should be placed in a folder called "PhonePlugins" in the user library. If there is no "PhonePlugins" folder then create one. I suggest trying the plugin with a clean version of the metaclasses.plist. Also, delete your phone in Bluetooth set up and re-pair it. Good luck.
 
MADADAM - Thanks, I'm back in business. I re-installed Leopard to start clean, then, as you suggested, deleted the V9M from Bluetooth. I had to create a 'PhonePlugins' folder in my library, dropped your plugin re-paired the phone and Bingo - as was well again.

Thanks again!
 
Back
Top