wifi calling enabled can prevent phone to receive any calls

joseg2016

Member
ToTW Winner
HoFo Member
Joined
Apr 23, 2016
Messages
872
I would not have guessed. Possible that wifi-calling being enabled on android mobile device can prevent the device receiving incoming calls.

Struggle it was to find where in Settings to check on wifi-calling and then to disable it; and then I made a test call to the device and the device successfully detected and indicated a incoming call happening.

That's the short story. Why, how? I am interested to know.
 
What phone carrier were you on?

What version of Android was the Motorola E6 on? I think the location of the settings and the terminology has changed as new versions have been introduced. Your issue might or might not be specific to your phone.

Sent from my Pixel 6a using HoFo mobile app
 
Last edited:
What's your wifi calling preference set to. "WiFi preferred" or "Mobile preferred" ?

If Mobile your phone will ring. From what I understand, if Wifi preferred the phone won't ring unless you're in an area with no cell coverage.

On my Moto E6 os 9 on Tello.
Settings>Network and Internet>Mobile network>Advanced>WiFi calling>Calling preference. Wifi calling must be on to get to that menu.
 
What phone carrier were you on?

What version of Android was the Motorola E6 on? I think the location of the settings and the terminology has changed as new versions have been introduced. Your issue might or might not be specific to your phone.

Sent from my Pixel 6a using HoFo mobile app
US Mobile, using the T-Mobile network;
My MotoE6 is on android version 9.


@rpz1,
I will go back and try to look through those settings later. Finding what I did find a few hours ago was a chore.
I hope I'll be able to find the setting you ask about without using the search feature within Settings.
 
You may or may not want to consider upgrading to a newer phone with newer version of Android. Not that the Motorola E6 is incapable but newer phones may or may not behave differently.

I can only lend you my experience which may or may not be applicable. I had a couple of umidigi phones on Android 9 with redpocket Verizon that got volte(they called it HD Voice) but wifi calling was either not available or disabled. Wifi calling was available and working on the same phone when using T-mobile-had an additional menu item only seen with the T-mobile sim installed.

On one of the red pocket Verizon accounts, I moved it to a Verizon unlocked Motorola Ace 5G UW and with no additional changes or jumping through hoops, Wi-Fi calling is enabled. It's on Android 11 now 12. The menus and options did change when it upgraded.

Sent from my motorola one 5G UW ace using HoFo mobile app
 
US Mobile, using the T-Mobile network;
My MotoE6 is on android version 9.


@rpz1,
I will go back and try to look through those settings later. Finding what I did find a few hours ago was a chore.
I hope I'll be able to find the setting you ask about without using the search feature within Settings.

Just use the string I gave, easy to find.
Settings>Network and Internet>Mobile network>Advanced>WiFi calling>Calling preference. Note when you turn on wifi calling the preferences section will be shown. 10 seconds.
Sounds like that setting is your issue. I had my E6 on US Mobile using T-Mobile at one time too. Wifi calling worked fine.
Wouldn't work with Vzw though.
 
Just use the string I gave, easy to find.
Settings>Network and Internet>Mobile network>Advanced>WiFi calling>Calling preference. Note when you turn on wifi calling the preferences section will be shown. 10 seconds.
Sounds like that setting is your issue. I had my E6 on US Mobile using T-Mobile at one time too. Wifi calling worked fine.
Wouldn't work with Vzw though.

I'm starting to look through that setting. Wifi is currently turned off. I am comfortable this way; but I am guessing you want I should turn it ON, and see what it shows.

---
 
There maybe what you asked. If turn on wifi calling, the note says "wifi preferneces; wifi preferred".

I then disabled wifi calling. (turned if off, again)
 
There maybe what you asked. If turn on wifi calling, the note says "wifi preferneces; wifi preferred".

I then disabled wifi calling. (turned if off, again)

With wifi calling on, if you touch the screen where it now says "wifi preferences; wifi preferred" another screen will come up where you can select "Mobil preferred". With "Mobile preferred" selected your phone will ring when you get a call even with wifi calling on.
You can only make an outgoing call on wifi calling if you're in an area with no mobile signal(service).

If you just want to keep Wifi calling off unless you want to use it fine.
Was just answering your original question why your phone wasn't ringing with wifi calling on and if the preference was WiFi preferred vs Mobile preferred. Nothing wrong with the phone or network.
 
rpz1, post #11 is thorough details. I will need to read that post a few more times. Also will later need to play with the settings there and see what the information looks like.

As much as I am aware, I have never used wifi calling.
 
Back
Top